mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/matplotlib: Re-added and updated to 0.99.1.2.
This commit is contained in:
parent
3d26ebd3ff
commit
e32ff21dde
5 changed files with 111 additions and 0 deletions
7
libraries/matplotlib/README
Normal file
7
libraries/matplotlib/README
Normal file
|
@ -0,0 +1,7 @@
|
|||
Matplotlib strives to produce publication quality 2D graphics for
|
||||
interactive graphing, scientific publishing, user interface
|
||||
development and web application servers targeting multiple user
|
||||
interfaces and hardcopy output formats. There is a 'pylab' mode which
|
||||
emulates matlab graphics
|
||||
|
||||
This requires numpy.
|
12
libraries/matplotlib/libpng-1.4.patch
Normal file
12
libraries/matplotlib/libpng-1.4.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur matplotlib-0.99.1.1-orig/src/_png.cpp matplotlib-0.99.1.1/src/_png.cpp
|
||||
--- matplotlib-0.99.1.1-orig/src/_png.cpp 2010-01-25 01:42:32.000000000 -0500
|
||||
+++ matplotlib-0.99.1.1/src/_png.cpp 2010-01-25 01:43:17.000000000 -0500
|
||||
@@ -290,7 +290,7 @@
|
||||
|
||||
//free the png memory
|
||||
png_read_end(png_ptr, info_ptr);
|
||||
- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
|
||||
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
|
||||
fclose(fp);
|
||||
for (row = 0; row < height; row++)
|
||||
delete [] row_pointers[row];
|
63
libraries/matplotlib/matplotlib.SlackBuild
Normal file
63
libraries/matplotlib/matplotlib.SlackBuild
Normal file
|
@ -0,0 +1,63 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for matplotlib
|
||||
|
||||
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
|
||||
# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
|
||||
# Patch for libpng borrowed from Arch Linux
|
||||
|
||||
PRGNAM=matplotlib
|
||||
VERSION=${VERSION:-0.99.1.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=${PKG:-$TMP/package-$PRGNAM}
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$TARBALL_VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$TARBALL_VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/libpng-1.4.patch
|
||||
|
||||
python setup.py install --root $PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
install -m 0644 \
|
||||
CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
libraries/matplotlib/matplotlib.info
Normal file
10
libraries/matplotlib/matplotlib.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="matplotlib"
|
||||
VERSION="0.99.1.2"
|
||||
HOMEPAGE="http://matplotlib.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.99.1.2.tar.gz"
|
||||
MD5SUM="952e2c992e4a762b8538171f51c9140a"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="João Felipe Santos"
|
||||
EMAIL="joao.eel@gmail.com"
|
||||
APPROVED="rworkman"
|
19
libraries/matplotlib/slack-desc
Normal file
19
libraries/matplotlib/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler--------------------------------------------------|
|
||||
matplotlib: matplotlib (a Python 2D plotting library)
|
||||
matplotlib:
|
||||
matplotlib: Matplotlib is a plotting library for Python which uses
|
||||
matplotlib: syntax similar to MATLAB. Matplotlib produces publication
|
||||
matplotlib: quality figures in a variety of hardcopy formats and
|
||||
matplotlib: interactive environments across platforms.
|
||||
matplotlib:
|
||||
matplotlib: Homepage: http://matplotlib.sourceforge.net/
|
||||
matplotlib:
|
||||
matplotlib:
|
||||
matplotlib:
|
Loading…
Reference in a new issue