mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
network/uTox: Updated for version 078fbf8d1a4e.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
73358011e0
commit
de19d09532
4 changed files with 24 additions and 9 deletions
|
@ -1 +1,5 @@
|
|||
Lightweight Tox client that uses Xlib. Supports many features and is on-par with other Tox clients.
|
||||
|
||||
By default, it builds with GTK2. If you want to build with GTK3 support, do:
|
||||
|
||||
GTK3=YES ./uTox.Slackbuild
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- uTox-0.4.5/Makefile 2015-12-09 16:56:06.000000000 -0700
|
||||
+++ uTox-0.4.5-fix/Makefile 2015-12-13 06:28:47.453261588 -0700
|
||||
@@ -104,8 +104,8 @@
|
||||
--- uTox-0.5.0/Makefile 2015-12-20 00:57:28.000000000 -0700
|
||||
+++ uTox-0.5.0-fix/Makefile 2015-12-24 10:57:21.787213435 -0700
|
||||
@@ -127,8 +127,8 @@
|
||||
install -m 644 utox.desktop $(DESTDIR)$(PREFIX)/share/applications/utox.desktop
|
||||
if [ "$(UNITY)" -eq "1" ]; then echo "X-MessagingMenu-UsesChatSection=true" >> $(DESTDIR)$(PREFIX)/share/applications/utox.desktop; fi
|
||||
|
||||
|
@ -9,5 +9,5 @@
|
|||
+ mkdir -p $(DESTDIR)$(PREFIX)/man/man1
|
||||
+ install -m 644 utox.1 $(DESTDIR)$(PREFIX)/man/man1/utox.1
|
||||
|
||||
main.o: xlib/main.c xlib/keysym2ucs.c
|
||||
|
||||
$(OBJ): %.o: %.c $(HEADERS)
|
||||
@echo " CC $@"
|
||||
|
|
|
@ -5,6 +5,9 @@
|
|||
# Copyright 2015 Gethyn ThomasQuail <gethyn@bloodbathsoftworks.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Tiny bit of shell from:
|
||||
# Wine SlackBuild by David Woodfall Copyright 2011
|
||||
#
|
||||
# Permission to use, copy, modify, and/or distribute this software for any
|
||||
# purpose with or without fee is hereby granted, provided that the above
|
||||
# copyright notice and this permission notice appear in all copies.
|
||||
|
@ -18,7 +21,7 @@
|
|||
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
||||
|
||||
PRGNAM=uTox
|
||||
VERSION=${VERSION:-0.4.5}
|
||||
VERSION=${VERSION:-0.5.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -64,8 +67,16 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fixes man install directory
|
||||
patch -p1 < $CWD/locationfix.diff
|
||||
|
||||
# Build with GTK2 by default
|
||||
GTK3=${GTK3:-NO}
|
||||
|
||||
if [ "$GTK3" = "NO" ]; then
|
||||
patch -p1 < $CWD/gtk2.diff
|
||||
fi
|
||||
|
||||
make
|
||||
make DESTDIR=$PKG \
|
||||
PREFIX=/usr \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="uTox"
|
||||
VERSION="0.4.5"
|
||||
VERSION="0.5.0"
|
||||
HOMEPAGE="https://github.com/GrayHatter/utox"
|
||||
DOWNLOAD="https://github.com/GrayHatter/uTox/archive/v0.4.5.tar.gz"
|
||||
MD5SUM="be36aeebaf39cb8da927d8cefe3460cb"
|
||||
DOWNLOAD="https://github.com/GrayHatter/uTox/archive/v0.5.0.tar.gz"
|
||||
MD5SUM="de906e2a5dad1b1da0465462429bb037"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="toxcore libfilteraudio"
|
||||
|
|
Loading…
Reference in a new issue