games/pinball: Add more patch.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Alexander Verbovetsky 2019-11-01 07:41:10 +07:00 committed by Willy Sudiarto Raharjo
parent 73a6854775
commit dd3a27e0bd
2 changed files with 35 additions and 5 deletions

View file

@ -0,0 +1,22 @@
From c20e9bb1fbf1175b76522e85d04ff7df96beaf51 Mon Sep 17 00:00:00 2001
From: orbea <orbea@riseup.net>
Date: Sun, 27 Oct 2019 11:07:18 -0700
Subject: [PATCH] Fix build issue with gettext-0.20.
*** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.19 but the autoconf macros are from gettext version 0.20
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index c6e1dcb..746c768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,7 @@ AM_GNU_GETTEXT([external])
#For rhel6 but rhel6 doesn't have SDL2
#AM_GNU_GETTEXT_VERSION(0.17)
AM_GNU_GETTEXT_VERSION(0.19.8)
+AM_GNU_GETTEXT_REQUIRE_VERSION([0.19.8])
dnl this is a c++ program
dnl CFLAGS="-g -W -Wall -O2"

View file

@ -2,7 +2,7 @@
# Slackware build script for pinball
# Copyright 2015-2016, 2018 Hunter Sezen California, USA
# Copyright 2015-2016, 2018-2019 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,7 +24,7 @@
PRGNAM=pinball
VERSION=${VERSION:-0.3.4}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -69,9 +69,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Use a sys version of ltdl
# https://github.com/sergiomb2/pinball/pull/23
# https://github.com/sergiomb2/pinball/commit/e3ac2b6addf31cb350f572e24794ef9f9535d566
patch -p1 < $CWD/pinball-0.3.4-sys-ltdl.patch
# Fix build issue with gettext-0.20.
# https://github.com/sergiomb2/pinball/pull/30
patch -p1 < $CWD/gettext-version.patch
autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@ -87,11 +95,11 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL License.txt README \
cp -a AUTHORS COPYING ChangeLog License.txt README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild