mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
graphics/k3d: Patched for new gtkmm
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
3ae0a9d4fb
commit
dcec8fbaf3
2 changed files with 45 additions and 2 deletions
|
@ -5,11 +5,11 @@
|
|||
|
||||
# Written by Niels Horn <niels.horn@gmail.com>
|
||||
# (based on a script by Larry Hajali)
|
||||
# Revision date: 2010/07/14
|
||||
# Revision date: 2011/05/01
|
||||
|
||||
PRGNAM=k3d
|
||||
VERSION=${VERSION:-0.8.0.2}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -57,6 +57,9 @@ find . \
|
|||
# Patch code for new libpng
|
||||
patch -p1 < $CWD/png14.patch
|
||||
|
||||
# Patch code for gtkmm-2.24
|
||||
patch -p1 < $CWD/k3d_gtkmm224.patch
|
||||
|
||||
# Fix man install directory.
|
||||
sed -i "s|share/man|man|" man/CMakeLists.txt
|
||||
|
||||
|
|
40
graphics/k3d/k3d_gtkmm224.patch
Normal file
40
graphics/k3d/k3d_gtkmm224.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- k3d-source-0.8.0.2/k3dsdk/ngui/main_document_window.cpp 2010-07-02 23:27:46.000000000 -0300
|
||||
+++ k3d-source-0.8.0.2_patched/k3dsdk/ngui/main_document_window.cpp 2011-05-01 22:24:14.000000000 -0300
|
||||
@@ -1371,7 +1371,7 @@
|
||||
Gtk::HBox import_box(false, 5);
|
||||
Gtk::Label import_label(_("Choose import plugin:"));
|
||||
|
||||
- Gtk::ComboBox import_combo(model);
|
||||
+ Gtk::ComboBox import_combo((Glib::RefPtr<Gtk::TreeModel> &) model);
|
||||
import_combo.pack_start(columns.icon, false);
|
||||
import_combo.pack_start(columns.label);
|
||||
import_combo.set_active(0);
|
||||
@@ -1461,7 +1461,7 @@
|
||||
Gtk::HBox export_box(false, 5);
|
||||
Gtk::Label export_label(_("Choose export plugin:"));
|
||||
|
||||
- Gtk::ComboBox export_combo(model);
|
||||
+ Gtk::ComboBox export_combo((Glib::RefPtr<Gtk::TreeModel> &) model);
|
||||
export_combo.pack_start(columns.icon, false);
|
||||
export_combo.pack_start(columns.label);
|
||||
export_combo.set_active(0);
|
||||
--- k3d-source-0.8.0.2/k3dsdk/ngui/render.cpp 2010-07-02 23:27:46.000000000 -0300
|
||||
+++ k3d-source-0.8.0.2_patched/k3dsdk/ngui/render.cpp 2011-05-01 22:41:08.000000000 -0300
|
||||
@@ -169,7 +169,7 @@
|
||||
row[columns.separator] = false;
|
||||
}
|
||||
|
||||
- Gtk::ComboBox combo(model);
|
||||
+ Gtk::ComboBox combo((Glib::RefPtr<Gtk::TreeModel> &) model);
|
||||
|
||||
combo.pack_start(columns.icon, false);
|
||||
|
||||
@@ -295,7 +295,7 @@
|
||||
row[columns.separator] = false;
|
||||
}
|
||||
|
||||
- Gtk::ComboBox combo(model);
|
||||
+ Gtk::ComboBox combo((Glib::RefPtr<Gtk::TreeModel> &) model);
|
||||
|
||||
combo.pack_start(columns.icon, false);
|
||||
|
Loading…
Reference in a new issue