mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
academic/easy_spice: Added (A Simple Frontend for SPICE).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
67009d3f21
commit
dcc7ebdb46
8 changed files with 210 additions and 0 deletions
18
academic/easy_spice/01_docurl.diff
Normal file
18
academic/easy_spice/01_docurl.diff
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- easyspice-0.6.8.orig/src/util.c
|
||||
+++ easyspice-0.6.8/src/util.c
|
||||
@@ -655,12 +655,12 @@
|
||||
void
|
||||
commands_set_default(ExternalProgramms *prog)
|
||||
{
|
||||
- prog->editor=update_str(prog->editor, "xemacs");
|
||||
+ prog->editor=update_str(prog->editor, "sensible-editor");
|
||||
prog->plot_command=update_str(prog->plot_command, "ngspice");
|
||||
prog->spice_command=update_str(prog->spice_command, "ngspice");
|
||||
- prog->browser=update_str(prog->browser, "firefox");
|
||||
+ prog->browser=update_str(prog->browser, "sensible-browser");
|
||||
prog->html_files=update_str(prog->html_files,
|
||||
- "file:///usr/local/doc/spice/index.html");
|
||||
+ "http://ngspice.sourceforge.net/docs.html");
|
||||
prog->spicehelp_command=update_str(prog->spicehelp_command, "nghelp");
|
||||
}
|
||||
|
2
academic/easy_spice/README
Normal file
2
academic/easy_spice/README
Normal file
|
@ -0,0 +1,2 @@
|
|||
EasySpice is a simple to use spice frontend.
|
||||
It uses gschem for schematic entry and ngspice as circuit simulator.
|
9
academic/easy_spice/doinst.sh
Normal file
9
academic/easy_spice/doinst.sh
Normal file
|
@ -0,0 +1,9 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
121
academic/easy_spice/easy_spice.SlackBuild
Normal file
121
academic/easy_spice/easy_spice.SlackBuild
Normal file
|
@ -0,0 +1,121 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for easy_spice
|
||||
|
||||
# Copyright 2017 R. S. Ananda Murthy, Mysore, India
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=easy_spice
|
||||
VERSION=${VERSION:-0.6.8}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/01_docurl.diff
|
||||
patch -p1 < $CWD/libm_underlinkage.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--build=$ARCH-slackware-linux \
|
||||
--with-tclconfig=/usr/lib${LIBDIRSUFFIX}
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS NEWS COPYING README TODO INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat $CWD/01_docurl.diff > $PKG/usr/doc/$PRGNAM-$VERSION/01_docurl.diff
|
||||
cat $CWD/libm_underlinkage.patch > $PKG/usr/doc/$PRGNAM-$VERSION/libm_underlinkage.patch
|
||||
cp $CWD/$PRGNAM.png $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.png
|
||||
|
||||
mkdir -p $PKG/usr/share/icons/hicolor/48x48/apps
|
||||
cp $CWD/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
|
||||
chmod -x $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
|
||||
cat <<EOF > $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
[Desktop Entry]
|
||||
Name=easy_spice
|
||||
Comment=A simple frontend to Spice
|
||||
Encoding=UTF-8
|
||||
Type=Application
|
||||
Categories=Education
|
||||
Exec=easy_spice
|
||||
Icon=easy_spice
|
||||
StartupNotify=false
|
||||
EOF
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
|
10
academic/easy_spice/easy_spice.info
Normal file
10
academic/easy_spice/easy_spice.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="easy_spice"
|
||||
VERSION="0.6.8"
|
||||
HOMEPAGE="http://easy-spice.sourceforge.net/index.html"
|
||||
DOWNLOAD="https://downloads.sourceforge.net/project/easy-spice/easy-spice/easy_spice-0.6.8/easy_spice-0.6.8.tar.gz"
|
||||
MD5SUM="6ffaab8c2dcdfc30ecdca52f3c8bcded"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="geda-gaf ngspice"
|
||||
MAINTAINER="R. S. Ananda Murthy"
|
||||
EMAIL="rsamurti@gmail.com"
|
BIN
academic/easy_spice/easy_spice.png
Normal file
BIN
academic/easy_spice/easy_spice.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 667 B |
31
academic/easy_spice/libm_underlinkage.patch
Normal file
31
academic/easy_spice/libm_underlinkage.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
Description: Added missing math lib to link, fixing FTBFS.
|
||||
Author: Daniel T Chen <crimsun@ubuntu.com>
|
||||
Bug-Debian: https://bugs.debian.org/747052
|
||||
Last-Update: 2013-04-11
|
||||
|
||||
Index: easyspice-0.6.8/src/Makefile.am
|
||||
===================================================================
|
||||
--- easyspice-0.6.8.orig/src/Makefile.am 2013-04-11 09:44:23.680002124 -0400
|
||||
+++ easyspice-0.6.8/src/Makefile.am 2013-04-11 09:44:34.571928687 -0400
|
||||
@@ -18,7 +18,7 @@
|
||||
spice.c \
|
||||
util.c
|
||||
|
||||
-easy_spice_LDADD = @PACKAGE_LIBS@ $(INTLLIBS)
|
||||
+easy_spice_LDADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
|
||||
|
||||
localedir = @datadir@/locale
|
||||
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
|
||||
Index: easyspice-0.6.8/src/Makefile.in
|
||||
===================================================================
|
||||
--- easyspice-0.6.8.orig/src/Makefile.in 2013-04-11 09:44:17.416036093 -0400
|
||||
+++ easyspice-0.6.8/src/Makefile.in 2013-04-11 09:44:43.115859927 -0400
|
||||
@@ -181,7 +181,7 @@
|
||||
spice.c \
|
||||
util.c
|
||||
|
||||
-easy_spice_LDADD = @PACKAGE_LIBS@ $(INTLLIBS)
|
||||
+easy_spice_LDADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
|
||||
AM_CFLAGS = -Wall
|
||||
all: all-am
|
||||
|
19
academic/easy_spice/slack-desc
Normal file
19
academic/easy_spice/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
easy_spice: easy_spice (A Simple Frontend for SPICE)
|
||||
easy_spice:
|
||||
easy_spice: easy_spice is a simple to use spice frontend. It uses gschem for
|
||||
easy_spice: schematic entry and ngspice as circuit simulator.
|
||||
easy_spice:
|
||||
easy_spice:
|
||||
easy_spice:
|
||||
easy_spice:
|
||||
easy_spice:
|
||||
easy_spice:
|
||||
easy_spice:
|
Loading…
Reference in a new issue