games/antares: Updated for version 0.9.1.

Signed-off-by: orbea <orbea@riseup.net>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
orbea 2020-08-18 10:01:43 -07:00 committed by Willy Sudiarto Raharjo
parent 3a32ab05d2
commit dbdce6e764
No known key found for this signature in database
GPG key ID: 3F617144D7238786
5 changed files with 39 additions and 75 deletions

View file

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=antares
VERSION=${VERSION:-0.9.0}
VERSION=${VERSION:-0.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -59,20 +59,17 @@ find -L . \
mkdir -p $PKG/usr/share/games/$PRGNAM/downloads
cp $CWD/Ares-1.2.0.zip $PKG/usr/share/games/$PRGNAM/downloads
# Don't connect accessibility bus.
# Don't connect to the accessibility bus.
# https://github.com/arescentral/antares/issues/276
export NO_AT_BRIDGE=1
# Use a system version of gn.
sed -i 's|build/lib/bin/gn|gn|' build/lib/scripts/cfg.py
# gn: Fix build with newer gn versions.
# https://github.com/arescentral/procyon/pull/15
( cd ext/procyon; patch -p1 < $CWD/procyon.patch )
# Makefile: Install the text directory.
# https://github.com/arescentral/antares/pull/307
patch -p1 < $CWD/text.patch
# Revert: Update to python3 (scripts/antares_launcher.py)
# Doesn't work with python3 and removed upstream.
# https://github.com/arescentral/antares/commit/0137f46c58e26352b2ba88cb581974f3f263ba3f
patch -R -p1 < $CWD/python.patch
# configure is a python script
./configure \

View file

@ -1,12 +1,12 @@
PRGNAM="antares"
VERSION="0.9.0"
VERSION="0.9.1"
HOMEPAGE="https://arescentral.org/antares"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
DOWNLOAD_x86_64="http://downloads.arescentral.org/Antares/antares-0.9.0.zip \
http://downloads.arescentral.org/Ares/Ares-1.2.0.zip"
MD5SUM_x86_64="351ae6d76673564b4fe17b56b583a0dc \
b41f52c74f7cad3ff183dabe81bd1cf2"
REQUIRES="OpenAL glfw3 gn libc++ libmodplug"
DOWNLOAD="http://downloads.arescentral.org/Antares/antares-0.9.1.zip \
http://downloads.arescentral.org/Ares/Ares-1.2.0.zip"
MD5SUM="ef44ba09889aef72763212f96989983b \
b41f52c74f7cad3ff183dabe81bd1cf2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="OpenAL glfw3 gn libc++ libmodplug python3"
MAINTAINER="Hunter Sezen"
EMAIL="orbea@riseup.net"

View file

@ -1,32 +0,0 @@
From 42aeba19dbe79c6ebd3e860bff977595577ad90f Mon Sep 17 00:00:00 2001
From: orbea <orbea@riseup.net>
Date: Wed, 8 Jan 2020 12:12:34 -0800
Subject: [PATCH] gn: Fix build with newer gn versions.
---
src/cpp/BUILD.gn | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/cpp/BUILD.gn b/src/cpp/BUILD.gn
index 58da775..b76d236 100644
--- a/src/cpp/BUILD.gn
+++ b/src/cpp/BUILD.gn
@@ -13,7 +13,7 @@
# limitations under the License.
static_library("procyon-cpp") {
- sources = [
+ public = [
"include/pn/arg",
"include/pn/array",
"include/pn/data",
@@ -23,6 +23,9 @@ static_library("procyon-cpp") {
"include/pn/output",
"include/pn/string",
"include/pn/value",
+ ]
+
+ sources = [
"src/array.cpp",
"src/common.hpp",
"src/data.cpp",

View file

@ -0,0 +1,25 @@
From 0137f46c58e26352b2ba88cb581974f3f263ba3f Mon Sep 17 00:00:00 2001
From: Chris Pickel <sfiera@twotaled.com>
Date: Fri, 5 Jun 2020 20:09:00 +0900
Subject: [PATCH] Update to python3
---
scripts/antares_launcher.py | 4 +---
1 files changed, 1 insertions(+), 3 deletions(-)
diff --git a/scripts/antares_launcher.py b/scripts/antares_launcher.py
index d20f343e..fc5e4d32 100755
--- a/scripts/antares_launcher.py
+++ b/scripts/antares_launcher.py
@@ -1,10 +1,8 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (C) 2017 The Antares Authors
# This file is part of Antares, a tactical space combat game.
# Antares is free software, distributed under the LGPL+. See COPYING.
-from __future__ import division, print_function, unicode_literals
-
import gi
import json
import os

View file

@ -1,26 +0,0 @@
From 914ad7b2cd53b8396a6e407c91b63adfc3b18443 Mon Sep 17 00:00:00 2001
From: orbea <orbea@riseup.net>
Date: Wed, 8 Jan 2020 07:42:21 -0800
Subject: [PATCH] Makefile: Install the text directory.
This fixes a crash at the end of the tutorial level.
antares-glfw: text/6000.txt: couldn't find resource "text/6000.txt"
Signed-off-by: orbea <orbea@riseup.net>
---
Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
index 7146731e..7404fb34 100644
--- a/Makefile
+++ b/Makefile
@@ -105,6 +105,7 @@ install-data: build
cp -r data/sounds $(DESTDIR)$(DATADIR)/app
cp -r data/sprites $(DESTDIR)$(DATADIR)/app
cp -r data/strings $(DESTDIR)$(DATADIR)/app
+ cp -r data/text $(DESTDIR)$(DATADIR)/app
.PHONY: install-scenario
install-scenario: build