libraries/lrmi: Added to 12.1 repository

This commit is contained in:
Heinz Wiesinger 2010-05-11 22:54:16 +02:00 committed by David Somero
parent 74c2d01756
commit daf55bef1a
5 changed files with 151 additions and 0 deletions

View file

@ -0,0 +1,38 @@
--- Makefile.orig 2005-12-05 00:33:57.000000000 +0100
+++ lrmi-0.10/Makefile 2008-07-14 15:16:41.206752922 +0200
@@ -1,7 +1,7 @@
-LIBDIR ?= /usr/local/lib
-INCDIR ?= /usr/local/include
+LIBDIR ?= /usr/lib
+INCDIR ?= /usr/include
-CFLAGS = -g -Wall
+CFLAGS += -g -Wall
sources = lrmi.c
objects = lrmi.o
@@ -30,17 +30,16 @@
ln -sf $(LIBNAME).so.$(VERSION) $(LIBNAME).so.$(MAJOR)
ln -sf $(LIBNAME).so.$(MAJOR) $(LIBNAME).so
-vbetest: vbetest.c liblrmi.a
+vbetest: vbetest.c liblrmi.so
$(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $^
install:
- mkdir -p $(LIBDIR)
- install -m 755 -s -p $(LIBNAME).so.$(VERSION) $(LIBDIR)/$(LIBNAME).so.$(VERSION)
- rm -f $(LIBDIR)/$(LIBNAME).so
- ln -sf $(LIBNAME).so.$(VERSION) $(LIBDIR)/$(LIBNAME).so.$(MAJOR)
- ln -sf $(LIBNAME).so.$(MAJOR) $(LIBDIR)/$(LIBNAME).so
- install -m 644 -s -p lrmi.h $(INCDIR)/lrmi.h
- ldconfig
+ mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCDIR)
+ install -m 755 -s -p $(LIBNAME).so.$(VERSION) $(DESTDIR)$(LIBDIR)/$(LIBNAME).so.$(VERSION)
+ rm -f $(DESTDIR)$(LIBDIR)/$(LIBNAME).so
+ ln -sf $(LIBNAME).so.$(VERSION) $(DESTDIR)$(LIBDIR)/$(LIBNAME).so.$(MAJOR)
+ ln -sf $(LIBNAME).so.$(MAJOR) $(DESTDIR)$(LIBDIR)/$(LIBNAME).so
+ install -m 644 -p lrmi.h $(DESTDIR)$(INCDIR)/lrmi.h
.PHONY: clean
clean:

4
libraries/lrmi/README Normal file
View file

@ -0,0 +1,4 @@
This library provides a DPMI like interface under Linux and
*BSD systems using vm86.
vbetest is a utility to test the video card for available
vesa-modes.

View file

@ -0,0 +1,82 @@
#!/bin/sh
# Slackware build script for lrmi
# Copyright 2008 Heinz Wiesinger <hmwiesinger@gmx.at>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lrmi
VERSION=${VERSION:-0.10}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch -p1 -i $CWD/Makefile.diff
CFLAGS=$SLKCFLAGS \
make
CFLAGS=$SLKCFLAGS \
make install DESTDIR=$PKG
mkdir -p $PKG/usr/bin
install -m 755 vbetest $PKG/usr/bin/vbetest
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -f README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

8
libraries/lrmi/lrmi.info Normal file
View file

@ -0,0 +1,8 @@
PRGNAM="lrmi"
VERSION="0.10"
HOMEPAGE="http://sourceforge.net/projects/lrmi"
DOWNLOAD="http://downloads.sourceforge.net/lrmi/lrmi-0.10.tar.gz"
MD5SUM="fc1d9495e8f4563fca471bb65f34a5da"
MAINTAINER="ppr:kut"
EMAIL="HMWiesinger@gmx.at"
APPROVED="David Somero"

19
libraries/lrmi/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler-----------------------------------------------|
lrmi: lrmi (linux real mode interface)
lrmi:
lrmi: This library provides a DPMI like interface under Linux and
lrmi: *BSD systems using vm86.
lrmi: vbetest is a utility to test the video card for available
lrmi: vesa-modes.
lrmi:
lrmi: Homepage: http://sourceforge.net/projects/lrmi
lrmi:
lrmi:
lrmi: