mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
audio/Pd-extended: Added (real-time audio processing).
Signed-off-by: Michiel van Wessem <michiel@slackbuilds.org>
This commit is contained in:
parent
1dd7d65847
commit
da86549e82
8 changed files with 443 additions and 0 deletions
12
audio/Pd-extended/Makefile.diff
Normal file
12
audio/Pd-extended/Makefile.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur Pd-0.42.5-extended-orig/packages/Makefile Pd-0.42.5-extended/packages/Makefile
|
||||
--- Pd-0.42.5-extended-orig/packages/Makefile 2010-09-10 01:03:57.000000000 +0100
|
||||
+++ Pd-0.42.5-extended/packages/Makefile 2010-11-03 19:06:37.095286845 +0000
|
||||
@@ -404,7 +404,7 @@
|
||||
echo '<p>Please consider trying to get rid of software patents in your country: <a href="http://www.nosoftwarepatents.com" target="nsp">http://www.nosoftwarepatents.com</a></p>' >> $(README_FILE)
|
||||
echo "<h3>Pure Data CVS Developers</h3>" >> $(README_FILE)
|
||||
# this may seem whack, but it generates the list of developers from the SourceForge site:
|
||||
- curl 'http://sourceforge.net/project/memberlist.php?group_id=55736' | grep -A2 -e '<td>' | sed 's|\(href="\)|target="w" \1http://sourceforge.net|' >> $(README_FILE)
|
||||
+ cat $(DEVELOPERSLIST) >> $(README_FILE)
|
||||
echo "</p>" >> $(README_FILE)
|
||||
echo "<p>" >> $(README_FILE)
|
||||
echo "Many others not listed have contributed their time and effort, this is just a list of the current developers in the SourceForge project. But really, every Pd user is a developer and is encouraged to contribute to the CVS repository." >> $(README_FILE)
|
94
audio/Pd-extended/Pd-extended.SlackBuild
Normal file
94
audio/Pd-extended/Pd-extended.SlackBuild
Normal file
|
@ -0,0 +1,94 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Written by Felix Pfeifer, revision date 2010/07/31
|
||||
# contact: pfeifer[dot]felix[at]googlemail[dot]com
|
||||
|
||||
# Modified by the SlackBuilds.org project.
|
||||
|
||||
PRGNAM=Pd-extended
|
||||
VERSION=0.42.5
|
||||
SRCNAM=Pd
|
||||
SRCVER=0.42.5-extended
|
||||
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
export DEVELOPERSLIST=$CWD/developers.htm
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$SRCVER
|
||||
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
|
||||
cd $SRCNAM-$SRCVER
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Disable the usage of curl to get the list of developpers.
|
||||
patch -p1 < $CWD/Makefile.diff
|
||||
|
||||
cd packages/linux_make
|
||||
make install \
|
||||
prefix="/usr" \
|
||||
libdir="/usr/lib$LIBDIRSUFFIX" \
|
||||
mandir="/usr/man" \
|
||||
DOC_TARGETS="media messageoddness pd_fileformat pd-msg pddp tutorials" \
|
||||
DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# Copy program documentation into the package
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
$TMP/$SRCNAM-$SRCVER/doc/* $TMP/$SRCNAM-$SRCVER/packages/gpl-3.0.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/example.pdextended > $PKG/usr/doc/$PRGNAM-$VERSION/example.pdextended
|
||||
cat $CWD/Pd-extended.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-extended.SlackBuild
|
||||
|
||||
# Seems Pd can't make their mind up how they want to be called,
|
||||
#(Pd/pd or Pd/pd-extended), so we're hardcoding the files here.
|
||||
mkdir -p $PKG/usr/share/{applications,pixmaps,mime/packages}
|
||||
cat $TMP/$SRCNAM-$SRCVER/packages/linux_make/pd-extended.desktop > $PKG/usr/share/applications/pd-extended.desktop
|
||||
cat $TMP/$SRCNAM-$SRCVER/packages/linux_make/pd.png > $PKG/usr/share/pixmaps/pd.png
|
||||
cat $TMP/$SRCNAM-$SRCVER/packages/linux_make/pd-extended.xml > $PKG/usr/share/mime/packages/pd-extended.xml
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
audio/Pd-extended/Pd-extended.info
Normal file
10
audio/Pd-extended/Pd-extended.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="Pd-extended"
|
||||
VERSION="0.42.5"
|
||||
HOMEPAGE="http://puredata.info"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pure-data/Pd-0.42.5-extended.tar.gz"
|
||||
MD5SUM="54c20a51d4d07396f6a806ab46b31b18"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Felix Pfeifer"
|
||||
EMAIL="pfeifer[dot]felix[at]googlemail[dot]com"
|
||||
APPROVED="Michiel van Wessem"
|
22
audio/Pd-extended/README
Normal file
22
audio/Pd-extended/README
Normal file
|
@ -0,0 +1,22 @@
|
|||
Pd-extended (Pure Data, by Miller Puckette) is a real-time
|
||||
audio synthesis/processing package. It is one of the
|
||||
"MUSIC N" family members, open source (BSD style) successor
|
||||
of the MAX branch. This package contains the core of Pd and
|
||||
many external objetcs.
|
||||
|
||||
Since this version the programs binaries name is pdextended,
|
||||
in order to start Pd-extended you have to call it with this
|
||||
name.
|
||||
|
||||
Pd-extended is usually based on an older version of Pd.
|
||||
Since version 0.42.5 Pd-extended doesn't conflict any more
|
||||
with Pd.
|
||||
|
||||
You find an example for $HOME/.pdextended in
|
||||
/usr/doc/Pd-<version>-extended/example.pdextended
|
||||
which should work out of the box on most machines and
|
||||
will enable most of the external libraries in pd.
|
||||
|
||||
It requires dssi, gsl, imlib2, jack-audio-connection-kit,
|
||||
ladspa_sdk, lame, liblo, libquicktime and speex at compile
|
||||
time.
|
171
audio/Pd-extended/developers.htm
Normal file
171
audio/Pd-extended/developers.htm
Normal file
|
@ -0,0 +1,171 @@
|
|||
<td>
|
||||
Alexandre Quessy
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
daniel aschauer
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
august black
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
B. Bogart
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Chris McCormick
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
chunlee
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
David Merrill
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
dmotd
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Tom Schouten
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Ed Kelly
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
<b><A target="w" href="http://sourceforge.net/users/eighthave/">Hans-Christoph Steiner</A></b></td>
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
<b><A target="w" href="http://sourceforge.net/users/fbar/">Frank Barknecht</A></b></td>
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Franz Zotter
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
<b><A target="w" href="http://sourceforge.net/users/ggeiger/">Guenter Geiger</A></b></td>
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Georg Holzmann
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
carmen rocco
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
jasch
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Jonathan Wilkes
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
João Pais
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Krzysztof Czaja
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
lluÃs gómez i bigordÃ
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Luke Iannini
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
mescalinum
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
<b><A target="w" href="http://sourceforge.net/users/millerpuckette/">Miller Puckette</A></b></td>
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Michael McGonagle
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Davide Morelli
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Martin Peach
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Thomas O Fredericks
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Bryan Jurish
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Nicolas Montgermont
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Cyrille Henry
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Olaf Matthes
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
David Plans Casal
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Jamie Bullock
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Roman Haefeli
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Rich E
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Winfried Ritsch
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Russell Bryant
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Sergi Lario Loyo
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Yves Degoyon
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
musil
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
Thomas Grill
|
||||
</td>
|
||||
--
|
||||
<td>
|
||||
<b><A target="w" href="http://sourceforge.net/users/zmoelnig/">IOhannes m zmölnig</A></b></td>
|
||||
</td>
|
7
audio/Pd-extended/doinst.sh
Normal file
7
audio/Pd-extended/doinst.sh
Normal file
|
@ -0,0 +1,7 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
108
audio/Pd-extended/example.pdextended
Normal file
108
audio/Pd-extended/example.pdextended
Normal file
|
@ -0,0 +1,108 @@
|
|||
audioapi: 1
|
||||
noaudioin: False
|
||||
audioindev1: 0 2
|
||||
noaudioout: False
|
||||
audiooutdev1: 0 2
|
||||
audiobuf: 50
|
||||
rate: 44100
|
||||
callback: 0
|
||||
nomidiin: True
|
||||
nomidiout: True
|
||||
path1: /usr/lib/pd-extended/extra/3dp
|
||||
path2: /usr/lib/pd-extended/extra/Gem
|
||||
path3: /usr/lib/pd-extended/extra/adaptive
|
||||
path4: /usr/lib/pd-extended/extra/bassemu~
|
||||
path5: /usr/lib/pd-extended/extra/boids
|
||||
path6: /usr/lib/pd-extended/extra/bonk~
|
||||
path7: /usr/lib/pd-extended/extra/bsaylor
|
||||
path8: /usr/lib/pd-extended/extra/choice
|
||||
path9: /usr/lib/pd-extended/extra/controctopus
|
||||
path10: /usr/lib/pd-extended/extra/creb
|
||||
path11: /usr/lib/pd-extended/extra/cxc
|
||||
path12: /usr/lib/pd-extended/extra/cyclone
|
||||
path13: /usr/lib/pd-extended/extra/earplug~
|
||||
path14: /usr/lib/pd-extended/extra/ekext
|
||||
path15: /usr/lib/pd-extended/extra/expr~
|
||||
path16: /usr/lib/pd-extended/extra/ext13
|
||||
path17: /usr/lib/pd-extended/extra/fiddle~
|
||||
path18: /usr/lib/pd-extended/extra/flashserver
|
||||
path19: /usr/lib/pd-extended/extra/flatspace
|
||||
path20: /usr/lib/pd-extended/extra/flib
|
||||
path21: /usr/lib/pd-extended/extra/freeverb~
|
||||
path22: /usr/lib/pd-extended/extra/ggee
|
||||
path23: /usr/lib/pd-extended/extra/hcs
|
||||
path24: /usr/lib/pd-extended/extra/hid
|
||||
path25: /usr/lib/pd-extended/extra/iem16
|
||||
path26: /usr/lib/pd-extended/extra/iem_adaptfilt
|
||||
path27: /usr/lib/pd-extended/extra/iem_ambi
|
||||
path28: /usr/lib/pd-extended/extra/iem_bin_ambi
|
||||
path29: /usr/lib/pd-extended/extra/iem_delay
|
||||
path30: /usr/lib/pd-extended/extra/iem_roomsim
|
||||
path31: /usr/lib/pd-extended/extra/iem_spec2
|
||||
path32: /usr/lib/pd-extended/extra/iem_tab
|
||||
path33: /usr/lib/pd-extended/extra/iemgui
|
||||
path34: /usr/lib/pd-extended/extra/iemlib
|
||||
path35: /usr/lib/pd-extended/extra/iemmatrix
|
||||
path36: /usr/lib/pd-extended/extra/iemxmlrpc
|
||||
path37: /usr/lib/pd-extended/extra/jasch_lib
|
||||
path38: /usr/lib/pd-extended/extra/jmmmp
|
||||
path39: /usr/lib/pd-extended/extra/keyboardkeys
|
||||
path40: /usr/lib/pd-extended/extra/la-kitchen
|
||||
path41: /usr/lib/pd-extended/extra/list-abs
|
||||
path42: /usr/lib/pd-extended/extra/loop~
|
||||
path43: /usr/lib/pd-extended/extra/lrshift~
|
||||
path44: /usr/lib/pd-extended/extra/mapping
|
||||
path45: /usr/lib/pd-extended/extra/markex
|
||||
path46: /usr/lib/pd-extended/extra/maxlib
|
||||
path47: /usr/lib/pd-extended/extra/memento
|
||||
path48: /usr/lib/pd-extended/extra/memento-p
|
||||
path49: /usr/lib/pd-extended/extra/mjlib
|
||||
path50: /usr/lib/pd-extended/extra/moocow
|
||||
path51: /usr/lib/pd-extended/extra/moonlib
|
||||
path52: /usr/lib/pd-extended/extra/motex
|
||||
path53: /usr/lib/pd-extended/extra/mrpeach
|
||||
path54: /usr/lib/pd-extended/extra/nqpoly4
|
||||
path55: /usr/lib/pd-extended/extra/nqpoly~
|
||||
path56: /usr/lib/pd-extended/extra/nsend
|
||||
path57: /usr/lib/pd-extended/extra/nusmuk
|
||||
path58: /usr/lib/pd-extended/extra/oscx
|
||||
path59: /usr/lib/pd-extended/extra/pan
|
||||
path60: /usr/lib/pd-extended/extra/pd-wavelet
|
||||
path61: /usr/lib/pd-extended/extra/pdcontainer
|
||||
path62: /usr/lib/pd-extended/extra/pddp
|
||||
path63: /usr/lib/pd-extended/extra/pdogg
|
||||
path64: /usr/lib/pd-extended/extra/pdp
|
||||
path65: /usr/lib/pd-extended/extra/pd~
|
||||
path66: /usr/lib/pd-extended/extra/pidip
|
||||
path67: /usr/lib/pd-extended/extra/pique
|
||||
path68: /usr/lib/pd-extended/extra/pixeltango
|
||||
path69: /usr/lib/pd-extended/extra/pmpd
|
||||
path70: /usr/lib/pd-extended/extra/postlude
|
||||
path71: /usr/lib/pd-extended/extra/purepd
|
||||
path72: /usr/lib/pd-extended/extra/rradical
|
||||
path73: /usr/lib/pd-extended/extra/rtc
|
||||
path74: /usr/lib/pd-extended/extra/sfruit
|
||||
path75: /usr/lib/pd-extended/extra/sigmund~
|
||||
path76: /usr/lib/pd-extended/extra/sigpack
|
||||
path77: /usr/lib/pd-extended/extra/smlib
|
||||
path78: /usr/lib/pd-extended/extra/stdout
|
||||
path79: /usr/lib/pd-extended/extra/timestretch
|
||||
path80: /usr/lib/pd-extended/extra/tof
|
||||
path81: /usr/lib/pd-extended/extra/toxy
|
||||
path82: /usr/lib/pd-extended/extra/unauthorized
|
||||
path83: /usr/lib/pd-extended/extra/vanilla
|
||||
path84: /usr/lib/pd-extended/extra/vbap
|
||||
path85: /usr/lib/pd-extended/extra/windowing
|
||||
path86: /usr/lib/pd-extended/extra/zexy
|
||||
path87: /usr/lib/pd-extended/extra
|
||||
npath: 87
|
||||
standardpath: 87
|
||||
verbose: 0
|
||||
loadlib1: Gem
|
||||
loadlib2: libdir
|
||||
loadlib3: list-abs
|
||||
loadlib4: pdp
|
||||
loadlib5: pidip
|
||||
nloadlib: 5
|
||||
defeatrt: 0
|
||||
flags:
|
19
audio/Pd-extended/slack-desc
Normal file
19
audio/Pd-extended/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
Pd-extended: Pd-extended (real-time audio processing)
|
||||
Pd-extended:
|
||||
Pd-extended: Pd-extended (Pure Data, by Miller Puckette) is a real-time
|
||||
Pd-extended: audio synthesis/processing package. It is one of the
|
||||
Pd-extended: "MUSIC N" family members, open source (BSD style) successor
|
||||
Pd-extended: of the MAX branch. This package contains the core of Pd and
|
||||
Pd-extended: many external objetcs.
|
||||
Pd-extended:
|
||||
Pd-extended:
|
||||
Pd-extended: homepage: http://puredata.info/
|
||||
Pd-extended:
|
Loading…
Reference in a new issue