audio/audacity: Updated for version 1.3.13.

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
ponce 2011-07-19 09:04:49 -03:00 committed by Robby Workman
parent 2a8bbae3f3
commit da3d72fa1b
4 changed files with 8 additions and 134 deletions

View file

@ -1,33 +0,0 @@
diff -p -up audacity-src-1.3.12-beta/src/FFmpeg.cpp~ audacity-src-1.3.12-beta/src/FFmpeg.cpp
--- audacity-src-1.3.12-beta/src/FFmpeg.cpp~ 2010-03-30 13:28:54.000000000 +0200
+++ audacity-src-1.3.12-beta/src/FFmpeg.cpp 2010-05-07 11:17:29.000000000 +0200
@@ -356,7 +356,7 @@ int ufile_fopen_input(AVFormatContext **
}
// Otherwize, resort to extension matching if available
else if (fmt1->extensions) {
- if (FFmpegLibsInst->match_ext(filename, fmt1->extensions)) {
+ if (FFmpegLibsInst->av_match_ext(filename, fmt1->extensions)) {
score = 50;
}
}
@@ -829,7 +829,7 @@ bool FFmpegLibs::InitLibs(wxString libpa
INITDYN(avformat,av_open_input_file);
INITDYN(avformat,av_open_input_stream);
INITDYN(avformat,get_buffer);
- INITDYN(avformat,match_ext);
+ INITDYN(avformat,av_match_ext);
#if FFMPEG_STABLE
INITDYN(avformat,av_init_packet);
diff -p -up audacity-src-1.3.12-beta/src/FFmpeg.h~ audacity-src-1.3.12-beta/src/FFmpeg.h
--- audacity-src-1.3.12-beta/src/FFmpeg.h~ 2010-03-30 13:28:54.000000000 +0200
+++ audacity-src-1.3.12-beta/src/FFmpeg.h 2010-05-07 11:17:45.000000000 +0200
@@ -224,7 +224,7 @@ public:
AVStream* (*av_new_stream) (AVFormatContext *s, int id);
AVFormatContext* (*av_alloc_format_context) (void);
AVOutputFormat* (*guess_format) (const char *short_name, const char *filename, const char *mime_type);
- int (*match_ext) (const char *filename, const char *extensions);
+ int (*av_match_ext) (const char *filename, const char *extensions);
int (*av_write_trailer) (AVFormatContext *s);
int (*av_interleaved_write_frame) (AVFormatContext *s, AVPacket *pkt);
int (*av_write_frame) (AVFormatContext *s, AVPacket *pkt);

View file

@ -1,88 +0,0 @@
diff -Naur audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac audacity-src-1.3.12-beta/lib-src/portmixer/configure.ac
--- audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac 2010-03-30 13:29:47.000000000 +0200
+++ audacity-src-1.3.12-beta/lib-src/portmixer/configure.ac 2011-02-10 11:24:20.256414598 +0100
@@ -49,29 +49,52 @@
fi
#
+# Check which APIs are available
+#
+
+have_oss=no
+AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
+
+AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
+AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
+AC_CHECK_HEADER(windows.h, have_windows=yes, have_windows=no)
+
# Make sure the support is there
#
have_support=yes
-AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
-if [[ $have_support = "no" ]] ; then
- AC_MSG_WARN("Missing support in pa_win_ds.h");
-fi
-AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
-if [[ $have_support = "no" ]] ; then
+
+if [[ $have_alsa = "yes" ]] ; then
+ AC_EGREP_HEADER([PaAlsa_GetStreamInputCard], [pa_linux_alsa.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
AC_MSG_WARN("Missing support in pa_linux_alsa.h");
+ fi
fi
-AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
-if [[ $have_support = "no" ]] ; then
- AC_MSG_WARN("Missing support in pa_win_wmme.h");
-fi
-AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
-if [[ $have_support = "no" ]] ; then
+
+if [[ $have_coreaudio = "yes" ]] ; then
+ AC_EGREP_HEADER([PaMacCore_GetStreamInputDevice], [pa_mac_core.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
AC_MSG_WARN("Missing support in pa_mac_core.h");
+ fi
fi
-AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
-if [[ $have_support = "no" ]] ; then
- AC_MSG_WARN("Missing support in pa_unix_oss.h");
+
+if [[ $have_oss = "yes" ]] ; then
+ AC_EGREP_HEADER([PaOSS_GetStreamInputDevice], [pa_unix_oss.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_unix_oss.h");
+ fi
+fi
+
+if [[ $have_windows = "yes" ]] ; then
+ AC_EGREP_HEADER([PaWinDS_GetStreamInputGUID], [pa_win_ds.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_win_ds.h");
+ fi
+ AC_EGREP_HEADER([PaWinMME_GetStreamInputHandle], [pa_win_wmme.h], , [have_support=no])
+ if [[ $have_support = "no" ]] ; then
+ AC_MSG_WARN("Missing support in pa_win_wmme.h");
+ fi
fi
+
AC_EGREP_HEADER([Pa_GetStreamHostApiType], [portaudio.h], , [have_support=no])
if [[ $have_support = "no" ]] ; then
AC_MSG_WARN("Missing support in portaudio.h");
@@ -88,16 +111,6 @@
AC_SUBST( objects, [px_mixer.o] )
#
-# Check which APIs are available
-#
-
-have_oss=no
-AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
-
-AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
-AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
-
-#
# Set up to use the identified ones
#
AC_MSG_NOTICE(---------------------------------------);

View file

@ -29,8 +29,8 @@
# Modified by the SlackBuilds.org project
PRGNAM=audacity
VERSION=1.3.12
BUILD=${BUILD:-3}
VERSION=${VERSION:-1.3.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -93,14 +93,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix ffmpeg support for version 0.6
patch -p1 -i $CWD/audacity-src-1.3.12-beta-avformat-api-change.patch
# Fix configure in lib-src/portmixer/
patch -p1 -i $CWD/audacity-src-1.3.12-beta-configure-portmixer.patch
cd lib-src/portmixer
autoreconf
cd -
# Fix vamp plugin search path on x86_64 - thanks to B. Watson
sed -i "s,/usr/lib/vamp,/usr/lib$LIBDIRSUFFIX/vamp," \
lib-src/libvamp/src/vamp-hostsdk/PluginHostAdapter.cpp
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \

View file

@ -1,8 +1,8 @@
PRGNAM="audacity"
VERSION="1.3.12"
VERSION="1.3.13"
HOMEPAGE="http://audacity.sourceforge.net"
DOWNLOAD="http://audacity.googlecode.com/files/audacity-minsrc-1.3.12-beta.tar.bz2"
MD5SUM="76996fec67181ca82ba191e012518b57"
DOWNLOAD="http://audacity.googlecode.com/files/audacity-minsrc-1.3.13-beta.tar.bz2"
MD5SUM="57be7fadb8c8dd17b8462c7ac1561d03"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="ponce"