system/wiimms-wbfs-tool: Added to 13.0 repository

This commit is contained in:
Marco Bonetti 2010-05-13 01:01:17 +02:00 committed by Michiel van Wessem
parent 335917f3a2
commit d84fe24cbc
5 changed files with 161 additions and 0 deletions

View file

@ -0,0 +1,12 @@
diff -Naur wiimms-wbfs-tool-0.25a.orig/Makefile wiimms-wbfs-tool-0.25a/Makefile
--- wiimms-wbfs-tool-0.25a.orig/Makefile 2010-01-04 14:47:11.265517000 +0100
+++ wiimms-wbfs-tool-0.25a/Makefile 2010-01-04 15:36:37.033724127 +0100
@@ -105,7 +105,7 @@
#LDFLAGS += -Xlinker --strip-all
LDFLAGS := $(strip $(LDFLAGS))
-INSTALL_PATH = /usr/local
+INSTALL_PATH = /usr
INSTALL_SCRIPTS = install.sh load-titles.sh
RM_FILES += $(INSTALL_SCRIPTS)
SCRIPTS = ./scripts

View file

@ -0,0 +1,25 @@
Wiimm's WBFS Tool (a command line WBFS tool set for various os)
Wiimm's WBFS Tool (or wwt, for shorter) is a set of programs which can manage,
create and convert ISO, WBFS and WDF files and partitions.
Some special features:
* WDF support: WDF is a new format for reducing the size of ISO images
* Support WBFS on block devices, as plain files and as splitted files.
* Find WBFS partitions on block devices automatically if option --auto
is set.
* Multi WBFS support
* Advanced shell support
* When writing an ISO you have the choice between three formats:
* When reading an ISO the following files are accepted:
* Support of splitted files (WBFS, WDF and ISO):
* Dump the data structure of WBFS images for analysis. This dumps includes
the WBFS header, WBFS main parameters, a disc dump and memory layout dumps
for each disc and for the whole WBFS.
* Dump the data structure of ISO images for analysis. This dumps includes
the WBFS header, WBFS main parameters, a disc dump and memory layout dumps
for each disc and for the whole WBFS. The dump work also for ISO images
within a WBFS.
* The wwt command CHECK checks a WBFS for block assigning errors. Repairing
is also possible.
More information about these features can be found at "http://wiimm.de/wwt/"

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
wiimms-wbfs-tool: Wiimm's WBFS Tool (a command line WBFS tool set for various os)
wiimms-wbfs-tool:
wiimms-wbfs-tool: Wiimm's WBFS Tool (or wwt, for shorter) is a set of programs which can
wiimms-wbfs-tool: manage, create and convert ISO, WBFS and WDF files and partitions.
wiimms-wbfs-tool:
wiimms-wbfs-tool:
wiimms-wbfs-tool:
wiimms-wbfs-tool:
wiimms-wbfs-tool:
wiimms-wbfs-tool:
wiimms-wbfs-tool:

View file

@ -0,0 +1,95 @@
#!/bin/sh
# Slackware build script for Wiimm's WBFS Tool
#
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wiimms-wbfs-tool
VERSION=${VERSION:-0.25a}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="WDF.txt"
if [ "$ARCH" = "i486" ]; then
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix paths: remove "local" from "/usr/local"
patch -p1 --verbose < $CWD/Makefile.diff
# Fix paths: move from /usr/share/wwt to /usr/lib$LIBDIRSUFFIX/wwt and from
# /share/wwt to /lib$LIBDIRSUFFIX/wwt (yes, they're hardcoded...)
find . -type f | xargs sed -i -e "s:local/share/wwt:lib$LIBDIRSUFFIX/wwt:g"
find . -type f | xargs sed -i -e "s:share/wwt:lib$LIBDIRSUFFIX/wwt:g"
# Make the program
make
# Fix paths again: no support for DESTDIR, hack together something similar
sed -i -e "s:s|@@INSTALL-PATH@@|/usr|g;:s|@@INSTALL-PATH@@|$TMP/package-$PRGNAM/usr|g;:g" templates.sed
# Now we can install
make install
# strip binaries
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
)
# Copy over important docs
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="wiimms-wbfs-tool"
VERSION="0.25a"
HOMEPAGE="http://wiimm.de/wwt/"
DOWNLOAD="http://slackbuilds.org/sources/13.0/wiimms-wbfs-tool-0.25a.tar.bz2"
MD5SUM="cfd941182dbda376055980327070c41b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Marco Bonetti"
EMAIL="sid77@slackware.it"
APPROVED="michiel"