mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
games/odamex: Add missing diff.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
72183c362b
commit
d79cdc76b7
2 changed files with 22 additions and 1 deletions
|
@ -6,6 +6,7 @@
|
|||
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
# 20220208 bkw: BUILD=3, add the missing .diff...
|
||||
# 20211231 bkw: BUILD=2.
|
||||
# - the SDL2 segfault will likely be fixed soon (reported to PV, along
|
||||
# with a patch). add SDL2 environment variable, default to no.
|
||||
|
@ -32,7 +33,7 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=odamex
|
||||
VERSION=${VERSION:-0.9.5}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
|
20
games/odamex/use_bundled_portmidi.diff
Normal file
20
games/odamex/use_bundled_portmidi.diff
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff -Naur odamex-src-0.9.5/client/CMakeLists.txt odamex-src-0.9.5.patched/client/CMakeLists.txt
|
||||
--- odamex-src-0.9.5/client/CMakeLists.txt 2021-09-08 23:18:23.000000000 -0400
|
||||
+++ odamex-src-0.9.5.patched/client/CMakeLists.txt 2022-01-01 14:36:43.305448361 -0500
|
||||
@@ -65,8 +65,6 @@
|
||||
|
||||
# PortMidi
|
||||
if(ENABLE_PORTMIDI)
|
||||
- find_package(PortMidi)
|
||||
- if(NOT PORTMIDI_FOUND)
|
||||
# build the PortMidi library
|
||||
set(PORTMIDI_LIBRARY "portmidi")
|
||||
set(PORTMIDI_LIBRARIES ${PORTMIDI_LIBRARY})
|
||||
@@ -107,7 +105,6 @@
|
||||
add_library(${PORTMIDI_LIBRARY} STATIC ${PORTMIDI_SOURCES} ${PORTMIDI_HEADERS})
|
||||
target_link_libraries(${PORTMIDI_LIBRARY} ${PM_NEEDED_LIBS})
|
||||
message(STATUS "portmidi will be built and staticaly linked when compiling the client application.")
|
||||
- endif()
|
||||
|
||||
add_definitions(-DPORTMIDI)
|
||||
include_directories(${PORTMIDI_INCLUDE_DIR})
|
Loading…
Reference in a new issue