mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
libraries/mxml: Added to 12.2 repository
This commit is contained in:
parent
aea929a90c
commit
d36fa327ee
6 changed files with 141 additions and 0 deletions
9
libraries/mxml/README
Normal file
9
libraries/mxml/README
Normal file
|
@ -0,0 +1,9 @@
|
|||
Mini-XML is a small XML parsing library that you can
|
||||
use to read XML and XML-like data files in your
|
||||
application without requiring large non-standard libraries.
|
||||
|
||||
Mini-XML supports reading of UTF-8 and UTF-16 and writing
|
||||
of UTF-8 encoded XML files and strings. Data is stored in
|
||||
a linked-list tree structure, preserving the XML data hierarchy,
|
||||
and arbitrary element names, attributes, and attribute values
|
||||
are supported with no preset limits, just available memory.
|
12
libraries/mxml/link_with_pthread.diff
Normal file
12
libraries/mxml/link_with_pthread.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur mxml-2.6.orig/Makefile.in mxml-2.6/Makefile.in
|
||||
--- mxml-2.6.orig/Makefile.in 2008-12-06 04:20:38.000000000 +0000
|
||||
+++ mxml-2.6/Makefile.in 2009-06-02 07:30:21.000000000 +0000
|
||||
@@ -256,7 +256,7 @@
|
||||
#
|
||||
|
||||
libmxml.so.1.4: $(LIBOBJS)
|
||||
- $(DSO) $(DSOFLAGS) -o libmxml.so.1.4 $(LIBOBJS)
|
||||
+ $(DSO) $(DSOFLAGS) -o libmxml.so.1.4 $(LIBOBJS) $(LIBS)
|
||||
$(RM) libmxml.so libmxml.so.1
|
||||
$(LN) libmxml.so.1.4 libmxml.so
|
||||
$(LN) libmxml.so.1.4 libmxml.so.1
|
78
libraries/mxml/mxml.SlackBuild
Normal file
78
libraries/mxml/mxml.SlackBuild
Normal file
|
@ -0,0 +1,78 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for mxml
|
||||
|
||||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=mxml
|
||||
VERSION=${VERSION:-2.6}
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/remove_rpath.diff
|
||||
patch -p1 < $CWD/link_with_pthread.diff
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--mandir=/usr/man \
|
||||
--with-docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--enable-threads \
|
||||
--with-vsnprintf \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DSTROOT=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
libraries/mxml/mxml.info
Normal file
8
libraries/mxml/mxml.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="mxml"
|
||||
VERSION="2.6"
|
||||
HOMEPAGE="http://www.minixml.org/"
|
||||
DOWNLOAD="http://ftp.easysw.com/pub/mxml/2.6/mxml-2.6.tar.gz"
|
||||
MD5SUM="68977789ae64985dddbd1a1a1652642e"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="dsomero"
|
15
libraries/mxml/remove_rpath.diff
Normal file
15
libraries/mxml/remove_rpath.diff
Normal file
|
@ -0,0 +1,15 @@
|
|||
Index: trunk/configure
|
||||
===================================================================
|
||||
--- a/configure 2007-12-15 20:40:05.000000000 -0500
|
||||
+++ b/configure 2007-12-15 20:40:37.000000000 -0500
|
||||
@@ -4715,8 +4715,8 @@
|
||||
echo "${ECHO_T}yes" >&6; }
|
||||
LIBMXML="libmxml.so.1.4"
|
||||
DSO="\$(CC)"
|
||||
- DSOFLAGS="$DSOFLAGS -Wl,-soname,libmxml.so.1,-rpath,\$(libdir) -shared \$(OPTIM)"
|
||||
- LDFLAGS="$LDFLAGS -Wl,-rpath,\$(libdir)"
|
||||
+ DSOFLAGS="$DSOFLAGS -Wl,-soname,libmxml.so.1 -shared \$(OPTIM)"
|
||||
+ LDFLAGS="$LDFLAGS"
|
||||
;;
|
||||
|
||||
*BSD*)
|
19
libraries/mxml/slack-desc
Normal file
19
libraries/mxml/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|' on
|
||||
# the right side marks the last column you can put a character in. You must make
|
||||
# exactly 11 lines for the formatting to be correct. It's also customary to
|
||||
# leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
mxml: mxml (Lightweight xml parsing library)
|
||||
mxml:
|
||||
mxml: Mini-XML is a small XML parsing library that you can use to read XML
|
||||
mxml: and XML-like data files in your application without requiring large
|
||||
mxml: non-standard libraries.
|
||||
mxml:
|
||||
mxml: Homepage: http://www.minixml.org/
|
||||
mxml:
|
||||
mxml:
|
||||
mxml:
|
||||
mxml:
|
Loading…
Reference in a new issue