mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
desktop/wmii: Added (window manager improved 2)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
b53f581a61
commit
d25436bde7
10 changed files with 265 additions and 0 deletions
12
desktop/wmii/README
Normal file
12
desktop/wmii/README
Normal file
|
@ -0,0 +1,12 @@
|
|||
wmii - window manager improved 2
|
||||
|
||||
wmii is a dynamic window manager for X11. It supports classic and dynamic
|
||||
window management with extended keyboard, mouse, and filesystem based remote
|
||||
control. It replaces the workspace paradigm with a new tagging approach. Its
|
||||
minimalist philosophy attempts to not exceed 10.000 lines of code (including
|
||||
all shipped utilities and libraries), to enforce simplicity and clarity.
|
||||
|
||||
This package requires libixp.
|
||||
|
||||
If you plan to use plan9port, python or ruby scripting support you should also
|
||||
install required interpreters at run time.
|
19
desktop/wmii/doinst.sh
Normal file
19
desktop/wmii/doinst.sh
Normal file
|
@ -0,0 +1,19 @@
|
|||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/wmii/welcome.new
|
||||
config etc/wmii/wmiirc.new
|
||||
config etc/wmii/plan9port/wmiirc.new
|
||||
config etc/wmii/python/wmiirc.new
|
||||
config etc/wmii/ruby/wmiirc.new
|
||||
|
19
desktop/wmii/slack-desc
Normal file
19
desktop/wmii/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
wmii: wmii (window manager improved 2)
|
||||
wmii:
|
||||
wmii: wmii is a dynamic window manager for X11. It supports classic and
|
||||
wmii: dynamic window management with extended keyboard, mouse, and
|
||||
wmii: filesystem based remote control. It replaces the workspace paradigm
|
||||
wmii: with a new tagging approach. Its minimalist philosophy attempts to
|
||||
wmii: not exceed 10.000 lines of code (including all shipped utilities and
|
||||
wmii: libraries), to enforce simplicity and clarity.
|
||||
wmii:
|
||||
wmii: Homepage: http://wmii.suckless.org
|
||||
wmii:
|
18
desktop/wmii/wmii-3.9.2-config_mk.diff
Normal file
18
desktop/wmii/wmii-3.9.2-config_mk.diff
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff -Naur wmii+ixp-3.9.2.orig/config.mk wmii+ixp-3.9.2/config.mk
|
||||
--- wmii+ixp-3.9.2.orig/config.mk 2010-06-10 09:24:04.000000000 +0200
|
||||
+++ wmii+ixp-3.9.2/config.mk 2011-11-15 10:57:47.850346147 +0100
|
||||
@@ -6,12 +6,12 @@
|
||||
MAN = $(PREFIX)/share/man
|
||||
DOC = $(PREFIX)/share/doc/wmii
|
||||
ETC = $(PREFIX)/etc
|
||||
- LIBDIR = $(PREFIX)/lib
|
||||
+ LIBDIR = $(PREFIX)/lib$(LIBDIRSUFFIX)
|
||||
INCLUDE = $(PREFIX)/include
|
||||
|
||||
# Includes and libs
|
||||
INCLUDES = -I. -I$(ROOT)/include -I$(INCLUDE) -I/usr/include
|
||||
-LIBS = -L$(ROOT)/lib -L/usr/lib
|
||||
+LIBS = -L$(ROOT)/lib$(LIBDIRSUFFIX) -L/usr/lib$(LIBDIRSUFFIX)
|
||||
|
||||
TERMINAL = xterm
|
||||
|
20
desktop/wmii/wmii-3.9.2-mk_hdr_mk.diff
Normal file
20
desktop/wmii/wmii-3.9.2-mk_hdr_mk.diff
Normal file
|
@ -0,0 +1,20 @@
|
|||
diff -Naur wmii+ixp-3.9.2.orig/mk/hdr.mk wmii+ixp-3.9.2/mk/hdr.mk
|
||||
--- wmii+ixp-3.9.2.orig/mk/hdr.mk 2010-06-10 09:24:03.000000000 +0200
|
||||
+++ wmii+ixp-3.9.2/mk/hdr.mk 2011-11-15 10:59:19.110546818 +0100
|
||||
@@ -37,14 +37,8 @@
|
||||
|
||||
PACKAGES = 2>/dev/null
|
||||
|
||||
-# and this:
|
||||
-# Try to find a sane shell. /bin/sh is a last resort, because it's
|
||||
-# usually bash on Linux, which means it's painfully slow.
|
||||
-BINSH := $(shell \
|
||||
- if [ -x /bin/dash ]; then echo /bin/dash; \
|
||||
- elif [ -x /bin/ksh ]; then echo /bin/ksh; \
|
||||
- else echo /bin/sh; fi)
|
||||
-BINSH != echo /bin/sh
|
||||
+# This is Slackware
|
||||
+BINSH=/bin/sh
|
||||
|
||||
include $(ROOT)/config.mk
|
||||
|
125
desktop/wmii/wmii.SlackBuild
Normal file
125
desktop/wmii/wmii.SlackBuild
Normal file
|
@ -0,0 +1,125 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for wmii
|
||||
|
||||
# Copyright (c) 2011, Marco Bonetti <sid77@slackware.it>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions are met:
|
||||
# 1.- Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
|
||||
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
|
||||
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
|
||||
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
|
||||
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
|
||||
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
|
||||
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
|
||||
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Thanks to selkfoster <selkfoster@gmail.com>
|
||||
|
||||
PRGNAM=wmii
|
||||
SRCNAM=wmii+ixp
|
||||
VERSION=3.9.2
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$VERSION
|
||||
tar xvf $CWD/$SRCNAM-$VERSION.tbz
|
||||
cd $SRCNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fixup config.mk
|
||||
patch -p1 < $CWD/wmii-3.9.2-config_mk.diff
|
||||
# Fixup mk/hdr.mk
|
||||
patch -p1 < $CWD/wmii-3.9.2-mk_hdr_mk.diff
|
||||
|
||||
make \
|
||||
OPT="$SLKCLAGS" \
|
||||
PREFIX=/usr \
|
||||
MAN=/usr/man \
|
||||
ETC=/etc \
|
||||
LIBDIRSUFFIX=${LIBDIRSUFFIX}
|
||||
|
||||
make install \
|
||||
OPT="$SLKCLAGS" \
|
||||
PREFIX=$PKG/usr \
|
||||
MAN=$PKG/usr/man \
|
||||
ETC=$PKG/etc \
|
||||
LIBDIRSUFFIX=${LIBDIRSUFFIX}
|
||||
|
||||
# Add wmii to xwmconfig's list...
|
||||
install -D -m 0755 $CWD/xinitrc.wmii $PKG/etc/X11/xinit/xinitrc.wmii
|
||||
# ...and the required startup script
|
||||
install -D -m 0755 $CWD/wmii.xinit $PKG/usr/bin/wmii.xinit
|
||||
# Add a simple wmii.desktop so it can be started from kdm
|
||||
install -D -m 0644 $CWD/wmii.desktop $PKG/usr/share/apps/kdm/sessions/wmii.desktop
|
||||
|
||||
# Don't clobber config files
|
||||
mv $PKG/etc/wmii/welcome $PKG/etc/wmii/welcome.new
|
||||
mv $PKG/etc/wmii/wmiirc $PKG/etc/wmii/wmiirc.new
|
||||
mv $PKG/etc/wmii/plan9port/wmiirc $PKG/etc/wmii/plan9port/wmiirc.new
|
||||
mv $PKG/etc/wmii/python/wmiirc $PKG/etc/wmii/python/wmiirc.new
|
||||
mv $PKG/etc/wmii/ruby/wmiirc $PKG/etc/wmii/ruby/wmiirc.new
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
||||
mv $PKG/usr/share/doc $PKG/usr
|
||||
mv $PKG/usr/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
( cd $PKG/usr/doc ; ln -s $PRGNAM-$VERSION $PRGNAM )
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
6
desktop/wmii/wmii.desktop
Normal file
6
desktop/wmii/wmii.desktop
Normal file
|
@ -0,0 +1,6 @@
|
|||
[Desktop Entry]
|
||||
Type=XSession
|
||||
Exec=/usr/bin/wmii.xinit
|
||||
TryExec=/usr/bin/wmii.xinit
|
||||
Name=window manager improved 2
|
||||
Comment=A small, dynamic window manager for X11.
|
10
desktop/wmii/wmii.info
Normal file
10
desktop/wmii/wmii.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="wmii"
|
||||
VERSION="3.9.2"
|
||||
HOMEPAGE="http://wmii.suckless.org"
|
||||
DOWNLOAD="http://dl.suckless.org/wmii/wmii+ixp-3.9.2.tbz"
|
||||
MD5SUM="3d480502b7b1e2a405d941df67f16bcf"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Marco Bonetti"
|
||||
EMAIL="sid77@slackware.it"
|
||||
APPROVED="rworkman"
|
5
desktop/wmii/wmii.xinit
Normal file
5
desktop/wmii/wmii.xinit
Normal file
|
@ -0,0 +1,5 @@
|
|||
#!/bin/sh
|
||||
|
||||
until wmii; do
|
||||
true
|
||||
done
|
31
desktop/wmii/xinitrc.wmii
Normal file
31
desktop/wmii/xinitrc.wmii
Normal file
|
@ -0,0 +1,31 @@
|
|||
#!/bin/sh
|
||||
|
||||
userresources=$HOME/.Xresources
|
||||
usermodmap=$HOME/.Xmodmap
|
||||
sysresources=/etc/X11/xinit/.Xresources
|
||||
sysmodmap=/etc/X11/xinit/.Xmodmap
|
||||
|
||||
# merge in defaults and keymaps
|
||||
|
||||
if [ -f $sysresources ]; then
|
||||
xrdb -merge $sysresources
|
||||
fi
|
||||
|
||||
if [ -f $sysmodmap ]; then
|
||||
xmodmap $sysmodmap
|
||||
fi
|
||||
|
||||
if [ -f $userresources ]; then
|
||||
xrdb -merge $userresources
|
||||
fi
|
||||
|
||||
if [ -f $usermodmap ]; then
|
||||
xmodmap $usermodmap
|
||||
fi
|
||||
|
||||
# Start the window manager:
|
||||
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
|
||||
ck-launch-session /usr/bin/wmii.xinit
|
||||
else
|
||||
/usr/bin/wmii.xinit
|
||||
fi
|
Loading…
Reference in a new issue