mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/irrlicht: Fixed to build against gcc-4.7
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
09161e04ca
commit
d1768face2
2 changed files with 19 additions and 3 deletions
|
@ -3,7 +3,7 @@
|
|||
# Slackware build script for irrlicht
|
||||
|
||||
# Copyright 2010 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2011 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# Copyright 2011-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,11 +23,11 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Revision date 2011/10/26
|
||||
# Revision date 2012/08/09
|
||||
|
||||
PRGNAM=irrlicht
|
||||
VERSION=${VERSION:-svn_3843}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -76,8 +76,13 @@ find . \
|
|||
# Based on a patch from Debian, adapted for the newer irrlicht versions
|
||||
patch -p1 < $CWD/correct-install.diff
|
||||
|
||||
# Patch for gcc-4.7 - included upstream on 2012/06/18.
|
||||
# Thanks to Larry Hajali for the info!
|
||||
patch -p1 < $CWD/irrlicht_gcc47.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
NDEBUG=1 \
|
||||
make -C source/Irrlicht \
|
||||
sharedlib staticlib
|
||||
make -C source/Irrlicht install \
|
||||
|
|
11
libraries/irrlicht/irrlicht_gcc47.patch
Normal file
11
libraries/irrlicht/irrlicht_gcc47.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
diff -Naur irrlicht-svn_3843.orig/source/Irrlicht/Makefile irrlicht-svn_3843/source/Irrlicht/Makefile
|
||||
--- irrlicht-svn_3843.orig/source/Irrlicht/Makefile 2011-05-18 21:32:00.000000000 +0000
|
||||
+++ irrlicht-svn_3843/source/Irrlicht/Makefile 2012-07-14 23:23:53.693933309 +0000
|
||||
@@ -82,7 +82,6 @@
|
||||
LIB_PATH = ../../lib/$(SYSTEM)
|
||||
INSTALL_DIR = /usr/local/lib
|
||||
sharedlib install: SHARED_LIB = libIrrlicht.so
|
||||
-staticlib sharedlib: LDFLAGS += --no-export-all-symbols --add-stdcall-alias
|
||||
sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm
|
||||
staticlib sharedlib: CXXINCS += -I/usr/X11R6/include
|
||||
|
Loading…
Reference in a new issue