mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/gl2ps: Added (OpenGL to PostScript printing library)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
8b83601bf4
commit
cff22125fb
5 changed files with 152 additions and 0 deletions
8
libraries/gl2ps/README
Normal file
8
libraries/gl2ps/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
GL2PS is a C library providing high quality vector output for any OpenGL
|
||||
application.
|
||||
|
||||
The main difference between GL2PS and other similar libraries is the use of
|
||||
sorting algorithms capable of handling intersecting and stretched polygons,
|
||||
as well as non manifold objects.
|
||||
GL2PS provides advanced smooth shading and text rendering, culling of
|
||||
invisible primitives, mixed vector/bitmap output, and much more...
|
104
libraries/gl2ps/gl2ps.SlackBuild
Normal file
104
libraries/gl2ps/gl2ps.SlackBuild
Normal file
|
@ -0,0 +1,104 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for gl2ps
|
||||
|
||||
# Copyright 2011 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# revision date 2011/08/10
|
||||
|
||||
PRGNAM=gl2ps
|
||||
VERSION=${VERSION:-1.3.5}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION-source
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||
cd $PRGNAM-$VERSION-source
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Patch CMakeLists.txt to accept -DLIB_SUFFIX
|
||||
patch -p1 <$CWD/gl2ps_libsuffix.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc
|
||||
# Move docs to correct location
|
||||
mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rm -rf $PKG/usr/share/doc
|
||||
cp -a TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
libraries/gl2ps/gl2ps.info
Normal file
10
libraries/gl2ps/gl2ps.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="gl2ps"
|
||||
VERSION="1.3.5"
|
||||
HOMEPAGE="http://geuz.org/gl2ps/"
|
||||
DOWNLOAD="http://geuz.org/gl2ps/src/gl2ps-1.3.5.tgz"
|
||||
MD5SUM="22e51ff57ecd35cb1cc22497a178a017"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Niels Horn"
|
||||
EMAIL="niels.horn@gmail.com"
|
||||
APPROVED="dsomero"
|
11
libraries/gl2ps/gl2ps_libsuffix.patch
Normal file
11
libraries/gl2ps/gl2ps_libsuffix.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- gl2ps-1.3.5-source/CMakeLists.txt 2009-10-16 16:14:07.000000000 -0300
|
||||
+++ gl2ps-1.3.5-source_patched/CMakeLists.txt 2011-08-10 17:24:43.000000000 -0300
|
||||
@@ -113,7 +113,7 @@
|
||||
set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
|
||||
endif(MSVC)
|
||||
|
||||
- install(TARGETS lib shared DESTINATION lib)
|
||||
+ install(TARGETS lib shared DESTINATION lib${LIB_SUFFIX})
|
||||
endif(OPENGL_FOUND)
|
||||
|
||||
if(WIN32)
|
19
libraries/gl2ps/slack-desc
Normal file
19
libraries/gl2ps/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
gl2ps: gl2ps (OpenGL to PostScript printing library)
|
||||
gl2ps:
|
||||
gl2ps: GL2PS is a C library providing high quality vector output for any
|
||||
gl2ps: OpenGL application. The main difference between GL2PS and other
|
||||
gl2ps: similar libraries is the use of sorting algorithms capable of handling
|
||||
gl2ps: intersecting and stretched polygons, as well as non manifold objects.
|
||||
gl2ps:
|
||||
gl2ps: Homepage: http://geuz.org/gl2ps/
|
||||
gl2ps:
|
||||
gl2ps:
|
||||
gl2ps:
|
Loading…
Reference in a new issue