network/ekiga: Removed.

No longer built nor maintained upstream.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2021-11-03 11:58:44 +07:00
parent fbe24b2243
commit cfa82a7848
No known key found for this signature in database
GPG key ID: 3F617144D7238786
8 changed files with 0 additions and 2430 deletions

View file

@ -1,14 +0,0 @@
Ekiga (formely known as GnomeMeeting) is an open source VoIP and
video conferencing application for GNOME. Ekiga uses both the H.323
and SIP protocols. It supports many audio and video codecs, and is
interoperable with other SIP compliant software and also with
Microsoft NetMeeting.
Help button is broken, which probably needs the Gnome help system.
The following options, all disabled by default, are supported. Just
set any of them to "yes" to enable the corresponding feature:
- AVAHI (requires the optional dependency avahi)
- KDE (experimental KDE support)
- KAB (experimental KAddressBook support)
- GS (experimental GStreamer support)

View file

@ -1,19 +0,0 @@
schema_install() {
SCHEMA="$1"
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
chroot . gconftool-2 --makefile-install-rule \
/etc/gconf/schemas/$SCHEMA \
1>/dev/null 2>/dev/null
}
schema_install ekiga.schemas
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

File diff suppressed because it is too large Load diff

View file

@ -1,11 +0,0 @@
diff -Nrup a/lib/engine/framework/services.cpp b/lib/engine/framework/services.cpp
--- a/lib/engine/framework/services.cpp 2013-02-18 14:36:51.000000000 -0700
+++ b/lib/engine/framework/services.cpp 2019-09-23 19:38:14.662416178 -0600
@@ -43,6 +43,7 @@
#include <iostream>
#endif
+#include <ostream>
#include "services.h"
boost::optional<bool>

View file

@ -1,13 +0,0 @@
diff -up ekiga-4.0.1/configure.ac.libresolv ekiga-4.0.1/configure.ac
--- ekiga-4.0.1/configure.ac.libresolv 2017-02-23 02:30:42.051227852 -0600
+++ ekiga-4.0.1/configure.ac 2017-02-23 02:32:04.609519837 -0600
@@ -324,7 +324,8 @@ if test "x$enable_ldap" = "xyes"; then
dnl Checking for libresolv
if test ${gm_platform} = "linux" ; then
- AC_CHECK_LIB(resolv, res_gethostbyaddr, [LIBS="-lresolv $LIBS"], AC_MSG_ERROR([You need the libresolv library to compile Ekiga]), -lresolv)
+ # AC_CHECK_LIB(resolv, res_gethostbyaddr, [LIBS="-lresolv $LIBS"], AC_MSG_ERROR([You need the libresolv library to compile Ekiga]), -lresolv)
+ AC_WARNING([Just adding libresolv to LDAP_LIBS, without checking anything])
LDAP_LIBS="${LDAP_LIBS} -lresolv"
fi
found_ldap="yes"

View file

@ -1,165 +0,0 @@
#!/bin/bash
# Slackware build script for Ekiga
# Copyright 2008-2009 Mauro Giachero
# All rights reserved.
# Copyright 2011 Davd Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ekiga
VERSION=${VERSION:-4.0.1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
# Requires avahi
if [[ ${AVAHI:-no} = "no" ]] ; then
DO_AVAHI="dis"
else
DO_AVAHI="en"
fi
# Experimental XCAP support
#if [[ ${XCAP:-no} = "no" ]] ; then
DO_XCAP="dis"
#else
# DO_XCAP="en"
#fi
# Experimental KDE support
if [[ ${KDE:-no} = "no" ]] ; then
DO_KDE="dis"
else
DO_KDE="en"
fi
# Experimental KAddressBook support
if [[ ${KAB:-no} = "no" ]] ; then
DO_KAB="dis"
else
DO_KAB="en"
fi
# Experimental GStreamer support
if [[ ${GS:-no} = "no" ]] ; then
DO_GS="dis"
else
DO_GS="en"
fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/ekiga-4.0.1-libresolv.patch
patch -p1 < $CWD/ekiga-4.0.1-boost-signals2.patch
patch -p1 < $CWD/ekiga-4.0.1-gcc10.patch
# Fix for -current (20150722 dbs)
sed -e 's/gnome-icon-theme/adwaita-icon-theme/g' -i configure.ac
autoreconf -vif
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-static \
--disable-gdu \
--disable-eds \
--disable-schemas-install \
--${DO_AVAHI}able-avahi \
--${DO_XCAP}able-xcap \
--${DO_KDE}able-kde \
--${DO_KAB}able-kab \
--${DO_GS}able-gstreamer \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a [A-CE-LN-Z]* MAINTAINERS doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -1,10 +0,0 @@
PRGNAM="ekiga"
VERSION="4.0.1"
HOMEPAGE="https://www.ekiga.org/"
DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/ekiga/4.0/ekiga-4.0.1.tar.xz"
MD5SUM="704ba532a8e3e0b5e3e2971dd2db39e4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="opal ptlib"
MAINTAINER="David Woodfall"
EMAIL="dave@slackbuilds.org"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
ekiga: ekiga (an open source VoIP and video conferencing application)
ekiga:
ekiga: Ekiga (formely known as GnomeMeeting) is an open source VoIP and
ekiga: video conferencing application for GNOME. Ekiga uses both the H.323
ekiga: and SIP protocols. It supports many audio and video codecs, and is
ekiga: interoperable with other SIP compliant software and also with
ekiga: Microsoft NetMeeting.
ekiga:
ekiga: Homepage: https://www.ekiga.org/
ekiga:
ekiga: