mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
system/FreeFileSync: Added (graphical backup tool)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
eac90169cd
commit
ce619465f3
7 changed files with 169 additions and 0 deletions
103
system/FreeFileSync/FreeFileSync.SlackBuild
Normal file
103
system/FreeFileSync/FreeFileSync.SlackBuild
Normal file
|
@ -0,0 +1,103 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for FreeFileSync
|
||||
|
||||
# Written by titopoquito (titopoquito@gmail.com)
|
||||
|
||||
# The .desktop file is taken from fmjrey, and it has been published
|
||||
# on the AUR (Arch Linux User Repository) before:
|
||||
# https://aur.archlinux.org/packages.php?ID=41027&comments=all
|
||||
# (slightly modified by rworkman - 20110620)
|
||||
|
||||
# Permission to use, copy, modify, and distribute this software for
|
||||
# any purpose with or without fee is hereby granted, provided that
|
||||
# the above copyright notice and this permission notice appear in all
|
||||
# copies.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
|
||||
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
|
||||
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
|
||||
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
|
||||
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
|
||||
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
|
||||
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
# SUCH DAMAGE.
|
||||
|
||||
PRGNAM=FreeFileSync
|
||||
VERSION=${VERSION:-3.16}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
mkdir -p $PRGNAM-$VERSION
|
||||
cd $PRGNAM-$VERSION
|
||||
unzip $CWD/${PRGNAM}_Sourcecode_v${VERSION}.zip
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Let's use our SLKCFLAGS
|
||||
patch -p1 < $CWD/use_our_cflags.patch
|
||||
|
||||
make OPTS="$SLKCFLAGS"
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# no man pages included
|
||||
|
||||
# install a desktop file and an icon (from the included Help section)
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
cat $PKG/usr/share/$PRGNAM/Help/html/ffsicon.png > $PKG/usr/share/pixmaps/$PRGNAM.png
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a LICENSE BUILD/Changelog.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
13
system/FreeFileSync/FreeFileSync.desktop
Normal file
13
system/FreeFileSync/FreeFileSync.desktop
Normal file
|
@ -0,0 +1,13 @@
|
|||
[Desktop Entry]
|
||||
Comment=
|
||||
Exec=FreeFileSync
|
||||
GenericName=Folder Comparison and Synchronization
|
||||
Icon=FreeFileSync
|
||||
Name=FreeFileSync
|
||||
NoDisplay=false
|
||||
StartupNotify=true
|
||||
Categories=GTK;Utility;
|
||||
Terminal=false
|
||||
Type=Application
|
||||
X-KDE-SubstituteUID=false
|
||||
X-KDE-Username=
|
10
system/FreeFileSync/FreeFileSync.info
Normal file
10
system/FreeFileSync/FreeFileSync.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="FreeFileSync"
|
||||
VERSION="3.16"
|
||||
HOMEPAGE="http://freefilesync.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/freefilesync/FreeFileSync_Sourcecode_v3.16.zip"
|
||||
MD5SUM="7672414fffa05e44a5bc206e9b694753"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="titopoquito"
|
||||
EMAIL="titopoquito@gmail.com"
|
||||
APPROVED="rworkman"
|
6
system/FreeFileSync/README
Normal file
6
system/FreeFileSync/README
Normal file
|
@ -0,0 +1,6 @@
|
|||
FreeFileSync is an Open-Source folder comparison and synchronization
|
||||
tool. It is optimized for highest performance and usability without
|
||||
restricted or overloaded UI interfaces.
|
||||
FreeFileSync can be run on Linux and Microsoft Windows.
|
||||
|
||||
This requires gtkmm and wxGTK or wxPython.
|
4
system/FreeFileSync/doinst.sh
Normal file
4
system/FreeFileSync/doinst.sh
Normal file
|
@ -0,0 +1,4 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
19
system/FreeFileSync/slack-desc
Normal file
19
system/FreeFileSync/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
FreeFileSync: FreeFileSync (graphical backup tool)
|
||||
FreeFileSync:
|
||||
FreeFileSync: FreeFileSync is an Open-Source folder comparison and synchronization
|
||||
FreeFileSync: tool. It is optimized for highest performance and usability without
|
||||
FreeFileSync: restricted or overloaded UI interfaces.
|
||||
FreeFileSync: FreeFileSync can be run on Linux and Microsoft Windows.
|
||||
FreeFileSync:
|
||||
FreeFileSync: This requires gtkmm and wxWidgets (wxGTK) or wxPython.
|
||||
FreeFileSync:
|
||||
FreeFileSync:
|
||||
FreeFileSync:
|
14
system/FreeFileSync/use_our_cflags.patch
Normal file
14
system/FreeFileSync/use_our_cflags.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
diff -Nur orig/Makefile new/Makefile
|
||||
--- orig/Makefile 2011-04-19 14:46:30.000000000 -0500
|
||||
+++ new/Makefile 2011-06-20 12:12:45.252826394 -0500
|
||||
@@ -4,8 +4,8 @@
|
||||
SHAREDIR = $(DESTDIR)$(prefix)/share
|
||||
APPSHAREDIR = $(SHAREDIR)/$(APPNAME)
|
||||
|
||||
-COMMON_COMPILE_FLAGS = -Wall -pipe `pkg-config --cflags gtk+-2.0` -O3 -pthread -DNDEBUG -DwxUSE_UNICODE -DFFS_LINUX -DTIXML_USE_STL -DWXINTL_NO_GETTEXT_MACRO
|
||||
-COMMON_LINK_FLAGS = -O3 -pthread
|
||||
+COMMON_COMPILE_FLAGS = -Wall -pipe `pkg-config --cflags gtk+-2.0` $(OPTS) -pthread -DNDEBUG -DwxUSE_UNICODE -DFFS_LINUX -DTIXML_USE_STL -DWXINTL_NO_GETTEXT_MACRO
|
||||
+COMMON_LINK_FLAGS = $(OPTS) -pthread
|
||||
|
||||
#default build
|
||||
FFS_CPPFLAGS = $(COMMON_COMPILE_FLAGS) `wx-config --cxxflags --debug=no --unicode=yes`
|
Loading…
Reference in a new issue