mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
libraries/libaaio: fixes for crusty autoconf.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e42a8548bf
commit
ce1b6dd273
3 changed files with 73 additions and 25 deletions
|
@ -1,9 +1,10 @@
|
|||
libaaio is a software library providing the functionality of getch(), getche()
|
||||
and kbhit() on Linux and UNIX systems (including Mac OS X). It does not
|
||||
require an initialization (like curses) and does not abuse the terminal (i.e.
|
||||
whenever the mode of the terminal is changed its state is stored so it can be
|
||||
restored).
|
||||
libaaio is a software library providing the functionality of getch(),
|
||||
getche() and kbhit() on Linux and UNIX systems (including Mac OS
|
||||
X). It does not require an initialization (like curses) and does not
|
||||
abuse the terminal (i.e. whenever the mode of the terminal is changed
|
||||
its state is stored so it can be restored).
|
||||
|
||||
The software has not seen any changes since 2005, but remains useful for
|
||||
programs that still require it (e.g., beta releases of the Composer's Desktop
|
||||
Project tools).
|
||||
The software has not seen any changes since 2005, but remains useful
|
||||
for programs that still require it. This build installs both the
|
||||
static and shared libraries, as some programs still explicitly call
|
||||
for the former.
|
||||
|
|
|
@ -1,32 +1,34 @@
|
|||
#!/bin/sh -e
|
||||
|
||||
# SlackBuild for libaaio, 9 March 2016
|
||||
# SlackBuild for libaaio, 3 May 2016
|
||||
# Arthur W. Green <lynx@panix.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
# Redistribution and use of this script, with or without modification,
|
||||
# is permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR
|
||||
# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
|
||||
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
|
||||
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
|
||||
# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
|
||||
# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
|
||||
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# libaaio itself remains a copyrighted work. Please see the file COPYING
|
||||
# or README in the libaaio source distribution for more on this.
|
||||
## libaaio itself remains a copyrighted work. Please see the file
|
||||
## COPYING or README in the libaaio source distribution for more on
|
||||
## this.
|
||||
|
||||
PRGNAM=libaaio
|
||||
VERSION=${VERSION:-0.3.1}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -67,6 +69,14 @@ cd $PRGNAM-$VERSION
|
|||
chown -R root:root .
|
||||
find -L . -exec chmod -R u+w,go-w,a+rX-st {} \;
|
||||
|
||||
# twiddle and patch files to appease crusty autoconf.
|
||||
mv -v configure.in configure.ac
|
||||
patch -p1 < $CWD/$PRGNAM.patch
|
||||
mkdir -p m4 # a stub.
|
||||
autoreconf --install --force
|
||||
|
||||
# build BOTH static and shared libraries, as software dependent
|
||||
# on libaaio expect libaaio.a more often than not.
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -75,7 +85,7 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--disable-static \
|
||||
--enable-static \
|
||||
--enable-shared \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
|
|
37
libraries/libaaio/libaaio.patch
Normal file
37
libraries/libaaio/libaaio.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
--- libaaio-0.3.1.orig/configure.in 2005-09-22 07:34:37.000000000 -0600
|
||||
+++ libaaio-0.3.1/configure.ac 2016-03-30 14:17:30.214587130 -0600
|
||||
@@ -4,8 +4,10 @@
|
||||
AC_PREREQ(2.13)
|
||||
-dnl AC_INIT(libaaio, 0.2.0, macbishop@users.sf.net)
|
||||
-AC_INIT(aaio.c)
|
||||
+AC_INIT([libaaio], [0.3.1])
|
||||
|
||||
+AC_CONFIG_FILES([Makefile man/Makefile man/man3/Makefile])
|
||||
dnl AC_CONFIG_HEADER([config.h])
|
||||
+AC_CONFIG_SRCDIR([aaio.c])
|
||||
dnl DON'T FORGET TO CHANGE LIBTOOL VERSION IN MAKEFILE.AM
|
||||
-AM_INIT_AUTOMAKE(libaaio,0.3.1)
|
||||
+AC_CONFIG_MACRO_DIRS([m4])
|
||||
+AM_INIT_AUTOMAKE
|
||||
|
||||
@@ -14,3 +16,5 @@
|
||||
dnl AC_PROG_LIBTOOL
|
||||
-AM_PROG_LIBTOOL
|
||||
+dnl AM_PROG_LIBTOOL
|
||||
+AM_PROG_AR
|
||||
+LT_INIT
|
||||
|
||||
@@ -42,3 +46,2 @@
|
||||
|
||||
-AC_OUTPUT([Makefile man/Makefile man/man3/Makefile])
|
||||
-
|
||||
+AC_OUTPUT
|
||||
--- libaaio-0.3.1.orig/Makefile.am 2005-09-22 07:33:44.000000000 -0600
|
||||
+++ libaaio-0.3.1/Makefile.am 2016-03-30 14:16:57.622994581 -0600
|
||||
@@ -10,3 +10,5 @@
|
||||
|
||||
-CFLAGS=-Wall -pedantic -std=c99
|
||||
+AM_CFLAGS=-Wall -pedantic -std=c99
|
||||
+
|
||||
+ACLOCAL_AMFLAGS=-I m4
|
||||
|
Loading…
Reference in a new issue