mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
graphics/exact-image: Fix build on -current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
11872f9f21
commit
cc0cfeb393
3 changed files with 27 additions and 1 deletions
12
graphics/exact-image/c98.patch
Normal file
12
graphics/exact-image/c98.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
--- exact-image-0.9.2/Makefile.orig 2016-12-12 09:23:11.937243882 +0000
|
||||||
|
+++ exact-image-0.9.2/Makefile 2016-12-12 09:27:03.967245907 +0000
|
||||||
|
@@ -48,7 +48,7 @@
|
||||||
|
# we have some unimplemented colorspaces in the Image::iterator :-(
|
||||||
|
CFLAGS += $(call cc-option,-Wno-switch -Wno-switch-enum,)
|
||||||
|
|
||||||
|
-CXXFLAGS := $(CFLAGS) -Wno-sign-compare
|
||||||
|
+CXXFLAGS := $(CFLAGS) -Wno-sign-compare -std=gnu++98
|
||||||
|
|
||||||
|
ifeq "$(STATIC)" "1"
|
||||||
|
X_EXEFLAGS += -static
|
||||||
|
|
|
@ -56,12 +56,15 @@ sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-perl_paths.diff | patch -p1 --verbos
|
||||||
# Fix for swig-3.0.7
|
# Fix for swig-3.0.7
|
||||||
sed -i -e '/^# manually/d' api/api-swig.hh
|
sed -i -e '/^# manually/d' api/api-swig.hh
|
||||||
|
|
||||||
|
patch -p1 < $CWD/c98.patch
|
||||||
|
patch -p1 < $CWD/raw.patch
|
||||||
|
|
||||||
./configure \
|
./configure \
|
||||||
--bindir=/usr/bin \
|
--bindir=/usr/bin \
|
||||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||||
--without-php
|
--without-php
|
||||||
|
|
||||||
make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
|
make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS -Wno-narrowing -fpermissive"
|
||||||
make install DESTDIR=$PKG
|
make install DESTDIR=$PKG
|
||||||
|
|
||||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
|
11
graphics/exact-image/raw.patch
Normal file
11
graphics/exact-image/raw.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- exact-image-0.9.2/codecs/raw.cc.orig 2017-07-05 09:07:52.988538841 +0700
|
||||||
|
+++ exact-image-0.9.2/codecs/raw.cc 2017-07-05 09:08:21.813539168 +0700
|
||||||
|
@@ -71,7 +71,7 @@
|
||||||
|
if (!image.getRawData())
|
||||||
|
return false;
|
||||||
|
|
||||||
|
- return stream->write ((char*)image.getRawData(), image.stride()*image.h)
|
||||||
|
+ return (bool) stream->write ((char*)image.getRawData(), image.stride()*image.h)
|
||||||
|
/* ==
|
||||||
|
(size_t) image.stride()*image.h*/;
|
||||||
|
}
|
Loading…
Reference in a new issue