Revert "libraries/agg: Removed (build failure)"

This reverts commit 8ecfe85246.
Fixed libtool error and .pc file. Cleaned up build.
This commit is contained in:
dsomero 2010-05-26 20:07:11 -04:00 committed by David Somero
parent b6b256c666
commit cb825fcdc6
5 changed files with 145 additions and 0 deletions

11
libraries/agg/README Normal file
View file

@ -0,0 +1,11 @@
Anti-Grain Geometry (AGG) is an Open Source, free of charge graphic
library, written in industrially standard C++. The terms and conditions
of use AGG are described on The License page. AGG doesn't depend on any
graphic API or technology. Basically, you can think of AGG as of a
rendering engine that produces pixel images in memory from some vectorial
data. But of course, AGG can do much more than that. The ideas and the
philosophy of AGG are:
* Anti-Aliasing * Subpixel Accuracy * The highest possible quality
* High performance * Platform independence and compatibility
* Flexibility and extensibility * Lightweight design
* Reliability and stability (including numerical stability)

View file

@ -0,0 +1,95 @@
#!/bin/sh
# Slackware build script for Anti-Grain Geometry
# Written by Menno Duursma <druiloor@zonnet.nl>
# This program is free software. It comes without any warranty.
# Granted WTFPLv2, as published by Sam Hocevar dec'04.
# For details see http://sam.zoy.org/wtfpl/COPYING
PRGNAM=agg
VERSION=${VERSION:-2.5}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i486 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix a libtool error and the .pc file.
sed -r -i -e 's:^(.*) -L@.*:\1:' src/platform/X11/Makefile.am
patch -p1 < $CWD/no_rpath.patch
sh ./autogen.sh
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-static \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG -type f | xargs file | grep -e "executable" -e "shared object" | \
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
# Note: there is around 2.5 MB worth of stuff in the examples subdir
# If you need it, it's in the source :)
cp -a \
install ChangeLog authors readme news copying \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
libraries/agg/agg.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="agg"
VERSION="2.5"
HOMEPAGE="http://www.antigrain.com/"
DOWNLOAD="http://www.antigrain.com/agg-2.5.tar.gz"
MD5SUM="0229a488bc47be10a2fee6cf0b2febd6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Menno Duursma"
EMAIL="druiloor@zonnet.nl"
APPROVED="rworkman"

View file

@ -0,0 +1,10 @@
--- agg-2.5.orig/libagg.pc.in 2006-07-10 11:27:16.000000000 +0200
+++ agg-2.5/libagg.pc.in 2006-07-10 11:28:51.000000000 +0200
@@ -6,5 +6,5 @@
Name: libagg
Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
Version: @VERSION@
-Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg
+Libs: -L${libdir} -lagg
Cflags: -I${includedir}

19
libraries/agg/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
agg: Anti-Grain Geometry (AGG)
agg:
agg: A High Quality Rendering Engine for C++.
agg:
agg: AGG was written by Maxim Shemanarev
agg:
agg:
agg:
agg:
agg:
agg: