mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
misc/anymeal: Added (cooking recipe management program)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ebab4567f0
commit
ca6d5a7db1
7 changed files with 211 additions and 0 deletions
10
misc/anymeal/Makefile-am.patch
Normal file
10
misc/anymeal/Makefile-am.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- anymeal-1.17/Makefile.am.orig 2022-11-01 20:12:48.379000000 -0000
|
||||
+++ anymeal-1.17/Makefile.am 2022-11-01 20:12:53.568000000 -0000
|
||||
@@ -1,6 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
-SUBDIRS = anymeal tests
|
||||
+SUBDIRS = anymeal
|
||||
|
||||
doc_DATA = README.md
|
||||
|
4
misc/anymeal/README
Normal file
4
misc/anymeal/README
Normal file
|
@ -0,0 +1,4 @@
|
|||
AnyMeal is a free and open source recipe management software developed
|
||||
using SQLite3 and Qt5. It can manage a cookbook with more than 250,000
|
||||
MealMaster recipes, thereby allowing to import, export, search,
|
||||
display, edit, and print them.
|
120
misc/anymeal/anymeal.SlackBuild
Normal file
120
misc/anymeal/anymeal.SlackBuild
Normal file
|
@ -0,0 +1,120 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for anymeal
|
||||
|
||||
# Copyright 2022 SlackBuilds.org Project, Ben Collver, Earth-Planet, Universe
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=anymeal
|
||||
VERSION=${VERSION:-1.17}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# disable googletest harness and add --without-windres configure option
|
||||
patch -p1 < $CWD/configure-ac.patch
|
||||
patch -p1 < $CWD/Makefile-am.patch
|
||||
|
||||
autoreconf
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--build=$ARCH-slackware-linux \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--without-windres
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
|
||||
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
||||
mkdir -p $PKG/usr/share/{applications,pixmaps}
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ChangeLog ChangeLog LICENSE README.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
10
misc/anymeal/anymeal.info
Normal file
10
misc/anymeal/anymeal.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="anymeal"
|
||||
VERSION="1.17"
|
||||
HOMEPAGE="https://wedesoft.github.io/anymeal/"
|
||||
DOWNLOAD="https://github.com/wedesoft/anymeal/releases/download/v1.17/anymeal-1.17.tar.xz"
|
||||
MD5SUM="fc2c709656b99b757ed85db280e60d1a"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="recode"
|
||||
MAINTAINER="Ben Collver"
|
||||
EMAIL="bencollver@riseup.net"
|
34
misc/anymeal/configure-ac.patch
Normal file
34
misc/anymeal/configure-ac.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
--- anymeal-1.17/configure.ac.orig 2022-11-01 20:41:56.815000000 -0000
|
||||
+++ anymeal-1.17/configure.ac 2022-11-01 20:41:52.771000000 -0000
|
||||
@@ -15,17 +15,24 @@
|
||||
AC_MSG_ERROR([Could not find flex])
|
||||
fi
|
||||
|
||||
+AC_ARG_WITH(windres,
|
||||
+ AS_HELP_STRING([--with-windres],
|
||||
+ [Enable support for windres (default: auto)]),
|
||||
+ [WINDRES=$with_windres], [WINDRES=auto])
|
||||
+
|
||||
dnl Check for windres.
|
||||
-AC_CHECK_PROG(WINDRES,windres,windres,no)
|
||||
+if test "x$WINDRES" = "xauto"; then
|
||||
+ AC_CHECK_PROG(WINDRES,windres,windres,no)
|
||||
+fi
|
||||
AM_CONDITIONAL([HAVE_WINDRES], [test "x$WINDRES" = "xwindres"])
|
||||
|
||||
dnl Check for Googletest framework.
|
||||
-if test "x$GTEST" = "x"; then
|
||||
- GTEST="/usr/src/googletest/googletest"
|
||||
-fi
|
||||
-AS_IF([test -e "$GTEST/src/gtest-all.cc"],
|
||||
- AC_SUBST(GTEST),
|
||||
- AC_MSG_ERROR([Could not find $GTEST/src/gtest-all.cc]))
|
||||
+dnl if test "x$GTEST" = "x"; then
|
||||
+dnl GTEST="/usr/src/googletest/googletest"
|
||||
+dnl fi
|
||||
+dnl AS_IF([test -e "$GTEST/src/gtest-all.cc"],
|
||||
+dnl AC_SUBST(GTEST),
|
||||
+dnl AC_MSG_ERROR([Could not find $GTEST/src/gtest-all.cc]))
|
||||
|
||||
dnl Check for recode-library.
|
||||
AC_MSG_CHECKING([for recode-library])
|
14
misc/anymeal/doinst.sh
Normal file
14
misc/anymeal/doinst.sh
Normal file
|
@ -0,0 +1,14 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
19
misc/anymeal/slack-desc
Normal file
19
misc/anymeal/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
anymeal: anymeal (cooking recipe management program)
|
||||
anymeal:
|
||||
anymeal: AnyMeal is a free and open source recipe management software
|
||||
anymeal: developed using SQLite3 and Qt5. It can manage a cookbook with more
|
||||
anymeal: than 250,000 MealMaster recipes, thereby allowing to import, export,
|
||||
anymeal: search, display, edit, and print them.
|
||||
anymeal:
|
||||
anymeal: Homepage: https://wedesoft.github.io/anymeal/
|
||||
anymeal:
|
||||
anymeal:
|
||||
anymeal:
|
Loading…
Reference in a new issue