mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
graphics/paraview: Updated for version 5.1.2 + new maintainer
Signed-off-by: Christoph Willing <chris.willing@iinet.net.au>
This commit is contained in:
parent
6310a43dfe
commit
c8eb4401dc
8 changed files with 200 additions and 65 deletions
26
graphics/paraview/010_doc_path.diff
Normal file
26
graphics/paraview/010_doc_path.diff
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx.orig 2016-07-27 12:54:37.000000000 +1000
|
||||
+++ Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx 2016-07-28 15:10:34.755501222 +1000
|
||||
@@ -323,8 +323,8 @@
|
||||
#else
|
||||
QString appdir = QCoreApplication::applicationDirPath();
|
||||
QString documentationPath = QFileInfo(appdir).fileName() == "bin" ?
|
||||
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc" :
|
||||
- /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc";
|
||||
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL :
|
||||
+ /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ;
|
||||
#endif
|
||||
|
||||
QString paraViewGuideFile = documentationPath + "/Guide.pdf";
|
||||
--- Qt/ApplicationComponents/pqWelcomeDialog.cxx.orig 2016-07-27 12:54:37.000000000 +1000
|
||||
+++ Qt/ApplicationComponents/pqWelcomeDialog.cxx 2016-07-28 15:14:43.187484954 +1000
|
||||
@@ -44,8 +44,8 @@
|
||||
#else
|
||||
QString appdir = QCoreApplication::applicationDirPath();
|
||||
QString documentationPath = QFileInfo(appdir).fileName() == "bin" ?
|
||||
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc" :
|
||||
- /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc";
|
||||
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL :
|
||||
+ /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ;
|
||||
#endif
|
||||
QString paraViewGettingStartedFile = documentationPath + "/GettingStarted.pdf";
|
||||
QUrl gettingStartedURL = QUrl::fromLocalFile(paraViewGettingStartedFile);
|
11
graphics/paraview/020_fmmmesh_lib_path.diff
Normal file
11
graphics/paraview/020_fmmmesh_lib_path.diff
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Plugins/GeodesicMeasurementPlugin/FmmMesh/CMakeLists.txt.orig 2016-07-27 12:54:37.000000000 +1000
|
||||
+++ Plugins/GeodesicMeasurementPlugin/FmmMesh/CMakeLists.txt 2016-07-28 10:09:59.293353301 +1000
|
||||
@@ -59,6 +59,6 @@
|
||||
|
||||
install(TARGETS ${PROJECT_NAME}
|
||||
RUNTIME DESTINATION bin
|
||||
- LIBRARY DESTINATION lib
|
||||
- ARCHIVE DESTINATION lib
|
||||
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
|
||||
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
||||
)
|
|
@ -1,9 +1,17 @@
|
|||
ParaView is an open-source, multi-platform data analysis and
|
||||
visualization application. ParaView users can quickly build
|
||||
visualizations to analyze their data using qualitative and
|
||||
quantitative techniques. The data exploration can be done
|
||||
interactively in 3D or programmatically using ParaView's batch
|
||||
ParaView is an open-source, multi-platform data analysis and visualization
|
||||
application. ParaView users can quickly build visualizations to analyze their
|
||||
data using qualitative and quantitative techniques. The data exploration can be
|
||||
done interactively in 3D or programmatically using ParaView's batch
|
||||
processing capabilities.
|
||||
|
||||
NOTE: Source is not downloadable from wget. Please download it manually
|
||||
via browser.
|
||||
Although not recommended, building without MPI (mpich) and/or Matplotlib support
|
||||
is possible by setting the relevant variables in the build environment:
|
||||
MPICH=no
|
||||
MATPLOTLIB=no
|
||||
|
||||
This build incorporates the ParaView "Getting Started" and "Tutorial"
|
||||
documentation. In addition, the official ParaView Guide is available from:
|
||||
http://www.paraview.org/files/v5.1/ParaViewGuide-5.1.0.pdf
|
||||
For access to the Guide directly from the ParaView graphical interface
|
||||
(using Help menu or F1 key), it should be stored as
|
||||
/usr/doc/paraview-5.1.2/Guide.pdf
|
||||
|
|
26
graphics/paraview/README.sbo
Normal file
26
graphics/paraview/README.sbo
Normal file
|
@ -0,0 +1,26 @@
|
|||
The source tarball was generated from the official Paraview git repository at
|
||||
https://gitlab.kitware.com/paraview/paraview
|
||||
with third party modules (e.g. VTK) already included, rather than retrieving
|
||||
them at build time. Should this need to be replicated, checkout the 5.1.2 branch
|
||||
of the ParaView git repository and initialise the submodules as shown in the
|
||||
session output below:
|
||||
|
||||
chris@d6:/tmp/paraview-5.1.2$ git br
|
||||
* 5.1.2
|
||||
master
|
||||
chris@d6:/tmp/paraview-5.1.2$ git submodule update --init
|
||||
Submodule 'ThirdParty/IceT/vtkicet' (https://gitlab.kitware.com/icet/icet.git) registered for path 'ThirdParty/IceT/vtkicet'
|
||||
Submodule 'ThirdParty/QtTesting/vtkqttesting' (https://github.com/Kitware/QtTesting.git) registered for path 'ThirdParty/QtTesting/vtkqttesting'
|
||||
Submodule 'ThirdParty/protobuf/vtkprotobuf' (https://gitlab.kitware.com/paraview/protobuf.git) registered for path 'ThirdParty/protobuf/vtkprotobuf'
|
||||
Submodule 'Utilities/VisItBridge' (https://gitlab.kitware.com/paraview/visitbridge.git) registered for path 'Utilities/VisItBridge'
|
||||
Submodule 'VTK' (https://gitlab.kitware.com/vtk/vtk.git) registered for path 'VTK'
|
||||
Cloning into '/tmp/paraview-5.1.2/ThirdParty/IceT/vtkicet'...
|
||||
Cloning into '/tmp/paraview-5.1.2/ThirdParty/QtTesting/vtkqttesting'...
|
||||
Cloning into '/tmp/paraview-5.1.2/ThirdParty/protobuf/vtkprotobuf'...
|
||||
Cloning into '/tmp/paraview-5.1.2/Utilities/VisItBridge'...
|
||||
Cloning into '/tmp/paraview-5.1.2/VTK'...
|
||||
Submodule path 'ThirdParty/IceT/vtkicet': checked out '0d08b037f3fa8b6e1a82ed2beb84e024c06f895f'
|
||||
Submodule path 'ThirdParty/QtTesting/vtkqttesting': checked out '706d5cd1bbdd0658802da63b940c8bb2d1f3d192'
|
||||
Submodule path 'ThirdParty/protobuf/vtkprotobuf': checked out '3637bc9efc2c29c54ee907e4341e39127599c4ec'
|
||||
Submodule path 'Utilities/VisItBridge': checked out 'f8dd33fcfd025fd5b878b07f4d2e7deb5573e379'
|
||||
Submodule path 'VTK': checked out '31b13ea55f8db68b64e9412b7896e0e8110aedfe'
|
21
graphics/paraview/doinst.sh
Normal file
21
graphics/paraview/doinst.sh
Normal file
|
@ -0,0 +1,21 @@
|
|||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
||||
if [ -e usr/share/glib-2.0/schemas ]; then
|
||||
if [ -x /usr/bin/glib-compile-schemas ]; then
|
||||
/usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for ParaView
|
||||
# Slackware build script for paraview
|
||||
|
||||
# Copyright 2014 Youjie Zhou <jmpopusth AT gmail DOT com>
|
||||
# Copyright 2016 Christoph Willing Brisbane, Australia
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,82 +23,119 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=paraview
|
||||
VERSION=${VERSION:-4.0.1}
|
||||
VERSION=${VERSION:-5.1.2}
|
||||
SHORT_VERSION=${SHORT_VERSION:-5.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
# Change source package name
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
SRCARCH="64bit"
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
elif [ "$ARCH" = "arm" ]; then
|
||||
printf "\n$ARCH is unsupported for ParaView...\n\n"
|
||||
exit 1
|
||||
else
|
||||
SRCARCH="32bit"
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
# Construct the name of the tarball
|
||||
TARNAME="ParaView-${VERSION}-Linux-${SRCARCH}"
|
||||
if [ ! -r $TARNAME.tar.gz ]; then
|
||||
echo "$TARNAME not found"
|
||||
exit 1
|
||||
fi
|
||||
mpich="-DPARAVIEW_USE_MPI=ON -DVTK_VPIC_USE_MPI=ON -DVTK_XDMF_USE_MPI=ON" ; [ "${MPICH:-yes}" != "yes" ] && mpich=""
|
||||
matplotlib="-DPARAVIEW_ENABLE_MATPLOTLIB=ON" ; [ "${MATPLOTLIB:-yes}" != "yes" ] && matplotlib=""
|
||||
|
||||
set -eu
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $TARNAME
|
||||
tar xvf $CWD/$TARNAME.tar.gz
|
||||
|
||||
cd $TARNAME
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
patch -p0 < $CWD/010_doc_path.diff
|
||||
patch -p0 < $CWD/020_fmmmesh_lib_path.diff
|
||||
sed -i -e 's/@PARAVIEW_VERSION_FULL@/1.0/' Applications/ParaView/paraview.desktop.in
|
||||
echo "Exec=paraview" >> Applications/ParaView/paraview.desktop.in
|
||||
echo "Categories=Development;Graphics" >> Applications/ParaView/paraview.desktop.in
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
find . -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DFFMPEG_LIBAVCODEC_INCLUDE_DIRS=/usr/include/libavcodec \
|
||||
-DFFMPEG_LIBAVDEVICE_INCLUDE_DIRS=/usr/include/libavdevice \
|
||||
-DFFMPEG_LIBAVFORMAT_INCLUDE_DIRS=/usr/include/libavformat \
|
||||
-DFFMPEG_LIBAVUTIL_INCLUDE_DIRS=/usr/include/libavutil \
|
||||
-DFFMPEG_LIBSWSCALE_INCLUDE_DIRS=/usr/include/libswscale \
|
||||
-DPARAVIEW_BUILD_QT_GUI=ON \
|
||||
-DPARAVIEW_ENABLE_XDMF3=OFF \
|
||||
-DPARAVIEW_ENABLE_CATALYST=ON \
|
||||
-DPARAVIEW_ENABLE_FFMPEG=ON \
|
||||
-DPARAVIEW_ENABLE_PYTHON=ON \
|
||||
-DPARAVIEW_USE_QTWEBKIT=ON \
|
||||
-DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON \
|
||||
-DVTK_RENDERING_BACKEND="OpenGL2" \
|
||||
-DBUILD_DOCUMENTATION=ON \
|
||||
-DBUILD_EXAMPLES=ON \
|
||||
-DBUILD_TESTING=OFF \
|
||||
-DINSTALL_MAN_DIR=/usr/man \
|
||||
-DINSTALL_LIB_DIR=/usr/lib${LIBDIRSUFFIX} \
|
||||
-DICET_INSTALL_MAN_DIR=man \
|
||||
-DVTK_INSTALL_ARCHIVE_DIR=lib${LIBDIRSUFFIX}/paraview-${VERSION} \
|
||||
-DVTK_INSTALL_LIBRARY_DIR=lib${LIBDIRSUFFIX}/paraview-${VERSION} \
|
||||
-DVTK_INSTALL_PYTHON_MODULE_DIR=lib${LIBDIRSUFFIX}/paraview-${VERSION}/site-packages \
|
||||
-DVTK_INSTALL_PACKAGE_DIR=lib${LIBDIRSUFFIX}/cmake/paraview-${VERSION} \
|
||||
-DVTK_INSTALL_DOC_DIR=doc/${PRGNAM}-${VERSION} \
|
||||
-DQtTesting_INSTALL_LIB_DIR=lib${LIBDIRSUFFIX} \
|
||||
-DQtTesting_INSTALL_CMAKE_DIR=lib${LIBDIRSUFFIX}/cmake/qttesting \
|
||||
$matplotlib \
|
||||
$mpich \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/opt/$PRGNAM$VERSION
|
||||
mv * $PKG/opt/$PRGNAM$VERSION/
|
||||
|
||||
# Because paraview uses relative path in its codes, we have to create
|
||||
# small launcher scripts
|
||||
mkdir -p $PKG/usr/bin
|
||||
cd $PKG/usr/bin/
|
||||
for FILE in $PKG/opt/$PRGNAM$VERSION/bin/* ; do
|
||||
NAME=$(basename $FILE)
|
||||
echo /opt/$PRGNAM$VERSION/bin/$NAME > $NAME
|
||||
chmod +x $NAME ;
|
||||
done
|
||||
mkdir -p $PKG/usr/share/$PRGNAM-$SHORT_VERSION/data
|
||||
tar xf $CWD/ParaViewTutorialData.tar.gz
|
||||
cp -p ParaViewTutorialData/* $PKG/usr/share/$PRGNAM-$SHORT_VERSION/data
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cd $PKG/opt/$PRGNAM$VERSION/
|
||||
mv doc/* $PKG/usr/doc/$PRGNAM-$VERSION/
|
||||
rm -rf doc/
|
||||
cp -a \
|
||||
CONTRIBUTING.* Copyright.* License_v1.2.txt README.* version.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $CWD/ParaViewTutorial.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf
|
||||
cp $CWD/ParaViewGettingStarted-5.1.0.pdf $PKG/usr/doc/$PRGNAM-$VERSION/GettingStarted.pdf
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,10 +1,16 @@
|
|||
PRGNAM="paraview"
|
||||
VERSION="4.0.1"
|
||||
HOMEPAGE="http://www.paraview.org/"
|
||||
DOWNLOAD="http://cse.sc.edu/~zhou42/data/ParaView-4.0.1-Linux-32bit.tar.gz"
|
||||
MD5SUM="3e2521b1e5cc8435791002f9203fe5fd"
|
||||
DOWNLOAD_x86_64="http://cse.sc.edu/~zhou42/data/ParaView-4.0.1-Linux-64bit.tar.gz"
|
||||
MD5SUM_x86_64="0a9be32f8b8e7008e16646027cf65432"
|
||||
REQUIRES=""
|
||||
MAINTAINER="Youjie Zhou"
|
||||
EMAIL="jmpopush@gmail.com"
|
||||
VERSION="5.1.2"
|
||||
HOMEPAGE="http://www.paraview.org"
|
||||
DOWNLOAD="http://sourceforge.net/projects/slackbuildsdirectlinks/files/ParaView/paraview-5.1.2.tar.gz \
|
||||
http://www.paraview.org/Wiki/images/5/5d/ParaViewTutorialData.tar.gz \
|
||||
http://www.paraview.org/files/v5.1/ParaViewTutorial.pdf \
|
||||
http://www.paraview.org/files/v5.1/ParaViewGettingStarted-5.1.0.pdf"
|
||||
MD5SUM="6df8f5d6a5ce2d82d6d75b76308c65ad \
|
||||
0a4c2a37b8e566ccdb3b1eaaa949477a \
|
||||
4b1c410cd461f68a3bac5839c22bee93 \
|
||||
7ce54ce8a8b36c746035c2b228713074"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="ffmpeg hdf5 Sphinx matplotlib mpich"
|
||||
MAINTAINER="Christoph Willing"
|
||||
EMAIL="chris.willing@linux.com"
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
paraview: paraview (multi-platform data analysis and visualization application)
|
||||
paraview: paraview (Data Visualisation)
|
||||
paraview:
|
||||
paraview: ParaView is an open-source, multi-platform data analysis and
|
||||
paraview: visualization application. ParaView users can quickly build
|
||||
|
@ -14,6 +14,6 @@ paraview: visualizations to analyze their data using qualitative and
|
|||
paraview: quantitative techniques. The data exploration can be done
|
||||
paraview: interactively in 3D or programmatically using ParaView's batch
|
||||
paraview: processing capabilities.
|
||||
paraview:
|
||||
paraview: Homepage: http://www.paraview.org/
|
||||
paraview:
|
||||
paraview:
|
||||
paraview:
|
||||
|
|
Loading…
Reference in a new issue