mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
desktop/razorqt: Updated for version 0.5.1.
Added a small workaround to the startrazor launch script Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
0b099b6a18
commit
c6a03b745a
8 changed files with 89 additions and 47 deletions
|
@ -1,3 +1,20 @@
|
|||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
for i in desktop razor session windowmanagers razor-panel/panel; do
|
||||
config @RCONFDIR@/razor/$i.conf.new
|
||||
done
|
||||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
|
31
desktop/razorqt/patches/dont_hardcode_xdg_path.patch
Normal file
31
desktop/razorqt/patches/dont_hardcode_xdg_path.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff --git a/razorqt-config/src/CMakeLists.txt b/razorqt-config/src/CMakeLists.txt
|
||||
index 193809c..76df89d 100644
|
||||
--- a/razorqt-config/src/CMakeLists.txt
|
||||
+++ b/razorqt-config/src/CMakeLists.txt
|
||||
@@ -52,4 +52,4 @@ target_link_libraries( razor-config qcategorizedview)
|
||||
|
||||
INSTALL(TARGETS razor-config RUNTIME DESTINATION bin)
|
||||
install(FILES ${DESKTOP_FILES} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
|
||||
-install(FILES razor-config.menu DESTINATION /etc/xdg/menus/)
|
||||
+install(FILES razor-config.menu DESTINATION ${RAZOR_ETC_XDG_DIRECTORY}/menus/)
|
||||
diff --git a/razorqt-resources/application-menu/CMakeLists.txt b/razorqt-resources/application-menu/CMakeLists.txt
|
||||
index cfb1a64..356d7e5 100644
|
||||
--- a/razorqt-resources/application-menu/CMakeLists.txt
|
||||
+++ b/razorqt-resources/application-menu/CMakeLists.txt
|
||||
@@ -26,5 +26,5 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/razor-applications.menu.in
|
||||
${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu
|
||||
@ONLY)
|
||||
|
||||
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu DESTINATION /etc/xdg/menus/)
|
||||
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/razor-applications.menu DESTINATION ${RAZOR_ETC_XDG_DIRECTORY}/menus/)
|
||||
install(DIRECTORY desktop-directories DESTINATION share/ PATTERN ".desktop")
|
||||
diff --git a/razorqt-resources/autostart/CMakeLists.txt b/razorqt-resources/autostart/CMakeLists.txt
|
||||
index aa9dece..a00c119 100644
|
||||
--- a/razorqt-resources/autostart/CMakeLists.txt
|
||||
+++ b/razorqt-resources/autostart/CMakeLists.txt
|
||||
@@ -11,4 +11,4 @@ razor_translate_desktop(DESKTOP_FILES
|
||||
add_custom_target(autostart_desktop_files ALL DEPENDS ${DESKTOP_FILES})
|
||||
#************************************************
|
||||
|
||||
-install(FILES ${DESKTOP_FILES} DESTINATION /etc/xdg/autostart)
|
||||
+install(FILES ${DESKTOP_FILES} DESTINATION ${RAZOR_ETC_XDG_DIRECTORY}/autostart)
|
|
@ -1,24 +0,0 @@
|
|||
diff -Nur razorqt-0.4.1.orig/razorqt-session/src/main.cpp razorqt-0.4.1/razorqt-session/src/main.cpp
|
||||
--- razorqt-0.4.1.orig/razorqt-session/src/main.cpp 2012-02-13 04:24:51.000000000 -0600
|
||||
+++ razorqt-0.4.1/razorqt-session/src/main.cpp 2012-04-22 22:33:05.094043520 -0500
|
||||
@@ -28,6 +28,8 @@
|
||||
#include <QApplication>
|
||||
#include <QIcon>
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
#include "razormodman.h"
|
||||
#include "sessiondbusadaptor.h"
|
||||
#include "razortranslate.h"
|
||||
diff -Nur razorqt-0.4.1.orig/razorqt-session/src/razormodman.cpp razorqt-0.4.1/razorqt-session/src/razormodman.cpp
|
||||
--- razorqt-0.4.1.orig/razorqt-session/src/razormodman.cpp 2012-02-13 04:24:51.000000000 -0600
|
||||
+++ razorqt-0.4.1/razorqt-session/src/razormodman.cpp 2012-04-22 22:38:53.867441049 -0500
|
||||
@@ -25,6 +25,8 @@
|
||||
*
|
||||
* END_COMMON_COPYRIGHT_HEADER */
|
||||
|
||||
+#include <unistd.h>
|
||||
+
|
||||
#include "razormodman.h"
|
||||
#include <razorqt/razorsettings.h>
|
||||
#include <qtxdg/xdgautostart.h>
|
|
@ -1,6 +1,6 @@
|
|||
#!/bin/csh
|
||||
if ( $?XDG_CONFIG_DIRS ) then
|
||||
setenv XDG_CONFIG_DIRS ${XDG_CONFIG_DIRS}:/etc/razorqt/xdg
|
||||
setenv XDG_CONFIG_DIRS ${XDG_CONFIG_DIRS}:@RCONFDIR@
|
||||
else
|
||||
setenv XDG_CONFIG_DIRS /etc/xdg:/etc/razorqt/xdg
|
||||
setenv XDG_CONFIG_DIRS /etc/xdg:@RCONFDIR@
|
||||
endif
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
#!/bin/sh
|
||||
if [ ! "$XDG_CONFIG_DIRS" = "" ]; then
|
||||
XDG_CONFIG_DIRS=$XDG_CONFIG_DIRS:/etc/razorqt/xdg
|
||||
XDG_CONFIG_DIRS=$XDG_CONFIG_DIRS:@RCONFDIR@
|
||||
else
|
||||
XDG_CONFIG_DIRS=/etc/xdg:/etc/razorqt/xdg
|
||||
XDG_CONFIG_DIRS=/etc/xdg:@RCONFDIR@
|
||||
fi
|
||||
export XDG_CONFIG_DIRS
|
||||
|
|
|
@ -26,9 +26,10 @@
|
|||
# I'll be more than happy to let you maintain this build script. I don't
|
||||
# plan to actually use razorqt (I like xfce), but this looked too useful to
|
||||
# not have available in Slackware --rworkman
|
||||
# Same for me (the only difference is that I use lxde ;p ) --ponce
|
||||
|
||||
PRGNAM=razorqt
|
||||
VERSION=${VERSION:-0.4.1}
|
||||
VERSION=${VERSION:-0.5.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -65,7 +66,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -74,8 +75,11 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Needed for gcc47; harmless for earlier gcc
|
||||
patch -p1 < $CWD/patches/include_unistd_h.diff
|
||||
# Fix hardcoded xdg path
|
||||
patch -p1 < $CWD/patches/dont_hardcode_xdg_path.patch
|
||||
|
||||
# Where our system config (razor and xdg files) resides
|
||||
RCONFDIR=${RCONFDIR:-etc/razor/xdg}
|
||||
|
||||
cmake \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
|
@ -83,7 +87,7 @@ cmake \
|
|||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
|
||||
-DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
|
||||
-DRAZOR_CONFIG_DIR:STRING=".config/razorqt"
|
||||
-DRAZOR_ETC_XDG_DIRECTORY:PATH="/$RCONFDIR"
|
||||
|
||||
make VERBOSE=1
|
||||
make install DESTDIR=$PKG
|
||||
|
@ -91,24 +95,38 @@ make install DESTDIR=$PKG
|
|||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
|
||||
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/etc/razorqt
|
||||
mv $PKG/etc/xdg $PKG/etc/razorqt
|
||||
|
||||
mkdir -p $PKG/etc/X11/xinit
|
||||
cat $CWD/xinit/xinitrc.razorqt > $PKG/etc/X11/xinit/xinitrc.razorqt
|
||||
chmod 0755 $PKG/etc/X11/xinit/xinitrc.razorqt
|
||||
|
||||
mkdir -p $PKG/etc/profile.d
|
||||
cat $CWD/profile.d/razorqt.sh > $PKG/etc/profile.d/razorqt.sh
|
||||
cat $CWD/profile.d/razorqt.csh > $PKG/etc/profile.d/razorqt.csh
|
||||
sed "s|@RCONFDIR@|/$RCONFDIR|" \
|
||||
$CWD/profile.d/razorqt.sh > $PKG/etc/profile.d/razorqt.sh
|
||||
sed "s|@RCONFDIR@|/$RCONFDIR|" \
|
||||
$CWD/profile.d/razorqt.csh > $PKG/etc/profile.d/razorqt.csh
|
||||
chmod 0755 $PKG/etc/profile.d/*
|
||||
|
||||
# Don't clobber existing config files
|
||||
for i in desktop razor session windowmanagers razor-panel/panel; do
|
||||
mv $PKG/$RCONFDIR/razor/$i.conf $PKG/$RCONFDIR/razor/$i.conf.new
|
||||
done
|
||||
# Add missing section entry in razor.conf, to avoid complains
|
||||
# from razor-confupdate python script...
|
||||
sed -i '/^theme/i [General]' $PKG/$RCONFDIR/razor/razor.conf.new
|
||||
# ...beside the fact that it looks in the wrong path...
|
||||
sed -i "s|\.razor|.config/razor|" $PKG/usr/share/razor/razor-confupdate/*
|
||||
|
||||
# There's a small issue: seems like default configs are not created when
|
||||
# you launch razor the first time: copy them from their global dir if
|
||||
# ~/.config/razor doesn't exist
|
||||
sed -i "s|^$|if [ ! -d ~/.config/razor ]; then mkdir -p ~/.config ; cp -a /$RCONFDIR/razor ~/.config/razor ; fi|" $PKG/usr/bin/startrazor
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
sed "s|@RCONFDIR@|$RCONFDIR|" $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="razorqt"
|
||||
VERSION="0.4.1"
|
||||
VERSION="0.5.1"
|
||||
HOMEPAGE="http://razor-qt.org/"
|
||||
DOWNLOAD="https://github.com/downloads/Razor-qt/razor-qt/razorqt-0.4.1.tar.bz2"
|
||||
MD5SUM="d34743845aadedc547e6912b64c99b34"
|
||||
DOWNLOAD="https://github.com/downloads/Razor-qt/razor-qt/razorqt-0.5.1.tar.bz2"
|
||||
MD5SUM="a4c195c289c0843eb6152808ff21bd5a"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Robby Workman"
|
||||
EMAIL="rworkman@slackbuilds.org"
|
||||
REQUIRES="libstatgrab"
|
||||
MAINTAINER="Matteo Bernardini"
|
||||
EMAIL="ponce@slackbuilds.org"
|
||||
|
|
|
@ -12,8 +12,8 @@ sysmodmap=/etc/X11/xinit/.Xmodmap
|
|||
[ -f $usermodmap ] && /usr/bin/xmodmap $usermodmap
|
||||
|
||||
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
|
||||
ck-launch-session razor-session
|
||||
ck-launch-session startrazor
|
||||
else
|
||||
exec razor-session
|
||||
exec startrazor
|
||||
fi
|
||||
|
||||
|
|
Loading…
Reference in a new issue