mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
graphics/dia: Updated for version 0.97
This commit is contained in:
parent
f15dc716a0
commit
c694de2aa1
6 changed files with 63 additions and 29 deletions
|
@ -7,6 +7,3 @@ objects to help draw entity relationship diagrams, UML diagrams,
|
|||
flowcharts, network diagrams, and many other diagrams. It is also
|
||||
possible to add support for new shapes by writing simple XML files,
|
||||
using a subset of SVG to draw the shape.
|
||||
|
||||
note: Occasionally the mirror may be quite busy, this might lead to
|
||||
possible problems in downloading.
|
||||
|
|
12
graphics/dia/dia-0.97-fixup_fr_mandir.patch
Normal file
12
graphics/dia/dia-0.97-fixup_fr_mandir.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur dia-0.97.orig/doc/fr/Makefile.in dia-0.97/doc/fr/Makefile.in
|
||||
--- dia-0.97.orig/doc/fr/Makefile.in 2009-05-03 13:12:41.000000000 -0500
|
||||
+++ dia-0.97/doc/fr/Makefile.in 2009-10-12 17:44:25.949545398 -0500
|
||||
@@ -298,7 +298,7 @@
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
-mandir = $(datadir)/man/$(lang)
|
||||
+mandir = @mandir@/$(lang)
|
||||
mkdir_p = @mkdir_p@
|
||||
oldincludedir = @oldincludedir@
|
||||
pdfdir = @pdfdir@
|
|
@ -2,12 +2,14 @@
|
|||
|
||||
# Slackware build script for dia
|
||||
# Written by Matt Hayes (dominian@slackadelic.com
|
||||
# Updated for 64bit by Ash Wiren (ash@spooksoftware.com 19-08-2009
|
||||
|
||||
PRGNAM=dia
|
||||
VERSION=0.96.1
|
||||
VERSION=0.97
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
|
@ -15,31 +17,46 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP || exit 1
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
|
||||
cd $PRGNAM-$VERSION || exit 1
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# Fixup the fr mandir
|
||||
patch -p1 < $CWD/dia-0.97-fixup_fr_mandir.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|| exit 1
|
||||
--mandir=/usr/man \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make || exit 1
|
||||
make install DESTDIR=$PKG || exit 1
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
|
@ -47,9 +64,10 @@ make install DESTDIR=$PKG || exit 1
|
|||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
# docdir already exists :-)
|
||||
cp -a \
|
||||
AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
@ -57,4 +75,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
|
|||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="dia"
|
||||
VERSION="0.96.1"
|
||||
VERSION="0.97"
|
||||
HOMEPAGE="http://www.gnome.org/projects/dia/"
|
||||
DOWNLOAD="ftp://ftp.gnome.org/pub/gnome/sources/dia/0.96/dia-0.96.1.tar.bz2"
|
||||
MD5SUM="7b81b22baa2df55efe4845865dddc7b6"
|
||||
MAINTAINER="Matt Hayes"
|
||||
EMAIL="dominian@slackadelic.com"
|
||||
APPROVED="Michiel"
|
||||
DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/dia/0.97/dia-0.97.tar.bz2"
|
||||
MD5SUM="3d11f9aaa5a4923f0a5533962c87bdfb"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Ash Wiren"
|
||||
EMAIL="ash@spooksoftware.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
|
@ -1,5 +1,10 @@
|
|||
|
||||
if [ -x usr/bin/update-desktop-database ]; then
|
||||
./usr/bin/update-desktop-database ./usr/share/applications >/dev/null 2>&1
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
dia: Dia (diagram creation program)
|
||||
dia:
|
||||
dia: Dia is inspired by the commercial Windows program 'Visio', though
|
||||
|
|
Loading…
Reference in a new issue