mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
system/powertop: Removed (part of Slackware 13.1)
This commit is contained in:
parent
920696ee9f
commit
c671adb98d
5 changed files with 0 additions and 117 deletions
|
@ -1,23 +0,0 @@
|
|||
--- Makefile~ 2008-06-18 22:11:05.000000000 -0500
|
||||
+++ Makefile 2008-06-18 22:11:31.000000000 -0500
|
||||
@@ -1,8 +1,9 @@
|
||||
BINDIR=/usr/bin
|
||||
LOCALESDIR=/usr/share/locale
|
||||
-MANDIR=/usr/share/man/man1
|
||||
+MANDIR=/usr/man/man1
|
||||
WARNFLAGS=-Wall -W -Wshadow
|
||||
-CFLAGS?=-O1 -g ${WARNFLAGS}
|
||||
+CFLAGS?=-O1 -g
|
||||
+CFLAGS+=${WARNFLAGS}
|
||||
CC?=gcc
|
||||
|
||||
|
||||
@@ -24,7 +25,7 @@
|
||||
@(cd po/ && $(MAKE))
|
||||
|
||||
powertop.1.gz: powertop.1
|
||||
- gzip -c $< > $@
|
||||
+ gzip -9 -c $< > $@
|
||||
|
||||
install: powertop powertop.1.gz
|
||||
mkdir -p ${DESTDIR}${BINDIR}
|
|
@ -1,5 +0,0 @@
|
|||
PowerTOP is a Linux tool that finds the software component(s) that make your
|
||||
laptop use more power than necessary while it is idle. As of Linux kernel
|
||||
version 2.6.21, the kernel no longer has a fixed 1000Hz timer tick. This will
|
||||
(in theory) give a huge power savings because the CPU stays in low power mode
|
||||
for longer periods of time during system idle.
|
|
@ -1,60 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for powertop
|
||||
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||
|
||||
PRGNAM="powertop"
|
||||
VERSION="1.11"
|
||||
ARCH=${ARCH:-"i486"}
|
||||
BUILD=${BUILD:-"1"}
|
||||
TAG=${TAG:-"_SBo"}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-"/tmp/SBo"}
|
||||
PKG="$TMP/package-$PRGNAM-$VERSION"
|
||||
OUTPUT=${OUTPUT:-"/tmp"}
|
||||
|
||||
DOCS="COPYING Changelog README"
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-st .
|
||||
|
||||
# Patch the Makefile to:
|
||||
# Put the man page in the correct location
|
||||
# Use max compression on the man page
|
||||
# Handle $CFLAGS a bit more nicely
|
||||
patch < $CWD/Makefile.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
strip --strip-unneeded $PKG/usr/bin/powertop
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="powertop"
|
||||
VERSION="1.11"
|
||||
HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
|
||||
DOWNLOAD="http://www.lesswatts.org/projects/powertop/download/powertop-1.11.tar.gz"
|
||||
MD5SUM="3498f5983c683c3a57dce7379a722082"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Kyle Guinn"
|
||||
EMAIL="elyk03@gmail.com"
|
||||
APPROVED="rworkman,pprkut"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler----------------------------------------------------|
|
||||
powertop: PowerTOP (power usage monitor)
|
||||
powertop:
|
||||
powertop: PowerTOP is a Linux tool that finds the software component(s)
|
||||
powertop: that make your laptop use more power than necessary while it
|
||||
powertop: is idle. As of Linux kernel version 2.6.21, the kernel no
|
||||
powertop: longer has a fixed 1000Hz timer tick. This will (in theory)
|
||||
powertop: give a huge power savings because the CPU stays in low power
|
||||
powertop: mode for longer periods of time during system idle.
|
||||
powertop:
|
||||
powertop:
|
||||
powertop:
|
Loading…
Reference in a new issue