mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
network/yt-dlp: Updated for version 2023.03.04.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
b669acf9a3
commit
c665cb3090
3 changed files with 6 additions and 22 deletions
|
@ -1,12 +0,0 @@
|
|||
diff --git a/yt_dlp/plugins.py b/yt_dlp/plugins.py
|
||||
index 6eecdb4d0..85ff5f19b 100644
|
||||
--- a/yt_dlp/plugins.py
|
||||
+++ b/yt_dlp/plugins.py
|
||||
@@ -88,7 +88,7 @@ def _get_package_paths(*root_paths, containing_folder='plugins'):
|
||||
candidate = path / parts
|
||||
if candidate.is_dir():
|
||||
yield candidate
|
||||
- elif path.suffix in ('.zip', '.egg', '.whl'):
|
||||
+ elif path.suffix in ('.zip', '.egg', '.whl') and not path.is_dir():
|
||||
if parts in dirs_in_zip(path):
|
||||
yield candidate
|
|
@ -12,13 +12,14 @@
|
|||
# dependency for pipe-viewer (and might be useful as a dep for other
|
||||
# things), it has to exist on SBo.
|
||||
|
||||
# 20230402 bkw: updated for v2023.03.04
|
||||
# 20230222 bkw: updated for v2023.02.17
|
||||
# 20230104 bkw: updated for v2023.01.02
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=yt-dlp
|
||||
VERSION=${VERSION:-2023.02.17}
|
||||
VERSION=${VERSION:-2023.03.04}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -55,11 +56,6 @@ chown -R root:root .
|
|||
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
|
||||
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
|
||||
|
||||
# https://github.com/yt-dlp/yt-dlp/issues/6306, reported by KG Hammarlund.
|
||||
# Not sure what triggers the issue (I don't have it on my system), but
|
||||
# this will be in the next release anyway I think.
|
||||
patch -p1 < $CWD/plugin_loading.diff
|
||||
|
||||
# hardcoded paths.
|
||||
sed -i -e "s,share/doc/yt_dlp,doc/$PRGNAM-$VERSION," \
|
||||
-e "s,share/man,man," \
|
||||
|
@ -70,7 +66,7 @@ python3 setup.py install --root=$PKG
|
|||
|
||||
gzip -9 $PKG/usr/man/man1/*
|
||||
|
||||
# AUTHORS is 0 bytes in 2022.01.21
|
||||
# AUTHORS is 0 bytes in 2022.01.21 (still is, in 2023.03.04).
|
||||
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mkdir -p $PKGDOC
|
||||
cp -a CONTRIBUTORS LICENSE *.md $PKGDOC
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="yt-dlp"
|
||||
VERSION="2023.02.17"
|
||||
VERSION="2023.03.04"
|
||||
HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
|
||||
DOWNLOAD="https://github.com/yt-dlp/yt-dlp/releases/download/2023.02.17/yt-dlp.tar.gz"
|
||||
MD5SUM="d83e85f83a4acd8283c1bf1543143915"
|
||||
DOWNLOAD="https://github.com/yt-dlp/yt-dlp/releases/download/2023.03.04/yt-dlp.tar.gz"
|
||||
MD5SUM="392ead72a00cda0ade947af40fb91039"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue