mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
academic/genius: Updated for version 1.0.11.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
f3cf70a37b
commit
c638ad19b1
4 changed files with 36 additions and 10 deletions
|
@ -9,7 +9,8 @@ is designed to mimic how mathematics is usually written.
|
|||
Definite dependencies: rarian (as scrollkeeper replacement)
|
||||
is available on SBo.
|
||||
|
||||
Optional dependencies: libgnomeui (available on SBo)
|
||||
if you have the optional dependencies, pass the variable
|
||||
If you would like the GUI interface as well, it requires
|
||||
libgnomeui and gtksourceview (available on SBo)
|
||||
If you have these dependencies, pass the variable
|
||||
of GNOME=YES (or anything that isn't NO ;)
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for genius
|
||||
# Copyright 2009 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
|
||||
# Copyright 2009,2010 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
#
|
||||
|
||||
PRGNAM=genius
|
||||
VERSION=${VERSION:-1.0.5}
|
||||
VERSION=${VERSION:-1.0.11}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -32,7 +32,6 @@ if [ -z "$ARCH" ]; then
|
|||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -68,7 +67,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -77,6 +76,9 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Appearantly, some do not know that Makefiles require tabs, not spaces...
|
||||
cat $CWD/hidden-spaces.patch | patch -p1
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="genius"
|
||||
VERSION="1.0.5"
|
||||
VERSION="1.0.11"
|
||||
HOMEPAGE="http://www.5z.com/jirka/genius.html"
|
||||
DOWNLOAD="http://ftp.5z.com/pub/genius/genius-1.0.5.tar.bz2"
|
||||
MD5SUM="c81d70d1d17b99536293b1231211a167"
|
||||
DOWNLOAD="http://ftp.5z.com/pub/genius/genius-1.0.11.tar.bz2"
|
||||
MD5SUM="7f4fdc29237c9f68a7b2b139b7788968"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Vincent Batts"
|
||||
EMAIL="vbatts@hashbangbash.com"
|
||||
APPROVED="michiel"
|
||||
APPROVED="dsomero"
|
||||
|
|
23
academic/genius/hidden-spaces.patch
Normal file
23
academic/genius/hidden-spaces.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
diff -uar genius-1.0.11.orig//gtkextra/Makefile.in genius-1.0.11//gtkextra/Makefile.in
|
||||
--- genius-1.0.11.orig//gtkextra/Makefile.in 2010-09-10 01:49:00.000000000 -0400
|
||||
+++ genius-1.0.11//gtkextra/Makefile.in 2010-09-27 22:33:46.531620992 -0400
|
||||
@@ -800,13 +800,13 @@
|
||||
|
||||
|
||||
$(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|
||||
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
+ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
|
||||
+ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
|
||||
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
$(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
|
||||
- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|
||||
- || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
+ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
|
||||
+ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
|
||||
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
|
||||
|
||||
$(srcdir)/gtkextratypebuiltins.h: $(public_h_sources)
|
||||
( cd $(srcdir) && glib-mkenums \
|
Loading…
Reference in a new issue