mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
misc/cwiid: Fix build with python 3.10.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
1648752ee8
commit
c5a9e024db
2 changed files with 13 additions and 1 deletions
|
@ -92,10 +92,11 @@ for i in $( cat debian/patches/series ); do
|
|||
[ -e $i ] && patch -p1 < debian/patches/$i
|
||||
done
|
||||
|
||||
patch -p1 < $CWD/python310.patch
|
||||
|
||||
autoreconf -if
|
||||
|
||||
./configure \
|
||||
--disable-ldconfig \
|
||||
--prefix=/usr \
|
||||
--libdir=$LIBDIR \
|
||||
--sysconfdir=/etc \
|
||||
|
|
11
misc/cwiid/python310.patch
Normal file
11
misc/cwiid/python310.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- cwiid/configure.ac.orig 2021-10-25 12:06:48.965614546 +0700
|
||||
+++ cwiid/configure.ac 2021-10-25 12:07:01.190613822 +0700
|
||||
@@ -67,7 +67,7 @@
|
||||
fi
|
||||
AC_SUBST(PYTHON)
|
||||
if test $PYTHON; then
|
||||
- PYTHON_VERSION=[`$PYTHON -c 'import sys; print (sys.version[:3])'`]
|
||||
+ PYTHON_VERSION=[`$PYTHON -c 'import sys; print (sys.version[:4])'`]
|
||||
AC_SUBST(PYTHON_VERSION)
|
||||
AC_DEFINE([HAVE_PYTHON],1,[Define to 1 if python support is enabled])
|
||||
fi
|
Loading…
Reference in a new issue