mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
games/astromenace: Added patch for newer freetype2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
d09db4855e
commit
c546673494
2 changed files with 16 additions and 2 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for AstroMenace
|
||||
|
||||
# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
|
||||
# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,7 +25,7 @@
|
|||
SRCNAM=astromenace-src
|
||||
PRGNAM=$(echo $SRCNAM | cut -c1-11)
|
||||
VERSION=${VERSION:-1.3.2}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -70,6 +70,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix freetype2 header path
|
||||
patch -p1 < $CWD/ft2_path.patch
|
||||
|
||||
mkdir -p build
|
||||
cmake ./ # create Makefile
|
||||
make # build game
|
||||
|
|
11
games/astromenace/ft2_path.patch
Normal file
11
games/astromenace/ft2_path.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- AstroMenace/CMakeLists.orig.txt 2015-09-25 05:48:58.014083691 +0300
|
||||
+++ AstroMenace/CMakeLists.txt 2015-09-25 05:59:11.322416282 +0300
|
||||
@@ -192,7 +192,7 @@
|
||||
ELSE(FREETYPE_LIBRARY)
|
||||
MESSAGE(FATAL_ERROR "freetype not found")
|
||||
ENDIF(FREETYPE_LIBRARY)
|
||||
-FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
|
||||
+FIND_PATH(FREETYPE_INCLUDE_DIR_freetype2 /usr/include/freetype2/config/ftheader.h
|
||||
HINTS
|
||||
$ENV{FREETYPE_DIR}/include/freetype2
|
||||
PATHS
|
Loading…
Reference in a new issue