academic/abntex: Added to 12.2 repository

This commit is contained in:
Andre Barboza 2010-05-12 23:27:35 +02:00 committed by Robby Workman
parent 12627a9ec0
commit c3fb778f26
6 changed files with 159 additions and 0 deletions

View file

@ -0,0 +1,41 @@
--- Makefile 2006-09-09 21:25:16.000000000 -0300
+++ Makefile.new 2009-04-20 16:06:57.905013404 -0300
@@ -7,14 +7,17 @@
#altere a linha abaixo se o seu tetex não puder se detetado
#pelo comando kpsewich, na dúvida faça um "make test"
#TEXDIR= /tmp/test
-export TEXDIR= ${shell kpsewhich --expand-path='$$TEXMFMAIN'}
+export TEXDIR= ${DESTDIR}/${shell kpsewhich --expand-path='$$TEXMFMAIN'}
-export USRLOCAL=/usr/local/bin
+export USRLOCAL=${DESTDIR}/usr/bin
#Do "man lyx":
#The system directory is determined by searching for the
# file "chkconfig.ltx".
-export LYXDIR=${dir ${shell find /usr/share/lyx -name chkconfig.ltx}}
+export LYXDIR=${dir ${shell find /usr/share/lyx -name chkconfig.ltx}}
+ifneq (${LYXDIR},)
+export LYXDIR=${DESTDIR}/${LYXDIR}
+endif
#diretório corrente onde se expandiu o cvs do abntex
export ABNTEXDIR=$(notdir $(shell pwd))
@@ -119,14 +122,17 @@
#install e uninstall específico para tetex localizado em ${TEXDIR}
install-tex:
+ mkdir -p ${TEXDIR}
cp ${OPVR} --preserve texmf/* ${TEXDIR}
install-lyx:
ifneq (${LYXDIR},)
+ mkdir -p ${LYXDIR}
cp ${OPVR} --preserve lyx/* ${LYXDIR}
endif
install-bin:
+ mkdir -p ${USRLOCAL}
cp ${OPVR} --preserve bin/* ${USRLOCAL}
post-install:

6
academic/abntex/README Normal file
View file

@ -0,0 +1,6 @@
abnTeX (LATEX macros that follow the rules of ABNT)
abnTeX are LATEX macros that follow the rules of ABNT (Associacao
Brasileira de Normas Tecnicas). This lets you write your papers,
theses, and dissertations in full accordance with ABNT standards
without much effort.

View file

@ -0,0 +1,84 @@
#!/bin/sh
# Slackware build script for abntex
# Copyright 2009 Andre Barboza <bmg.andre@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Slightly modified by Robby Workman <rworkman@slackbuilds.org>
PRGNAM=abntex
VERSION=${VERSION:-0.9_beta2}
ARCH=${ARCH:-noarch}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
MAJOR=$(echo $VERSION | cut -d _ -f 1)
MINOR=$(echo $VERSION | cut -d _ -f 2)
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
FORCE_LYX=${FORCE_LYX:-NO}
LYX_PATH=${LYX_PATH:-/usr/share/lyx}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$MAJOR
tar xvf $CWD/$PRGNAM-$MAJOR-$MINOR.tar.gz
cd $PRGNAM-$MAJOR
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch < $CWD/Makefile.diff
find texmf/ lyx/ -type f -exec chmod 644 {} \;
echo quit | make doc
make install DESTDIR=$PKG
# Lyx may not have been installed
if [ "$FORCE_LYX" != "NO" ]; then
mkdir -p $PKG/usr/share/lyx
cp -rf lyx/layouts/ $PKG/$LYX_PATH
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
LEIAME LEIAME.administracao LEIAME.linux compiled.docs/* lyx/ \
$PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View file

@ -0,0 +1,8 @@
PRGNAM="abntex"
VERSION="0.9_beta2"
HOMEPAGE="http://abntex.codigolivre.org.br/"
DOWNLOAD="http://codigolivre.org.br/frs/download.php/5337/abntex-0.9-beta2.tar.gz"
MD5SUM="4c5bc2d5388ddf03df754072116ab1f8"
MAINTAINER="Andre Barboza"
EMAIL="bmg.andre@gmail.com"
APPROVED="rworkman"

View file

@ -0,0 +1 @@
chroot . /usr/share/texmf/bin/texhash

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
abntex: abnTeX (LATEX macros that follow the rules of ABNT)
abntex:
abntex: abnTeX are LATEX macros that follow the rules of ABNT (Associacao
abntex: Brasileira de Normas Tecnicas). This lets you write your papers,
abntex: theses and dissertations in full accordance with ABNT standards
abntex: without much effort.
abntex:
abntex: Homepage: http://abntex.codigolivre.org.br/
abntex:
abntex:
abntex: