mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
games/defendguin: Updated for version 0.0.12.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
a6818c11b5
commit
c156d5d150
3 changed files with 9 additions and 10 deletions
|
@ -7,16 +7,14 @@
|
|||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
PRGNAM=defendguin
|
||||
VERSION=${VERSION:-0.0.11}
|
||||
VERSION=${VERSION:-0.0.12}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="defendguin"
|
||||
VERSION="0.0.11"
|
||||
VERSION="0.0.12"
|
||||
HOMEPAGE="http://www.newbreedsoftware.com/defendguin/"
|
||||
DOWNLOAD="ftp://ftp.tuxpaint.org/unix/x/defendguin/src/defendguin-0.0.11.tar.gz"
|
||||
MD5SUM="c8040e39f199c5338625066025ec2395"
|
||||
DOWNLOAD="ftp://ftp.tuxpaint.org/unix/x/defendguin/src/defendguin-0.0.12.tar.gz"
|
||||
MD5SUM="a543e3f5f4e935546116384c6f20d782"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -Naur defendguin-0.0.11/Makefile defendguin-0.0.11.patched/Makefile
|
||||
--- defendguin-0.0.11/Makefile 2006-01-29 04:23:31.000000000 -0500
|
||||
+++ defendguin-0.0.11.patched/Makefile 2009-04-16 03:18:04.000000000 -0400
|
||||
diff -Naur defendguin-0.0.12/Makefile defendguin-0.0.12.patched/Makefile
|
||||
--- defendguin-0.0.12/Makefile 2009-11-05 16:21:34.000000000 -0500
|
||||
+++ defendguin-0.0.12.patched/Makefile 2013-06-11 21:46:07.000000000 -0400
|
||||
@@ -9,11 +9,12 @@
|
||||
|
||||
# User-definable stuff:
|
||||
|
@ -26,7 +26,7 @@ diff -Naur defendguin-0.0.11/Makefile defendguin-0.0.11.patched/Makefile
|
|||
-DJOY_$(JOY)
|
||||
SDL_LIB=$(SDL_LDFLAGS) $(MIXER)
|
||||
|
||||
@@ -37,13 +38,17 @@
|
||||
@@ -37,14 +38,17 @@
|
||||
make defendguin MIXER= NOSOUNDFLAG=NOSOUND
|
||||
|
||||
install: defendguin
|
||||
|
@ -35,6 +35,7 @@ diff -Naur defendguin-0.0.11/Makefile defendguin-0.0.11.patched/Makefile
|
|||
- chmod -R a+rX,g-w,o-w $(DATA_PREFIX)
|
||||
- cp defendguin $(BIN_PREFIX)/
|
||||
- chmod a+rx,g-w,o-w $(BIN_PREFIX)/defendguin
|
||||
- -mkdir -p $(MAN_PREFIX)/man/man6/
|
||||
- cp src/defendguin.6 $(MAN_PREFIX)/man/man6/
|
||||
- chmod a+rx,g-w,o-w $(MAN_PREFIX)/man/man6/defendguin.6
|
||||
+ install -d $(DESTDIR)$(DATA_PREFIX)
|
||||
|
|
Loading…
Reference in a new issue