office/teapot: Removed (website and source are not available).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2022-03-05 09:16:01 +07:00
parent 1651335412
commit c03d4b6ba4
No known key found for this signature in database
GPG key ID: 3F617144D7238786
6 changed files with 0 additions and 235 deletions

View file

@ -1,12 +0,0 @@
Teapot is a compact spreadsheet software originally written by Michael
Haardt. It features a (n)curses-based text terminal interface, and
recently also a FLTK-based GUI.
Another interesting feature is its modern approach to spread
sheet theory: It sports true three-dimensional tables and iterative
expressions. And since it breaks compatibility with the usual notions
of big spreadsheet packages, it can also throw old syntactic cruft
over board which many spreadsheets still inherit from the days of
VisiCalc on ancient CP/M systems.
Optional dependency: fltk

View file

@ -1,41 +0,0 @@
diff -Naur teapot-2.3.0/CMakeLists.txt teapot-2.3.0.patched/CMakeLists.txt
--- teapot-2.3.0/CMakeLists.txt 2020-11-19 00:18:02.217657446 -0500
+++ teapot-2.3.0.patched/CMakeLists.txt 2020-11-19 00:22:05.201635357 -0500
@@ -40,7 +40,7 @@
install(TARGETS teapot DESTINATION bin)
endif ()
-find_package(FLTK NO_MODULE)
+find_package(FLTK)
if (FLTK_FOUND)
include("${FLTK_USE_FILE}")
@@ -52,13 +52,13 @@
if (ENABLE_STATIC)
target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
else ()
- target_link_libraries(fteapot teapotlib fltk_SHARED fltk_images_SHARED ${LIB_PORTABLEXDR})
+ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
endif ()
else ()
if (ENABLE_STATIC)
target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
else ()
- target_link_libraries(fteapot teapotlib fltk_SHARED ${LIB_PORTABLEXDR})
+ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
endif ()
endif ()
install(TARGETS fteapot DESTINATION bin)
diff -Naur teapot-2.3.0/fteapot.fl teapot-2.3.0.patched/fteapot.fl
--- teapot-2.3.0/fteapot.fl 2020-11-19 00:15:47.506669691 -0500
+++ teapot-2.3.0.patched/fteapot.fl 2020-11-19 00:16:05.569668049 -0500
@@ -11,6 +11,9 @@
decl {\#include <fcntl.h>} {private global
}
+decl {\#include <unistd.h>} {private global
+}
+
decl {\#define shadow _shadow} {private global
}

View file

@ -1,11 +0,0 @@
diff -Naur teapot-2.3.0/scanner.c teapot-2.3.0.patched/scanner.c
--- teapot-2.3.0/scanner.c 2012-02-06 06:30:53.000000000 -0500
+++ teapot-2.3.0.patched/scanner.c 2020-11-19 00:24:24.289622714 -0500
@@ -25,6 +25,7 @@
#include "main.h"
#include "misc.h"
#include "scanner.h"
+#include "utf8.h"
/*}}}*/
/* identcode -- return number of identifier */ /*{{{*/

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
teapot: teapot (ncurses based spreadsheet)
teapot:
teapot: Teapot is a compact spreadsheet software originally
teapot: written by Michael Haardt. It features a (n)curses-based text
teapot: terminal interface, and recently also a FLTK-based GUI.
teapot:
teapot:
teapot:
teapot:
teapot:
teapot:

View file

@ -1,140 +0,0 @@
#!/bin/bash
# Slackware build script for teapot
# Copyright 2016 Jostein Berntsen <jvbernts@online.no>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20201122 bkw: Grr. Forgot to git add the diffs.
# 20201119 bkw: modified by SlackBuilds.org:
# - BUILD=2.
# - Fix fltk builds.
# - Shut up a compiler warning.
# - Restore original homepage/download, since the site is back up.
# - Fix README to comply with 72-column limit.
# - Fix doubleplus ungood refs undirectory /usr/share/doc in man page.
# - Since the man page says there's a manual, actually install the
# manual as part of the package. To avoid a dependency on lyx (and
# consequently qt5!), pull the prebuilt docs out of upstream's
# binary package.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=teapot
VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
# Extract *only* the docs from the binary package:
tar xvf $CWD/Teapot-$VERSION-Linux-i386.tar.gz --wildcards '*/share/doc/*'
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# 20201119 bkw: README says fltk is an optional dep, but it wasn't
# being picked up by cmake.
patch -p1 < $CWD/fix_fltk_build.diff
# 20201119 bkw: While we're in a patching state of mind, fix a
# compiler warning.
patch -p1 < $CWD/fix_mbslen_warning.diff
# 20201119 bkw: No such thing as /usr/share/doc/teapot.
sed -i "s,/usr/share/doc/$PRGNAM,/usr/doc/$PRGNAM-$VERSION,g" $PRGNAM.1
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS -I/usr/include/tirpc -Wl,-ltirpc" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_HELP=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mv $PKG/usr/share/man/ $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
rm -rf $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# 20201119 bkw: Install the PDF and HTML docs.
cd Teapot-$VERSION-Linux/share/doc/$PRGNAM
mv html *.pdf $PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -1,12 +0,0 @@
PRGNAM="teapot"
VERSION="2.3.0"
HOMEPAGE="https://www.syntax-k.de/projekte/teapot/"
DOWNLOAD="https://www.syntax-k.de/projekte/teapot/teapot-2.3.0.tar.gz \
https://www.syntax-k.de/projekte/teapot/Teapot-2.3.0-Linux-i386.tar.gz"
MD5SUM="ae59f90a5f70971703abccf0991dbd58 \
17ecda70a8478043e4a8b622e178bc55"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Jostein Berntsen"
EMAIL="jvbernts@online.no"