system/reiser4progs: Updated for version 1.1.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2017-02-11 07:17:16 +07:00
parent aaa5cc56a1
commit bed555f20f
4 changed files with 15 additions and 34 deletions

View file

@ -1,8 +0,0 @@
--- include/repair/Makefile.am~ 2009-01-08 15:34:27.000000000 -0600
+++ include/repair/Makefile.am 2011-02-23 22:23:25.654384304 -0600
@@ -3,4 +3,4 @@
master.h format.h journal.h node.h place.h item.h \
filter.h disk_scan.h twig_scan.h add_missing.h \
semantic.h lost_found.h cleanup.h tree.h alloc.h \
- object.h status.h backup.h oid.h pset.h
+ status.h backup.h oid.h pset.h

View file

@ -5,13 +5,13 @@
# Written by Kurt Erickson <kurt_erickson@att.net>
PRGNAM=reiser4progs
VERSION=${VERSION:-1.0.7}
VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@ -22,8 +22,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@ -43,22 +43,14 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# fix typo in a makefile.am that trips up more recent automake
patch -p0 < $CWD/fix_typo.patch
# reiser4progs ships with older, incompatible libtools
libtoolize --force --copy
aclocal && autoheader && autoconf && automake --add-missing
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@ -72,8 +64,6 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-libminimal \
--build=$ARCH-slackware-linux
# --with-libaal=/usr/lib${LIBDIRSUFFIX} \
make
make install DESTDIR=$PKG
@ -84,8 +74,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS BUGS COPYING CREDITS CUSTOM_INSTALL_README ChangeLog \
cp -a AUTHORS BUGS COPYING CREDITS CUSTOM_INSTALL_README ChangeLog \
INSTALL INSTALL_README README THANKS TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,8 +1,8 @@
PRGNAM="reiser4progs"
VERSION="1.0.7"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/reiser4/"
DOWNLOAD="http://korg.cs.utah.edu/pub/linux/utils/fs/reiser4/reiser4progs/reiser4progs-1.0.7.tar.bz2"
MD5SUM="0f637512ad11f73739e0e44057bd59e2"
VERSION="1.1.0"
HOMEPAGE="https://sourceforge.net/projects/reiser4/"
DOWNLOAD="https://sourceforge.net/projects/reiser4/files/reiser4-utils/reiser4progs/reiser4progs-1.1.0.tar.gz"
MD5SUM="4abfda040a0ef152bc2f42152e247a5e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libaal"

View file

@ -11,7 +11,7 @@ reiser4progs:
reiser4progs: The reiser4progs package contains the reiser4 utilities, including
reiser4progs: fsck and mkfs, and the library for reiser4 filesystem access.
reiser4progs:
reiser4progs: Homepage: http://www.kernel.org/pub/linux/utils/fs/reiser4/
reiser4progs: Homepage: http://sourceforge.net/projects/reiser4/
reiser4progs:
reiser4progs:
reiser4progs: