office/LibreOffice: Updated for version 7.4.1.2

Signed-off-by: Christoph Willing <chris.willing@linux.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Christoph Willing 2022-09-16 22:51:28 +10:00 committed by Willy Sudiarto Raharjo
parent 5cf8770df5
commit beb89b5059
No known key found for this signature in database
GPG key ID: 3F617144D7238786
3 changed files with 36 additions and 6 deletions

View file

@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=LibreOffice
SRCNAM=libreoffice
VERSION=${VERSION:-7.4.0.3}
VERSION=${VERSION:-7.4.1.2}
SHORT_VERSION=${VERSION%.*.*}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -293,6 +293,7 @@ fi
patch -p0 < $CWD/no-check-if-root.diff
#patch -p0 < $CWD/skia-freetype-2.11.diff
#patch -p0 < $CWD/bison_yyn-yyrule_rename.diff
patch -p1 < $CWD/libreoffice-7.4.0.3-poppler_22_09_fixes-1.patch
# GCC10 requirements (Tx alienBOB)
sed -i external/libebook/ExternalProject_libebook.mk \

View file

@ -1,10 +1,10 @@
PRGNAM="LibreOffice"
VERSION="7.4.0.3"
VERSION="7.4.1.2"
HOMEPAGE="https://www.libreoffice.org"
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.4.0/libreoffice-7.4.0.3.tar.xz \
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.4.0.3-srcs.tar.xz"
MD5SUM="5bfb607d302a21315faa5bb49c57cebe \
6bbabc7b207a3ffb2a36ad7bb9cddc2a"
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.4.1/libreoffice-7.4.1.2.tar.xz \
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.4.1.2-srcs.tar.xz"
MD5SUM="2fb28cbd5a436e05fccf3b73ca77e6ed \
bb2e0ad08305f80d4c8df4123ea07149"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zulu-openjdk11 apache-ant perl-Archive-Zip"

View file

@ -0,0 +1,29 @@
Submitted By: Douglas R. Reno <renodr at linuxfromscratch dot org>
Date: 2022-09-03
Initial Package Version: 7.4.0.3
Origin: Gentoo (commit 3fe3e0dc873e97eb1bb5ccb2846fffee35182caa in gentoo.git)
Upstream Status: Submitted
Description: Adapts libreoffice-7.4.0.3 to changes in Poppler's API,
similar to Inkscape's poppler-22.09 patch.
diff -Naurp libreoffice-7.4.0.3.orig/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx libreoffice-7.4.0.3/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
--- libreoffice-7.4.0.3.orig/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2022-08-10 09:14:32.000000000 -0500
+++ libreoffice-7.4.0.3/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2022-09-03 10:39:04.244841138 -0500
@@ -678,8 +678,16 @@ void PDFOutDev::updateLineDash(GfxState
return;
assert(state);
- double* dashArray; int arrayLen; double startOffset;
+ int arrayLen; double startOffset;
+#if POPPLER_CHECK_VERSION(22, 9, 0)
+ const double* dashArray;
+ const std::vector<double> &dash = state->getLineDash(&startOffset);
+ dashArray = dash.data();
+ arrayLen = dash.size();
+#else
+ double* dashArray;
state->getLineDash(&dashArray, &arrayLen, &startOffset);
+#endif
printf( "updateLineDash" );
if( arrayLen && dashArray )