mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
libraries/loudmouth: Updated for version 1.4.3
This commit is contained in:
parent
72ed4163d8
commit
be43b569ae
3 changed files with 32 additions and 6 deletions
15
libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch
Normal file
15
libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
# Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=272027
|
||||
# Patch from mandriva
|
||||
--- a/configure.ac 2009-05-30 17:59:03.000000000 +0200
|
||||
+++ b/configure.ac 2009-05-30 18:02:24.000000000 +0200
|
||||
@@ -146,8 +146,9 @@
|
||||
enable_ssl=no
|
||||
if test "x$ac_ssl" = "xgnutls"; then
|
||||
dnl Look for GnuTLS
|
||||
- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
|
||||
+ PKG_CHECK_EXISTS([gnutls >= $GNUTLS_REQUIRED], have_libgnutls=yes, have_libgnutls=no)
|
||||
if test "x$have_libgnutls" = "xyes"; then
|
||||
+ PKG_CHECK_MODULES(LIBGNUTLS, [gnutls >= $GNUTLS_REQUIRED])
|
||||
CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
|
||||
LIBS="$LIBS $LIBGNUTLS_LIBS"
|
||||
AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for loudmouth
|
||||
|
||||
# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
|
||||
# Copyright 2008-2009 Heinz Wiesinger, Amsterdam, The Netherlands
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,7 +25,7 @@
|
|||
PRGNAM=loudmouth
|
||||
VERSION=1.4.3
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
|
@ -35,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
@ -56,10 +59,16 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
#fix finding gnutls-2.8
|
||||
patch -p1 -i $CWD/loudmouth-1.4.3-gnutls28.patch
|
||||
|
||||
autoreconf -vif
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--disable-static \
|
||||
|
@ -79,4 +88,4 @@ mkdir -p $PKG/install
|
|||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="loudmouth"
|
||||
VERSION="1.4.3"
|
||||
HOMEPAGE="http://www.loudmouth-project.org/"
|
||||
DOWNLOAD="http://ftp.imendio.com/pub/imendio/loudmouth/src/loudmouth-1.4.3.tar.bz2"
|
||||
DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/loudmouth/1.4/loudmouth-1.4.3.tar.bz2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM="55339ca42494690c3942ee1465a96937"
|
||||
MAINTAINER="ppr:kut"
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Heinz Wiesinger"
|
||||
EMAIL="pprkut@liwjatan.at"
|
||||
APPROVED="dsomero"
|
||||
|
|
Loading…
Reference in a new issue