network/torsocks: Updated for version 2.1.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2016-01-13 22:53:17 +07:00
parent 654a2c70b7
commit bdf3d61c08
4 changed files with 17 additions and 35 deletions

View file

@ -11,5 +11,5 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
config etc/torsocks.conf.new
config etc/tor/torsocks.conf.new

View file

@ -1,16 +0,0 @@
--- src/tsocks.c 2011-10-25 17:49:50.000000000 -0400
+++ src/tsocks.c 2012-02-21 11:09:20.000000000 -0500
@@ -175,9 +175,9 @@
#define LOAD_ERROR(s,l) { \
char *error; \
error = dlerror(); \
- show_msg(l, "The symbol %s() was not found in any shared " \
- "library. The error reported was: %s!\n", s, \
- (error)?error:"not found"); \
+ if (error) \
+ show_msg(l, "The symbol %s() was not found in any shared " \
+ "library. The error reported was: %s!\n", s, error); \
dlerror(); \
}
pthread_mutex_lock(&torsocks_init_mutex);

View file

@ -5,8 +5,8 @@
# Written by Vincent Batts, vbatts@hashbangbash.com
PRGNAM=torsocks
VERSION=${VERSION:-1.1}
BUILD=${BUILD:-2}
VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -42,28 +42,28 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix a hardcoded lib path.
sed -i -e 's|@prefix@/lib|@libdir@|' src/Makefile.in
sed -i -e 's|@prefix@/lib|@libdir@|' src/torsocks.in
patch -p0 < $CWD/symbol_lookup.patch
sed -i -e 's|@prefix@/lib|@libdir@|' src/Makefile.am
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./autogen.sh
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--enable-static=no \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
@ -71,7 +71,7 @@ make
make install DESTDIR=$PKG
# do not clobber
mv $PKG/etc/torsocks.conf{,.new}
mv $PKG/etc/tor/torsocks.conf{,.new}
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@ -80,9 +80,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
INSTALL FAQ README* COPYING TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog INSTALL LICENSE README.md TODO gpl-2.0.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View file

@ -1,8 +1,8 @@
PRGNAM="torsocks"
VERSION="1.1"
HOMEPAGE="http://torsocks.googlecode.com/"
DOWNLOAD="http://torsocks.googlecode.com/files/torsocks-1.1.tar.gz"
MD5SUM="1704fd009ed1a1c1dc9c6b72305a5449"
VERSION="2.1.0"
HOMEPAGE="https://gitweb.torproject.org/torsocks.git"
DOWNLOAD="https://github.com/dgoulet/torsocks/archive/v2.1.0.tar.gz"
MD5SUM="70e68c935071b92ac06b1e3faa9c59f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""