mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
games/xonotic: fix -version-info as requested by Hunter Sezen
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ad04e44f28
commit
bc484d4831
2 changed files with 35 additions and 1 deletions
31
games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff
Normal file
31
games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff --git a/Makefile.am b/Makefile.am
|
||||
index d21887d..07338eb 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -5,7 +5,7 @@ blind_id_SOURCES = main.c
|
||||
blind_id_LDADD = libd0_blind_id.la
|
||||
|
||||
lib_LTLIBRARIES = libd0_blind_id.la
|
||||
-# versioninfo:
|
||||
+# version-info:
|
||||
# - compatible interface change: c:r:a -> c+1:0:a+1
|
||||
# - incompatible interface change: c:r:a -> c+1:0:0
|
||||
# - internal change: c:r:a -> c:r+1:a
|
||||
@@ -29,7 +29,7 @@ libd0_blind_id_la_SOURCES += d0_bignum-gmp.c
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
-libd0_blind_id_la_LDFLAGS = -versioninfo 7:1:7
|
||||
+libd0_blind_id_la_LDFLAGS = -version-info 7:1:7
|
||||
libd0_blind_id_la_CFLAGS = -fvisibility=hidden -Wold-style-definition -Wstrict-prototypes -Wsign-compare -Wdeclaration-after-statement
|
||||
library_includedir = $(includedir)/d0_blind_id
|
||||
library_include_HEADERS = d0_blind_id.h d0.h
|
||||
@@ -40,7 +40,7 @@ if ENABLE_RIJNDAEL
|
||||
lib_LTLIBRARIES += libd0_rijndael.la
|
||||
libd0_rijndael_la_SOURCES = d0_rijndael.c \
|
||||
d0_rijndael.h
|
||||
-libd0_rijndael_la_LDFLAGS = -versioninfo 0:0:0
|
||||
+libd0_rijndael_la_LDFLAGS = -version-info 0:0:0
|
||||
libd0_rijndael_la_CFLAGS = -fvisibility=hidden -Wold-style-definition -Wstrict-prototypes -Wsign-compare -Wdeclaration-after-statement
|
||||
library_include_HEADERS += d0_rijndael.h
|
||||
pkgconfig_HEADERS += d0_rijndael.pc
|
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=xonotic
|
||||
VERSION=${VERSION:-0.8.2}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -75,6 +75,9 @@ mkdir -p \
|
|||
$PKG/usr/share/$PRGNAM \
|
||||
$PKG/usr/share/{applications,pixmaps}
|
||||
|
||||
# Fix -version-info as requested by Hunter Sezen
|
||||
patch -p1 < $CWD/0d3d1f2655901776b2fc3e911eb78478412f789a.diff source/d0_blind_id/Makefile.am
|
||||
|
||||
cd source/d0_blind_id
|
||||
|
||||
autoreconf -fi
|
||||
|
|
Loading…
Reference in a new issue