development/MySQL-python: Updated for version 1.2.3.

This commit also fixes dep info in README (rworkman)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
ponce 2012-05-08 07:36:58 +02:00 committed by Robby Workman
parent 11d0e8aa16
commit bc04d974ab
4 changed files with 22 additions and 7 deletions

View file

@ -5,7 +5,7 @@
# Written by Jick Nan (jick.nan@gmail.com)
PRGNAM=MySQL-python
VERSION=1.2.3c1
VERSION=1.2.3
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -49,13 +49,16 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# patch MANIFEST.in
patch -p1 < $CWD/docs.patch
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog GPL HISTORY PKG-INFO README doc/*.txt \
cp -a HISTORY PKG-INFO README doc/*.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,8 +1,8 @@
PRGNAM="MySQL-python"
VERSION="1.2.3c1"
VERSION="1.2.3"
HOMEPAGE="http://cheeseshop.python.org/pypi/MySQL-python/"
DOWNLOAD="http://downloads.sourceforge.net/mysql-python/MySQL-python-1.2.3c1.tar.gz"
MD5SUM="310dd856e439d070b59ece6dd7a0734d"
DOWNLOAD="http://downloads.sourceforge.net/mysql-python/MySQL-python-1.2.3.tar.gz"
MD5SUM="215eddb6d853f6f4be5b4afc4154292f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"

View file

@ -8,5 +8,3 @@ The design goals are:
* Thread-friendliness (threads will not block each other)
MySQL-3.23 through 5.1 and Python-2.3 through 2.6 are currently supported.
This requires the Python setuptools (pysetuptools on SlackBuilds.org).

View file

@ -0,0 +1,14 @@
--- MySQL-python-1.2.3/MANIFEST.in.orig 2010-11-20 17:45:00.000000000 +0100
+++ MySQL-python-1.2.3/MANIFEST.in 2010-11-20 17:45:30.000000000 +0100
@@ -1,10 +1,8 @@
recursive-include doc *.txt
recursive-include tests *.py
include MANIFEST.in
-include MANIFEST
-include ChangeLog
include HISTORY
-include GPL
+include README
include pymemcompat.h
include metadata.cfg
include site.cfg