libraries/PDCurses: Updated for version 3.9.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Richard Narron 2022-04-09 15:34:12 +07:00 committed by Willy Sudiarto Raharjo
parent c1d257b630
commit bbde7a554f
No known key found for this signature in database
GPG key ID: 3F617144D7238786
6 changed files with 71 additions and 39 deletions

View file

@ -1,28 +0,0 @@
--- x11/Makefile.in.orig 2018-01-26 17:56:15.000000000 -0800
+++ x11/Makefile.in 2018-06-14 13:42:43.989390736 -0700
@@ -13,9 +13,9 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
-libdir = @libdir@
-bindir = @bindir@
-includedir = @includedir@
+libdir = $(DESTDIR)@libdir@
+bindir = $(DESTDIR)@bindir@
+includedir = $(DESTDIR)@includedir@
PDCURSES_CONFIG_H =$(osdir)/config.h
PDCURSES_CURSES_H =$(PDCURSES_SRCDIR)/curses.h
@@ -62,8 +62,12 @@
$(INSTALL) -d -m 755 $(includedir)
$(INSTALL) -d -m 755 $(includedir)/xcurses
$(INSTALL) -c -m 644 $(PDCURSES_CURSES_H) \
+ $(includedir)/xcurses.h
+ $(INSTALL) -c -m 644 $(PDCURSES_CURSES_H) \
$(includedir)/xcurses/curses.h
$(INSTALL) -c -m 644 $(PDCURSES_SRCDIR)/panel.h \
+ $(includedir)/xpanel.h
+ $(INSTALL) -c -m 644 $(PDCURSES_SRCDIR)/panel.h \
$(includedir)/xcurses/panel.h
$(INSTALL) -c -m 644 $(PDCURSES_SRCDIR)/term.h \
$(includedir)/xcurses/term.h

View file

@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PDCurses
VERSION=${VERSION:-3.8}
BUILD=${BUILD:-2}
VERSION=${VERSION:-3.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@ -73,7 +70,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
cat $CWD/PDCurses-3.6-makefile-in.patch | patch -b -p0
patch -b -p1 < $CWD/x11-makefile-in.patch
patch -b -p1 < $CWD/x11-xcurses-config-in.patch
chown -R root:root .
find -L . \
@ -104,9 +102,19 @@ cd $TMP/$PRGNAM-$VERSION
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# For the Hessling editor (THE) package build, create pkg-config meta-information
# (Note that a /usr/bin/xcurses-config script is also created by this SlackBuild)
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
cp $CWD/libpdcurses-x11.pc $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
sed -i -e "s/LIBDIR/lib${LIBDIRSUFFIX}/" \
-e "s/VERSION/${VERSION}/" \
$PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/libpdcurses-x11.pc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a man/HISTORY.md man/IMPLEMNT.md man/MANUAL.md man/README.md man/USERS.md \
cp -a README.md docs/HISTORY.md docs/IMPLEMNT.md docs/MANUAL.md docs/USERS.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/README.md \
$PKG/usr/doc/$PRGNAM-$VERSION/README-docs.md
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/lib*/*.la

View file

@ -1,8 +1,8 @@
PRGNAM="PDCurses"
VERSION="3.8"
HOMEPAGE="http://pdcurses.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/project/pdcurses/pdcurses/3.8/PDCurses-3.8.tar.gz"
MD5SUM="0147936a2510617486ba3f5658b9bfa6"
VERSION="3.9"
HOMEPAGE="http://pdcurses.org"
DOWNLOAD="https://github.com/wmcbrine/PDCurses/archive/3.9/PDCurses-3.9.tar.gz"
MD5SUM="c6e81fe56e127ae9af6a6d9082f9eca7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View file

@ -0,0 +1,14 @@
prefix=/usr
exec_prefix=${prefix}
libdir=${prefix}/LIBDIR
includedir=${prefix}/include/xcurses
version=VERSION
Name: PDCurses
Description: PDCurses ${version} X11 library
Version: ${version}
URL: https://pdcurses.org
Requires.private:
Libs: -l:libXCurses.a -lXaw -lXmu -lXt -lX11 -lXpm -lSM -lICE -lXext
Libs.private:
Cflags: -DXCURSES -I${includedir} -I/usr/include/X11

View file

@ -0,0 +1,15 @@
--- PDCursesMod-4.3.2a/x11/Makefile.in.orig 2022-02-06 08:35:35.000000000 -0800
+++ PDCursesMod-4.3.2a/x11/Makefile.in 2022-04-07 09:18:27.712387150 -0700
@@ -13,9 +13,9 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
-libdir = @libdir@
-bindir = @bindir@
-includedir = @includedir@
+libdir = $(DESTDIR)@libdir@
+bindir = $(DESTDIR)@bindir@
+includedir = $(DESTDIR)@includedir@
PDCURSES_CONFIG_H =$(osdir)/config.h
PDCURSES_CURSES_H =$(PDCURSES_SRCDIR)/curses.h

View file

@ -0,0 +1,23 @@
--- PDCurses-3.9/x11/xcurses-config.in.orig 2019-09-04 13:08:02.000000000 -0700
+++ PDCurses-3.9/x11/xcurses-config.in 2022-04-08 17:06:28.631395983 -0700
@@ -21,9 +21,9 @@
echo " --cflags pre-processor and compiler flags"
echo " [-I$includedir @PDC_WIDE@]"
echo " --libs library linking information"
- echo " [-L$libdir -lXCurses @LDFLAGS@ @MH_EXTRA_LIBS@"
+ echo " [-L$libdir -lXCurses @LDFLAGS@ @MH_EXTRA_LIBS@]"
echo " --libs-static static library linking information (libXCurses only)"
- echo " [$libdir/libXCurses.a @LDFLAGS@ @MH_XLIBS@ @MH_EXTRA_LIBS@"
+ echo " [-l:libXCurses.a @LDFLAGS@ @MH_XLIBS@ @MH_EXTRA_LIBS@]"
echo " --prefix PDCurses install prefix"
echo " [$prefix]"
echo " --version output version information"
@@ -67,7 +67,7 @@
;;
--libs-static)
- echo $libdir/libXCurses.a @LDFLAGS@ @MH_XLIBS@ @MH_EXTRA_LIBS@
+ echo -l:libXCurses.a @LDFLAGS@ @MH_XLIBS@ @MH_EXTRA_LIBS@
;;
*)