mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
system/isomd5sum: Added (MD5 checksums within an ISO9660 image)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
73146b17ea
commit
bb381bab72
5 changed files with 130 additions and 0 deletions
8
system/isomd5sum/README
Normal file
8
system/isomd5sum/README
Normal file
|
@ -0,0 +1,8 @@
|
|||
isomd5sum provides a way of making use of the ISO9660 application data
|
||||
area to store md5sum data about the iso. This allows you to check the
|
||||
iso given nothing more than the iso itself.
|
||||
|
||||
A checksum is implanted in an image using the implantisomd5 utility,
|
||||
and the corresponding checkisomd5 utility can be used to verify burned
|
||||
CDs are error-free. Also included is a Python extension for performing
|
||||
these tasks.
|
19
system/isomd5sum/fix_makefile.diff
Normal file
19
system/isomd5sum/fix_makefile.diff
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff -Naur isomd5sum-1.0.7/Makefile isomd5sum-1.0.7.patched//Makefile
|
||||
--- isomd5sum-1.0.7/Makefile 2011-04-08 04:43:01.000000000 -0400
|
||||
+++ isomd5sum-1.0.7.patched//Makefile 2011-07-15 01:43:55.000000000 -0400
|
||||
@@ -29,9 +29,13 @@
|
||||
checkisomd5: checkisomd5.o libcheckisomd5.a
|
||||
$(CC) -lpopt $(CFLAGS) checkisomd5.o libcheckisomd5.a -o checkisomd5
|
||||
|
||||
-libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o md5.o)
|
||||
+libimplantisomd5.a: libimplantisomd5.o md5.o
|
||||
+ ar rc libimplantisomd5.a libimplantisomd5.o md5.o
|
||||
+ ranlib libimplantisomd5.a
|
||||
|
||||
-libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o md5.o)
|
||||
+libcheckisomd5.a: libcheckisomd5.o md5.o
|
||||
+ ar rc libcheckisomd5.a libcheckisomd5.o md5.o
|
||||
+ ranlib libcheckisomd5.a
|
||||
|
||||
pyisomd5sum.so: $(PYOBJS)
|
||||
$(CC) -shared -g -o pyisomd5sum.so -fpic $(PYOBJS) $(LDFLAGS)
|
74
system/isomd5sum/isomd5sum.SlackBuild
Normal file
74
system/isomd5sum/isomd5sum.SlackBuild
Normal file
|
@ -0,0 +1,74 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for isomd5sum
|
||||
|
||||
# Written by B. Watson (yalhcru@gmail.com)
|
||||
|
||||
PRGNAM=isomd5sum
|
||||
VERSION=${VERSION:-1.0.7}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
# The Makefile is smart enough to use lib or lib64 as appropriate,
|
||||
# no LIBDIRSUFFIX needed here.
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/fix_makefile.diff
|
||||
|
||||
sed -i 's,/usr/share/man,/usr/man,' Makefile
|
||||
|
||||
make RPM_OPT_FLAGS="$SLKCFLAGS"
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README COPYING testpyisomd5sum.py $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
system/isomd5sum/isomd5sum.info
Normal file
10
system/isomd5sum/isomd5sum.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="isomd5sum"
|
||||
VERSION="1.0.7"
|
||||
HOMEPAGE="http://www.finnie.org/software/isomd5sum/"
|
||||
DOWNLOAD="https://fedorahosted.org/releases/i/s/isomd5sum/isomd5sum-1.0.7.tar.bz2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM="370c8ae799c15dd6f453aed269112c59"
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="B. Watson"
|
||||
EMAIL="yalhcru@gmail.com"
|
||||
APPROVED="Niels Horn"
|
19
system/isomd5sum/slack-desc
Normal file
19
system/isomd5sum/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
isomd5sum: isomd5sum (MD5 checksums within an ISO9660 image)
|
||||
isomd5sum:
|
||||
isomd5sum: isomd5sum provides a way of making use of the ISO9660 application
|
||||
isomd5sum: data area to store md5sum data about the iso. This allows you to
|
||||
isomd5sum: check the iso given nothing more than the iso itself.
|
||||
isomd5sum:
|
||||
isomd5sum: A checksum is implanted in an image using the implantisomd5 utility,
|
||||
isomd5sum: and the corresponding checkisomd5 utility can be used to verify burned
|
||||
isomd5sum: CDs are error-free. Also included is a Python extension for performing
|
||||
isomd5sum: these tasks.
|
||||
isomd5sum:
|
Loading…
Reference in a new issue