mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
network/pyzor: Updated for version 0.8.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
84aec5875d
commit
bb380fcdc0
3 changed files with 14 additions and 27 deletions
|
@ -1,8 +0,0 @@
|
|||
--- pyzor-0.5.0.orig/scripts/pyzor 2009-04-29 17:53:50.000000000 -0300
|
||||
+++ pyzor-0.5.0/scripts/pyzor 2012-11-30 19:42:39.601001128 -0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/python
|
||||
+#!/usr/bin/python -Wignore::DeprecationWarning
|
||||
|
||||
import os
|
||||
# set umask
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for pyzor
|
||||
|
||||
# Copyright 2009-2013 LukenShiro <lukenshiro@ngi.it>
|
||||
# Copyright 2009-2014 LukenShiro, Italy
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -25,8 +25,8 @@
|
|||
# Thanks to Carlos Xavier for a patch with better compatibility against Python 2.7
|
||||
|
||||
PRGNAM=pyzor
|
||||
VERSION=${VERSION:-0.5.0}
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=${VERSION:-0.8.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -42,8 +42,7 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
# docs/usage.html directly installed
|
||||
DOCFILES="COPYING INSTALL NEWS PKG-INFO README THANKS UPGRADING"
|
||||
DOCFILES="COPYING INSTALL PKG-INFO README.rst THANKS requirements.txt config/"
|
||||
|
||||
set -e
|
||||
|
||||
|
@ -55,21 +54,17 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/better-py27-compat.patch
|
||||
# better py27 compatibility
|
||||
sed -s "s|/usr/bin/env python|/usr/bin/python -Wignore::DeprecationWarning|g" \
|
||||
scripts/pyzor*
|
||||
|
||||
# Avoid /usr/share/doc html file's installation
|
||||
sed -r -i "s|share/doc/pyzor|doc/pyzor-$VERSION|g" setup.py
|
||||
python setup.py install --prefix=/usr --root=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/man/man1
|
||||
cp -a docs/pyzor*.1 $PKG/usr/man/man1
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \; 2>/dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="pyzor"
|
||||
VERSION="0.5.0"
|
||||
HOMEPAGE="http://pyzor.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pyzor/pyzor-0.5.0.tar.gz"
|
||||
MD5SUM="d752c1d34132a15bda7767306553911e"
|
||||
VERSION="0.8.0"
|
||||
HOMEPAGE="http://www.pyzor.org"
|
||||
DOWNLOAD="https://pypi.python.org/packages/source/p/pyzor/pyzor-0.8.0.tar.gz"
|
||||
MD5SUM="88a4c48fcc085f26f20e5f35bc48011f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue