mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
games/bsnes: Updated for version 0.072.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
parent
11a6839df4
commit
ba11325e95
3 changed files with 155 additions and 14 deletions
128
games/bsnes/bsnes-0.072-makefile.patch
Normal file
128
games/bsnes/bsnes-0.072-makefile.patch
Normal file
|
@ -0,0 +1,128 @@
|
|||
diff --git a/snesfilter/Makefile b/snesfilter/Makefile
|
||||
index 089b86e..08ba81b 100755
|
||||
--- a/../snesfilter/Makefile
|
||||
+++ b/../snesfilter/Makefile
|
||||
@@ -5,12 +5,12 @@ include nall/qt/Makefile
|
||||
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -O3 -I. -Iobj -fomit-frame-pointer $(qtinc)
|
||||
+flags := $(CXXFLAGS) -I. -Iobj -fomit-frame-pointer $(qtinc)
|
||||
link :=
|
||||
|
||||
ifeq ($(platform),x)
|
||||
flags := -fPIC -fopenmp $(flags)
|
||||
- link += -s -fopenmp -lpthread -lgomp
|
||||
+ link += -fopenmp -lpthread -lgomp
|
||||
else ifeq ($(platform),osx)
|
||||
flags := -fPIC -fopenmp $(flags)
|
||||
link += -fopenmp -lpthread -lgomp
|
||||
@@ -73,9 +73,8 @@ endif
|
||||
|
||||
install:
|
||||
ifeq ($(platform),x)
|
||||
- install -D -m 755 libsnesfilter.a $(DESTDIR)$(prefix)/lib
|
||||
- install -D -m 755 libsnesfilter.so $(DESTDIR)$(prefix)/lib
|
||||
- ldconfig -n $(DESTDIR)$(prefix)/lib
|
||||
+ install -D -m 755 libsnesfilter.a $(DESTDIR)$(prefix)/lib/libsnesfilter.a
|
||||
+ install -D -m 755 libsnesfilter.so $(DESTDIR)$(prefix)/lib/libsnesfilter.so
|
||||
else ifeq ($(platform),osx)
|
||||
cp libsnesfilter.dylib /usr/local/lib/libsnesfilter.dylib
|
||||
endif
|
||||
diff --git a/snesreader/Makefile b/snesreader/Makefile
|
||||
index 761317b..868a0cc 100755
|
||||
--- a/../snesreader/Makefile
|
||||
+++ b/../snesreader/Makefile
|
||||
@@ -5,12 +5,11 @@ include nall/qt/Makefile
|
||||
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -O3 -I. -Iobj -fomit-frame-pointer
|
||||
+flags := $(CXXFLAGS) -I. -Iobj -fomit-frame-pointer
|
||||
link :=
|
||||
|
||||
ifeq ($(platform),x)
|
||||
flags := -fPIC $(flags)
|
||||
- link += -s
|
||||
else ifeq ($(platform),osx)
|
||||
flags := -fPIC $(flags)
|
||||
endif
|
||||
@@ -171,9 +170,8 @@ endif
|
||||
|
||||
install:
|
||||
ifeq ($(platform),x)
|
||||
- install -D -m 755 libsnesreader.a $(DESTDIR)$(prefix)/lib
|
||||
- install -D -m 755 libsnesreader.so $(DESTDIR)$(prefix)/lib
|
||||
- ldconfig -n $(DESTDIR)$(prefix)/lib
|
||||
+ install -D -m 755 libsnesreader.a $(DESTDIR)$(prefix)/lib/libsnesreader.a
|
||||
+ install -D -m 755 libsnesreader.so $(DESTDIR)$(prefix)/lib/libsnesreader.so
|
||||
else ifeq ($(platform),osx)
|
||||
cp libsnesreader.dylib /usr/local/lib/libsnesreader.dylib
|
||||
endif
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index c3c1fe9..4b5de6d 100755
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -4,7 +4,7 @@ ui := qt
|
||||
# compiler
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -O3 -fomit-frame-pointer -I. -I$(snes)
|
||||
+flags := $(CXXFLAGS) -fomit-frame-pointer -I. -I$(snes)
|
||||
link :=
|
||||
objects :=
|
||||
|
||||
@@ -17,7 +17,7 @@ objects :=
|
||||
|
||||
# platform
|
||||
ifeq ($(platform),x)
|
||||
- link += -s -ldl -lX11 -lXext
|
||||
+ link += -ldl -lX11 -lXext
|
||||
else ifeq ($(platform),osx)
|
||||
else ifeq ($(platform),win)
|
||||
link += -mwindows -mthreads
|
||||
@@ -60,11 +60,8 @@ endif
|
||||
install:
|
||||
ifeq ($(platform),x)
|
||||
- install -D -m 755 out/bsnes $(DESTDIR)$(prefix)/bin/bsnes
|
||||
+ install -D -m 755 out/bsnes $(DESTDIR)$(prefix)/bin/bsnes-$(profile)
|
||||
install -D -m 644 data/bsnes.png $(DESTDIR)$(prefix)/share/pixmaps/bsnes.png
|
||||
install -D -m 644 data/bsnes.desktop $(DESTDIR)$(prefix)/share/applications/bsnes.desktop
|
||||
- test -d ~/.bsnes || mkdir ~/.bsnes
|
||||
- cp data/cheats.xml ~/.bsnes/cheats.xml
|
||||
- chmod 777 ~/.bsnes ~/.bsnes/cheats.xml
|
||||
endif
|
||||
|
||||
uninstall:
|
||||
diff --git a/supergameboy/Makefile b/supergameboy/Makefile
|
||||
index 60409af..cbef9ac 100755
|
||||
--- a/../supergameboy/Makefile
|
||||
+++ b/../supergameboy/Makefile
|
||||
@@ -2,14 +2,13 @@ include nall/Makefile
|
||||
|
||||
c := $(compiler) -std=gnu99
|
||||
cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
|
||||
-flags := -O3 -fomit-frame-pointer -I. -Icommon -Ilibgambatte/include -Ilibgambatte/src
|
||||
+flags := $(CXXFLAGS) -fomit-frame-pointer -I. -Icommon -Ilibgambatte/include -Ilibgambatte/src
|
||||
link :=
|
||||
|
||||
ifeq ($(platform),osx)
|
||||
flags := -fPIC $(flags)
|
||||
else ifeq ($(platform),x)
|
||||
flags := -fPIC $(flags)
|
||||
- link += -s
|
||||
endif
|
||||
|
||||
objects := supergameboy
|
||||
@@ -113,9 +112,8 @@ install:
|
||||
ifeq ($(platform),osx)
|
||||
cp libsupergameboy.dylib /usr/local/lib/libsupergameboy.dylib
|
||||
else
|
||||
- install -D -m 755 libsupergameboy.a $(DESTDIR)$(prefix)/lib
|
||||
- install -D -m 755 libsupergameboy.so $(DESTDIR)$(prefix)/lib
|
||||
- ldconfig -n $(DESTDIR)$(prefix)/lib
|
||||
+ install -D -m 755 libsupergameboy.a $(DESTDIR)$(prefix)/lib/libsupergameboy.a
|
||||
+ install -D -m 755 libsupergameboy.so $(DESTDIR)$(prefix)/lib/libsupergameboy.so
|
||||
endif
|
||||
|
||||
clean:
|
|
@ -5,7 +5,7 @@
|
|||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=bsnes
|
||||
VERSION=${VERSION:-0.068}
|
||||
VERSION=${VERSION:-0.072}
|
||||
SRCVER=${VERSION:2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -57,7 +57,7 @@ find . \
|
|||
cd $PRGNAM
|
||||
|
||||
# Patch makefile so SLKCFLAGS and LIBDIRSUFFIX are recognized.
|
||||
cat $CWD/bsnes-0.068-makefile.patch \
|
||||
cat $CWD/bsnes-0.072-makefile.patch \
|
||||
| sed -e "/^\+/s|/lib/|/lib${LIBDIRSUFFIX}/|g" \
|
||||
| patch -p1
|
||||
|
||||
|
@ -66,15 +66,27 @@ cat $CWD/bsnes-0.068-makefile.patch \
|
|||
sed -i \
|
||||
-e 's|audio.pulseaudio ||' \
|
||||
-e 's|audio.pulseaudiosimple ||' \
|
||||
-e '/pulse/d' qt/Makefile
|
||||
-e '/pulse/d' ui-qt/Makefile
|
||||
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
make \
|
||||
platform=x \
|
||||
compiler=gcc \
|
||||
prefix=/usr
|
||||
for profile in compatibility performance accuracy; do
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
make \
|
||||
platform=x \
|
||||
compiler=gcc \
|
||||
prefix=/usr \
|
||||
ui=ui-qt \
|
||||
profile=$profile
|
||||
|
||||
make install DESTDIR=$PKG prefix=/usr
|
||||
make install DESTDIR=$PKG prefix=/usr profile=$profile
|
||||
make clean
|
||||
done
|
||||
|
||||
# Install the launcher
|
||||
cd launcher
|
||||
sed -i -e '/^clear/d' -e "s|-O3|$SLKCFLAGS|" cc.sh
|
||||
./cc.sh
|
||||
install -m 0755 ../out/bsnes $PKG/usr/bin/bsnes
|
||||
cd ..
|
||||
|
||||
# Install plugins.
|
||||
for i in snesfilter snesreader supergameboy; do
|
||||
|
@ -86,6 +98,7 @@ for i in snesfilter snesreader supergameboy; do
|
|||
prefix=/usr
|
||||
|
||||
make install DESTDIR=$PKG prefix=/usr
|
||||
( cd $PKG/usr/lib${LIBDIRSUFFIX} ; ln -s lib${i}.so lib${i}.so.1 )
|
||||
cd -
|
||||
done
|
||||
|
||||
|
@ -93,7 +106,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ui-qt/data/*.html $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="bsnes"
|
||||
VERSION="0.068"
|
||||
VERSION="0.072"
|
||||
HOMEPAGE="http://byuu.org/bsnes/"
|
||||
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v068.tar.bz2"
|
||||
MD5SUM="9ff2f6dc64f54f0da538cefade64b3a7"
|
||||
DOWNLOAD="http://bsnes.googlecode.com/files/bsnes_v072.tar.bz2"
|
||||
MD5SUM="dcbd0f2a88682fb25d409a8276576983"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="dsomero"
|
||||
APPROVED="Erik Hanson"
|
||||
|
|
Loading…
Reference in a new issue