mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
office/kchmviewer: Cleaned up patch and updated copyright.
Signed-off-by: Michiel van Wessem <michiel@slackbuilds.org>
This commit is contained in:
parent
6b7ae339c3
commit
b8c3529b4c
2 changed files with 8 additions and 23 deletions
|
@ -1,7 +1,7 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
#
|
#
|
||||||
# SlackBuild script for KchmViewer.
|
# SlackBuild script for KchmViewer.
|
||||||
# Copyright 2007-2010 Michiel van Wessem, Manchester, United Kingdom
|
# Copyright 2007-2011 Michiel van Wessem, Manchester, United Kingdom
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use in source and binary forms, with or without
|
# Redistribution and use in source and binary forms, with or without
|
||||||
|
@ -72,7 +72,7 @@ find . \
|
||||||
|
|
||||||
# Apply a patch added patch for using the version of kio_msits.so provided
|
# Apply a patch added patch for using the version of kio_msits.so provided
|
||||||
# by kdegraphics (by disabling it to build here).
|
# by kdegraphics (by disabling it to build here).
|
||||||
patch -p0 < $CWD/kchmviewer_no_msits.patch
|
patch -p1 < $CWD/kchmviewer_no_msits.patch
|
||||||
|
|
||||||
cmake \
|
cmake \
|
||||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||||
|
|
|
@ -1,28 +1,13 @@
|
||||||
diff -Naur /tmp/SBo/kchmviewer-5.3-orig//CMakeLists.txt /tmp/SBo/kchmviewer-5.3/CMakeLists.txt
|
diff -Naur kchmviewer-5.3/CMakeLists.txt kchmviewer-5.3_patched/CMakeLists.txt
|
||||||
--- /tmp/SBo/kchmviewer-5.3-orig//CMakeLists.txt 2009-12-15 06:02:57.000000000 +0000
|
--- kchmviewer-5.3/CMakeLists.txt 2009-12-15 06:02:57.000000000 +0000
|
||||||
+++ /tmp/SBo/kchmviewer-5.3/CMakeLists.txt 2011-03-04 22:23:38.347963065 +0000
|
+++ kchmviewer-5.3_patched/CMakeLists.txt 2011-03-31 02:02:00.936125068 +0000
|
||||||
@@ -18,7 +18,7 @@
|
@@ -18,7 +18,8 @@
|
||||||
|
|
||||||
# Run in those subdirectories
|
# Run in those subdirectories
|
||||||
ADD_SUBDIRECTORY( lib/libchmfile )
|
ADD_SUBDIRECTORY( lib/libchmfile )
|
||||||
-ADD_SUBDIRECTORY( lib/kio-msits )
|
-ADD_SUBDIRECTORY( lib/kio-msits )
|
||||||
+#ADD_SUBDIRECTORY( lib/kio-msits )
|
+# Disable use of kio-msits so it uses KDE's own.
|
||||||
|
+#ADD_SUBDIRECTORY( lib/kio-msits )
|
||||||
ADD_SUBDIRECTORY( src )
|
ADD_SUBDIRECTORY( src )
|
||||||
ADD_SUBDIRECTORY( po )
|
ADD_SUBDIRECTORY( po )
|
||||||
ADD_SUBDIRECTORY( packages )
|
ADD_SUBDIRECTORY( packages )
|
||||||
diff -Naur /tmp/SBo/kchmviewer-5.3-orig//kchmviewer_no_msits.patch /tmp/SBo/kchmviewer-5.3/kchmviewer_no_msits.patch
|
|
||||||
--- /tmp/SBo/kchmviewer-5.3-orig//kchmviewer_no_msits.patch 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ /tmp/SBo/kchmviewer-5.3/kchmviewer_no_msits.patch 2011-03-04 22:27:20.793900840 +0000
|
|
||||||
@@ -0,0 +1,12 @@
|
|
||||||
+diff -Naur /tmp/SBo/kchmviewer-5.3-orig//CMakeLists.txt /tmp/SBo/kchmviewer-5.3/CMakeLists.txt
|
|
||||||
+--- /tmp/SBo/kchmviewer-5.3-orig//CMakeLists.txt 2009-12-15 06:02:57.000000000 +0000
|
|
||||||
++++ /tmp/SBo/kchmviewer-5.3/CMakeLists.txt 2011-03-04 22:23:38.347963065 +0000
|
|
||||||
+@@ -18,7 +18,7 @@
|
|
||||||
+
|
|
||||||
+ # Run in those subdirectories
|
|
||||||
+ ADD_SUBDIRECTORY( lib/libchmfile )
|
|
||||||
+-ADD_SUBDIRECTORY( lib/kio-msits )
|
|
||||||
++#ADD_SUBDIRECTORY( lib/kio-msits )
|
|
||||||
+ ADD_SUBDIRECTORY( src )
|
|
||||||
+ ADD_SUBDIRECTORY( po )
|
|
||||||
+ ADD_SUBDIRECTORY( packages )
|
|
||||||
|
|
Loading…
Reference in a new issue