development/gaphor: Add a patch and a new dependency.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Mikko Värri 2012-09-10 08:17:04 -05:00 committed by Robby Workman
parent 9f7bf98d55
commit b79abf8086
3 changed files with 23 additions and 1 deletions

View file

@ -0,0 +1,19 @@
--- gaphor/services/componentregistry.py.orig 2012-08-08 13:57:32.000000000 +0300
+++ gaphor/services/componentregistry.py 2012-08-08 13:57:57.000000000 +0300
@@ -7,6 +7,7 @@
"""
from zope import interface, component
+from zope.component import registry
from gaphor.core import inject
from gaphor.interfaces import IService, IEventFilter
@@ -27,7 +28,7 @@
pass
def init(self, app):
- self._components = component.registry.Components(
+ self._components = registry.Components(
name='component_registry',
bases=(component.getGlobalSiteManager(),))

View file

@ -55,6 +55,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# A patch from upstream git
patch -p0 <$CWD/fix_zope_component_registry.patch
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION

View file

@ -5,6 +5,6 @@ DOWNLOAD="http://pypi.python.org/packages/source/g/gaphor/gaphor-0.17.1.tar.gz"
MD5SUM="cf7b6e1f752913f19a69c7addcfe00d5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zope.component gaphas"
REQUIRES="etk.docking zope.component gaphas"
MAINTAINER="Mikko Värri"
EMAIL="vmj@linuxbox.fi"