development/mysql-workbench: Add upstream patch.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2022-04-22 00:54:57 +07:00
parent 649f1f0374
commit b6e849d013
No known key found for this signature in database
GPG key ID: 3F617144D7238786
3 changed files with 20 additions and 6 deletions

View file

@ -0,0 +1,12 @@
diff --git a/library/parsers/mysql/MySQLBaseLexer.h b/library/parsers/mysql/MySQLBaseLexer.h
index 1a8b9ac..8bd3d57 100644
--- a/library/parsers/mysql/MySQLBaseLexer.h
+++ b/library/parsers/mysql/MySQLBaseLexer.h
@@ -26,6 +26,7 @@
#include "Lexer.h"
#include "MySQLRecognizerCommon.h"
#include "mysql-recognition-types.h"
+#include <list>
namespace antlr4 {
class PARSERS_PUBLIC_TYPE Lexer;

View file

@ -207,10 +207,12 @@ sed -i "/target_link_libraries/s|\\$|-L$TMP/install-bundle/usr/lib${LIBDIRSUFFIX
# Fix boost 1.73
patch -p1 < $CWD/boost-1.73.0.patch
# Install antlr Java JAR
cp $CWD/antlr-4.9.2-complete.jar $TMP/install-bundle/antlr-4.9.2-complete.jar
patch -Np1 < $CWD/0003-include-list.patch
sed -i 's|4.9.1|4.9.2|' CMakeLists.txt
# Install antlr Java JAR
cp $CWD/antlr-4.9.3-complete.jar $TMP/install-bundle/antlr-4.9.3-complete.jar
sed -i 's|4.9.1|4.9.3|' CMakeLists.txt
mkdir -p wb-build
cd wb-build
@ -227,7 +229,7 @@ cmake \
-DMySQLCppConn_INCLUDE_DIR="$TMP/install-bundle/usr/include/jdbc" \
-DGDAL_INCLUDE_DIR="$TMP/install-bundle/usr/include" \
-DGDAL_LIBRARY="$TMP/install-bundle/usr/lib${LIBDIRSUFFIX}/libgdal.so" \
-DWITH_ANTLR_JAR="$TMP/install-bundle/antlr-4.9.2-complete.jar" \
-DWITH_ANTLR_JAR="$TMP/install-bundle/antlr-4.9.3-complete.jar" \
-DUSE_BUNDLED_MYSQLDUMP=1 \
..

View file

@ -6,13 +6,13 @@ DOWNLOAD="https://cdn.mysql.com//Downloads/MySQLGUITools/mysql-workbench-communi
https://sourceforge.net/projects/boost/files/boost/1.73.0/boost_1_73_0.tar.bz2 \
https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-8.0.28-src.tar.gz \
https://download.osgeo.org/gdal/3.2.2/gdal-3.2.2.tar.xz \
https://www.antlr.org/download/antlr-4.9.2-complete.jar"
https://www.antlr.org/download/antlr-4.9.3-complete.jar"
MD5SUM="7ab04fd8a529b56eb79c3f981b244bd5 \
4f379c05ed9ab5b64bca07cc39e5289a \
9273c8c4576423562bbe84574b07b2bd \
4f4192dfaffc76e792e425be81986482 \
c656be582f7beb528c66486cd1fca7a2 \
9ce7f39d655a723d2a98393765ef0c31"
67bfa5d762f069519a02dccb919676d3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="antlr4 ctemplate proj python2-paramiko vsqlite++ zulu-openjdk8 unixODBC rapidjson"