mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
libraries/opencv: Updated for version 2.4.7.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
333f6708e2
commit
b6c3411e12
3 changed files with 52 additions and 54 deletions
|
@ -1,19 +1,7 @@
|
|||
diff -Nbaur OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake
|
||||
--- OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake 2012-11-05 18:42:32.460958392 +0000
|
||||
+++ OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake 2012-11-05 18:52:43.766689315 +0000
|
||||
@@ -47,7 +47,7 @@
|
||||
|
||||
#need better solution....
|
||||
if(libpath MATCHES "3rdparty")
|
||||
- set(installDir "share/OpenCV/3rdparty/${OPENCV_LIB_INSTALL_PATH}")
|
||||
+ set(installDir "share/opencv/3rdparty/${OPENCV_LIB_INSTALL_PATH}")
|
||||
else()
|
||||
set(installDir "${OPENCV_LIB_INSTALL_PATH}")
|
||||
endif()
|
||||
diff -Nbaur OpenCV-2.4.3.orig/CMakeLists.txt OpenCV-2.4.3/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/CMakeLists.txt 2012-11-05 18:42:32.700956757 +0000
|
||||
+++ OpenCV-2.4.3/CMakeLists.txt 2012-11-05 18:55:42.358787848 +0000
|
||||
@@ -221,9 +221,9 @@
|
||||
diff -Naur opencv-2.4.7.orig/CMakeLists.txt opencv-2.4.7/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/CMakeLists.txt 2013-11-12 10:30:39.179852725 +0100
|
||||
@@ -243,9 +243,9 @@
|
||||
if(ANDROID OR WIN32)
|
||||
set(OPENCV_DOC_INSTALL_PATH doc)
|
||||
elseif(INSTALL_TO_MANGLED_PATHS)
|
||||
|
@ -24,27 +12,40 @@ diff -Nbaur OpenCV-2.4.3.orig/CMakeLists.txt OpenCV-2.4.3/CMakeLists.txt
|
|||
+ set(OPENCV_DOC_INSTALL_PATH share/doc/opencv)
|
||||
endif()
|
||||
|
||||
if(ANDROID)
|
||||
@@ -237,14 +237,14 @@
|
||||
set(LIBRARY_OUTPUT_PATH "${OpenCV_BINARY_DIR}/lib")
|
||||
set(3P_LIBRARY_OUTPUT_PATH "${OpenCV_BINARY_DIR}/3rdparty/lib${LIB_SUFFIX}")
|
||||
set(OPENCV_LIB_INSTALL_PATH lib${LIB_SUFFIX})
|
||||
- set(OPENCV_3P_LIB_INSTALL_PATH share/OpenCV/3rdparty/${OPENCV_LIB_INSTALL_PATH})
|
||||
+ set(OPENCV_3P_LIB_INSTALL_PATH share/opencv/3rdparty/${OPENCV_LIB_INSTALL_PATH})
|
||||
set(OPENCV_INCLUDE_INSTALL_PATH include)
|
||||
if(WIN32)
|
||||
@@ -282,7 +282,7 @@
|
||||
set(OPENCV_3P_LIB_INSTALL_PATH "${OpenCV_INSTALL_BINARIES_PREFIX}staticlib${LIB_SUFFIX}")
|
||||
else()
|
||||
set(OPENCV_LIB_INSTALL_PATH lib${LIB_SUFFIX})
|
||||
- set(OPENCV_3P_LIB_INSTALL_PATH share/OpenCV/3rdparty/${OPENCV_LIB_INSTALL_PATH})
|
||||
+ set(OPENCV_3P_LIB_INSTALL_PATH share/Opencv/3rdparty/${OPENCV_LIB_INSTALL_PATH})
|
||||
endif()
|
||||
set(OPENCV_INCLUDE_INSTALL_PATH "include")
|
||||
|
||||
math(EXPR SIZEOF_VOID_P_BITS "8 * ${CMAKE_SIZEOF_VOID_P}")
|
||||
@@ -290,7 +290,7 @@
|
||||
if(LIB_SUFFIX AND NOT SIZEOF_VOID_P_BITS EQUAL LIB_SUFFIX)
|
||||
set(OPENCV_CONFIG_INSTALL_PATH lib${LIB_SUFFIX}/cmake/opencv)
|
||||
else()
|
||||
- set(OPENCV_CONFIG_INSTALL_PATH share/OpenCV)
|
||||
+ set(OPENCV_CONFIG_INSTALL_PATH share/opencv)
|
||||
+ set(OPENCV_CONFIG_INSTALL_PATH share/Opencv)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
diff -Nbaur OpenCV-2.4.3.orig/data/CMakeLists.txt OpenCV-2.4.3/data/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/data/CMakeLists.txt 2012-11-05 18:42:32.460958392 +0000
|
||||
+++ OpenCV-2.4.3/data/CMakeLists.txt 2012-11-05 18:52:43.816688977 +0000
|
||||
diff -Naur opencv-2.4.7.orig/cmake/OpenCVGenPkgconfig.cmake opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake
|
||||
--- opencv-2.4.7.orig/cmake/OpenCVGenPkgconfig.cmake 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/cmake/OpenCVGenPkgconfig.cmake 2013-11-12 10:25:51.071843495 +0100
|
||||
@@ -46,7 +46,7 @@
|
||||
|
||||
#need better solution....
|
||||
if(libpath MATCHES "3rdparty")
|
||||
- set(installDir "share/OpenCV/3rdparty/${OPENCV_LIB_INSTALL_PATH}")
|
||||
+ set(installDir "share/opencv/3rdparty/${OPENCV_LIB_INSTALL_PATH}")
|
||||
else()
|
||||
set(installDir "${OPENCV_LIB_INSTALL_PATH}")
|
||||
endif()
|
||||
diff -Naur opencv-2.4.7.orig/data/CMakeLists.txt opencv-2.4.7/data/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/data/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/data/CMakeLists.txt 2013-11-12 10:25:51.072843495 +0100
|
||||
@@ -5,6 +5,6 @@
|
||||
install(FILES ${HAAR_CASCADES} DESTINATION sdk/etc/haarcascades COMPONENT main)
|
||||
install(FILES ${LBP_CASCADES} DESTINATION sdk/etc/lbpcascades COMPONENT main)
|
||||
|
@ -54,10 +55,10 @@ diff -Nbaur OpenCV-2.4.3.orig/data/CMakeLists.txt OpenCV-2.4.3/data/CMakeLists.t
|
|||
+ install(FILES ${HAAR_CASCADES} DESTINATION share/opencv/haarcascades COMPONENT main)
|
||||
+ install(FILES ${LBP_CASCADES} DESTINATION share/opencv/lbpcascades COMPONENT main)
|
||||
endif()
|
||||
diff -Nbaur OpenCV-2.4.3.orig/samples/c/CMakeLists.txt OpenCV-2.4.3/samples/c/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/samples/c/CMakeLists.txt 2012-11-05 18:42:32.697623446 +0000
|
||||
+++ OpenCV-2.4.3/samples/c/CMakeLists.txt 2012-11-05 18:52:43.826688906 +0000
|
||||
@@ -54,7 +54,7 @@
|
||||
diff -Naur opencv-2.4.7.orig/samples/c/CMakeLists.txt opencv-2.4.7/samples/c/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/samples/c/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/samples/c/CMakeLists.txt 2013-11-12 10:25:51.072843495 +0100
|
||||
@@ -54,6 +54,6 @@
|
||||
if (INSTALL_C_EXAMPLES AND NOT WIN32)
|
||||
file(GLOB C_SAMPLES *.c *.cpp *.jpg *.png *.data makefile.* build_all.sh *.dsp *.cmd )
|
||||
install(FILES ${C_SAMPLES}
|
||||
|
@ -65,11 +66,10 @@ diff -Nbaur OpenCV-2.4.3.orig/samples/c/CMakeLists.txt OpenCV-2.4.3/samples/c/CM
|
|||
+ DESTINATION share/opencv/samples/c
|
||||
PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
|
||||
endif ()
|
||||
|
||||
diff -Nbaur OpenCV-2.4.3.orig/samples/cpp/CMakeLists.txt OpenCV-2.4.3/samples/cpp/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/samples/cpp/CMakeLists.txt 2012-11-05 18:42:32.677623583 +0000
|
||||
+++ OpenCV-2.4.3/samples/cpp/CMakeLists.txt 2012-11-05 18:52:43.823355598 +0000
|
||||
@@ -64,7 +64,7 @@
|
||||
diff -Naur opencv-2.4.7.orig/samples/cpp/CMakeLists.txt opencv-2.4.7/samples/cpp/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/samples/cpp/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/samples/cpp/CMakeLists.txt 2013-11-12 10:25:51.072843495 +0100
|
||||
@@ -83,6 +83,6 @@
|
||||
if (INSTALL_C_EXAMPLES AND NOT WIN32)
|
||||
file(GLOB C_SAMPLES *.c *.cpp *.jpg *.png *.data makefile.* build_all.sh *.dsp *.cmd )
|
||||
install(FILES ${C_SAMPLES}
|
||||
|
@ -77,11 +77,10 @@ diff -Nbaur OpenCV-2.4.3.orig/samples/cpp/CMakeLists.txt OpenCV-2.4.3/samples/cp
|
|||
+ DESTINATION share/opencv/samples/cpp
|
||||
PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
|
||||
endif()
|
||||
|
||||
diff -Nbaur OpenCV-2.4.3.orig/samples/gpu/CMakeLists.txt OpenCV-2.4.3/samples/gpu/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/samples/gpu/CMakeLists.txt 2012-11-05 18:42:32.670956962 +0000
|
||||
+++ OpenCV-2.4.3/samples/gpu/CMakeLists.txt 2012-11-05 18:52:43.820022288 +0000
|
||||
@@ -64,7 +64,7 @@
|
||||
diff -Naur opencv-2.4.7.orig/samples/gpu/CMakeLists.txt opencv-2.4.7/samples/gpu/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/samples/gpu/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/samples/gpu/CMakeLists.txt 2013-11-12 10:25:51.073843495 +0100
|
||||
@@ -83,6 +83,6 @@
|
||||
if (INSTALL_C_EXAMPLES AND NOT WIN32)
|
||||
file(GLOB install_list *.c *.cpp *.jpg *.png *.data makefile.* build_all.sh *.dsp *.cmd )
|
||||
install(FILES ${install_list}
|
||||
|
@ -89,11 +88,10 @@ diff -Nbaur OpenCV-2.4.3.orig/samples/gpu/CMakeLists.txt OpenCV-2.4.3/samples/gp
|
|||
+ DESTINATION share/opencv/samples/${project}
|
||||
PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
|
||||
endif()
|
||||
|
||||
diff -Nbaur OpenCV-2.4.3.orig/samples/gpu/performance/CMakeLists.txt OpenCV-2.4.3/samples/gpu/performance/CMakeLists.txt
|
||||
--- OpenCV-2.4.3.orig/samples/gpu/performance/CMakeLists.txt 2012-11-05 18:42:32.674290272 +0000
|
||||
+++ OpenCV-2.4.3/samples/gpu/performance/CMakeLists.txt 2012-11-05 18:52:43.823355598 +0000
|
||||
@@ -21,6 +21,6 @@
|
||||
diff -Naur opencv-2.4.7.orig/samples/gpu/performance/CMakeLists.txt opencv-2.4.7/samples/gpu/performance/CMakeLists.txt
|
||||
--- opencv-2.4.7.orig/samples/gpu/performance/CMakeLists.txt 2013-11-06 15:26:39.000000000 +0100
|
||||
+++ opencv-2.4.7/samples/gpu/performance/CMakeLists.txt 2013-11-12 10:25:51.073843495 +0100
|
||||
@@ -29,6 +29,6 @@
|
||||
if(INSTALL_C_EXAMPLES AND NOT WIN32)
|
||||
file(GLOB GPU_FILES performance/*.cpp performance/*.h)
|
||||
install(FILES ${GPU_FILES}
|
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=opencv
|
||||
VERSION=${VERSION:-2.4.5}
|
||||
VERSION=${VERSION:-2.4.7}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -70,7 +70,7 @@ find . \
|
|||
-exec chmod 644 {} \;
|
||||
|
||||
# http://code.opencv.org/issues/2512
|
||||
patch -p1 < $CWD/fsh.patch
|
||||
patch -p1 < $CWD/opencv-2.4.7-fsh.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
@ -95,7 +95,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|||
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README doc/license.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README.md doc/license.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="opencv"
|
||||
VERSION="2.4.5"
|
||||
VERSION="2.4.7"
|
||||
HOMEPAGE="http://opencv.willowgarage.com/wiki/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/opencvlibrary/opencv-2.4.5.tar.gz"
|
||||
MD5SUM="8eac87462c7bec8b89021b723207c623"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/opencvlibrary/opencv-2.4.7.tar.gz"
|
||||
MD5SUM="33a12a8bba6e6dc32c97298c99b083b2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue