mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
academic/tophat: Updated for version 2.1.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
8f0d485ccc
commit
b6456152b1
4 changed files with 9 additions and 51 deletions
|
@ -1,24 +0,0 @@
|
||||||
Description: Resolves build failure with seqan 1.4
|
|
||||||
Bug-Closed: http://bugs.debian.org/733352
|
|
||||||
Author: Manuel Holtgrewe <manuel.holtgrewe@fu-berlin.de>
|
|
||||||
--- a/src/segment_juncs.cpp
|
|
||||||
+++ b/src/segment_juncs.cpp
|
|
||||||
@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
|
|
||||||
typedef map<uint32_t, IntronMotifs> MotifMap;
|
|
||||||
|
|
||||||
MotifMap ims;
|
|
||||||
-
|
|
||||||
- seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
|
||||||
- seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ typedef seqan::ModifiedString<
|
|
||||||
+ seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
|
|
||||||
+ seqan::ModReverse> ConstDnaStringReverseComplement;
|
|
||||||
+ ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
|
||||||
+ ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
|
||||||
+
|
|
||||||
if (talkative)
|
|
||||||
fprintf(stderr, "Collecting potential splice sites in islands\n");
|
|
||||||
|
|
||||||
|
|
|
@ -14,6 +14,6 @@ tophat: high-throughput short read aligner Bowtie, and then analyzes the
|
||||||
tophat: mapping results to identify splice junctions between exons.
|
tophat: mapping results to identify splice junctions between exons.
|
||||||
tophat:
|
tophat:
|
||||||
tophat: Home: http://tophat.cbcb.umd.edu/
|
tophat: Home: http://tophat.cbcb.umd.edu/
|
||||||
tophat: References: /usr/doc/tophat-2.1.0/References
|
tophat: References: /usr/doc/tophat-2.1.1/References
|
||||||
tophat:
|
tophat:
|
||||||
tophat:
|
tophat:
|
||||||
|
|
|
@ -23,7 +23,7 @@
|
||||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
PRGNAM=tophat
|
PRGNAM=tophat
|
||||||
VERSION=${VERSION:-2.1.0}
|
VERSION=${VERSION:-2.1.1}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -62,41 +62,25 @@ cd $TMP
|
||||||
rm -rf $PRGNAM-$VERSION
|
rm -rf $PRGNAM-$VERSION
|
||||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
tar xvf $CWD/seqan-v1.4.2.tar.gz || tar xvf $CWD/seqan-seqan-v1.4.2.tar.gz
|
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
sed -e 's|-gdwarf-2||' \
|
CFLAGS="$SLKCFLAGS" \
|
||||||
-e '/define.*esyscmd/d' \
|
|
||||||
-e 's/svnversion/Unversioned directory/' \
|
|
||||||
-i configure.ac
|
|
||||||
|
|
||||||
sed -e 's|make $(SAMPROG)|make -e $(SAMPROG)|' \
|
|
||||||
-i src/Makefile.am
|
|
||||||
|
|
||||||
# fixes seqan issues, Thanks to ARCH
|
|
||||||
rm -rf src/SeqAn-1.3
|
|
||||||
patch -p1 < $CWD/fix_build_w_seqan1.4.patch
|
|
||||||
sed -e "s|-I./SeqAn-1.3|-I$TMP/$PRGNAM-$VERSION/seqan-seqan-v1.4.2/core/include|" configure.ac
|
|
||||||
|
|
||||||
autoreconf -fi
|
|
||||||
CFLAGS="$SLKCFLAGS -I$TMP/$PRGNAM-$VERSION/seqan-seqan-v1.4.2/core/include" \
|
|
||||||
CXXFLAGS="$SLKCFLAGS" \
|
CXXFLAGS="$SLKCFLAGS" \
|
||||||
./configure \
|
./configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
|
--with-boost-libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||||
--localstatedir=/var \
|
--localstatedir=/var \
|
||||||
--mandir=/usr/man \
|
--mandir=/usr/man \
|
||||||
--build=$ARCH-slackware-linux
|
--build=$ARCH-slackware-linux
|
||||||
|
|
||||||
sed -i 's|-L/usr/lib||' Makefile src/Makefile
|
make
|
||||||
|
|
||||||
make -j1
|
|
||||||
make install DESTDIR=$PKG
|
make install DESTDIR=$PKG
|
||||||
|
|
||||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
|
|
@ -1,10 +1,8 @@
|
||||||
PRGNAM="tophat"
|
PRGNAM="tophat"
|
||||||
VERSION="2.1.0"
|
VERSION="2.1.1"
|
||||||
HOMEPAGE="http://ccb.jhu.edu/software/tophat/"
|
HOMEPAGE="http://ccb.jhu.edu/software/tophat/"
|
||||||
DOWNLOAD="http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.0.tar.gz \
|
DOWNLOAD="http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.1.tar.gz"
|
||||||
https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz"
|
MD5SUM="4b2391de46457ba6b2b7268a9da593e4"
|
||||||
MD5SUM="34afa379b030c6672a31bbe3689745bc \
|
|
||||||
7b0080b01feeb223e054dabef53d6fc5"
|
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES=""
|
REQUIRES=""
|
||||||
|
|
Loading…
Reference in a new issue