mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
system/sysdig: Updated for version 0.11.0
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
This commit is contained in:
parent
62217ef917
commit
b466c46292
3 changed files with 42 additions and 7 deletions
31
system/sysdig/0.11.0-do-not-use-private-jq-api.patch
Normal file
31
system/sysdig/0.11.0-do-not-use-private-jq-api.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
Only in sysdig-0.11.0.fix: build
|
||||
diff -ru sysdig-0.11.0/userspace/libsinsp/json_query.h sysdig-0.11.0.fix/userspace/libsinsp/json_query.h
|
||||
--- sysdig-0.11.0/userspace/libsinsp/json_query.h 2016-07-14 10:11:40.000000000 +0200
|
||||
+++ sysdig-0.11.0.fix/userspace/libsinsp/json_query.h 2016-07-21 21:50:23.582406170 +0200
|
||||
@@ -24,17 +24,9 @@
|
||||
// jq is not C++-friendly
|
||||
extern "C"
|
||||
{
|
||||
- #include "compile.h"
|
||||
#include "jv.h"
|
||||
#include "jq.h"
|
||||
//+++ jq C++ compile fixes
|
||||
- #ifndef NDEBUG
|
||||
- # define NDEBUG
|
||||
- # include "jv_alloc.h"
|
||||
- # undef NDEBUG
|
||||
- #else
|
||||
- # include "jv_alloc.h"
|
||||
- #endif // NDEBUG
|
||||
#ifndef HAVE_MKSTEMP
|
||||
# include <stdlib.h>
|
||||
# include <fcntl.h>
|
||||
@@ -58,8 +50,6 @@
|
||||
}
|
||||
# define HAVE_MKSTEMP
|
||||
#endif // HAVE_MKSTEMP
|
||||
- //--- jq C++ compile fix
|
||||
- #include "util.h"
|
||||
}
|
||||
|
||||
#include <string>
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for sysdig
|
||||
|
||||
# Copyright 2015 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2015-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=sysdig
|
||||
VERSION=${VERSION:-0.6.0}
|
||||
VERSION=${VERSION:-0.11.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -62,7 +62,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz 2>/dev/null || tar xvf $CWD/$VERSION.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -82,6 +82,10 @@ else
|
|||
sed -i '/sysdig-probe-loader/,$d' scripts/CMakeLists.txt
|
||||
fi
|
||||
|
||||
# Fix using jq private headers.
|
||||
# Source: https://github.com/draios/sysdig/issues/626
|
||||
patch -p1 < $CWD/0.11.0-do-not-use-private-jq-api.patch
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
cmake -G "Unix Makefiles" \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="sysdig"
|
||||
VERSION="0.6.0"
|
||||
VERSION="0.11.0"
|
||||
HOMEPAGE="http://www.sysdig.org"
|
||||
DOWNLOAD="https://github.com/draios/sysdig/archive/0.6.0.tar.gz"
|
||||
MD5SUM="ffe978c506eca48445bb1f7ece2c0313"
|
||||
DOWNLOAD="https://github.com/draios/sysdig/archive/0.11.0/sysdig-0.11.0.tar.gz"
|
||||
MD5SUM="19a42220d97d309744077c38934f9f34"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="jsoncpp lua libb64"
|
||||
REQUIRES="jsoncpp lua libb64 jq"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
|
|
Loading…
Reference in a new issue