audio/audacious-cue: Added (Cue Sheet Plugin).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Mario Preksavec 2015-02-09 00:19:17 +07:00 committed by Willy Sudiarto Raharjo
parent 1c7550c1a0
commit b430a1a53f
5 changed files with 147 additions and 0 deletions

View file

@ -0,0 +1,4 @@
audacious-cue (Cue Sheet Plugin used by the Audacious media player)
This plugin adds Cue Sheet support to the Audacious media player that comes
with Slackware stock packages

View file

@ -0,0 +1,106 @@
#!/bin/sh
# Slackware build script for audacious-cue
# Copyright 2012, 2015 Mario Preksavec, Zagreb, HR
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=audacious-cue
VERSION=${VERSION:-3.3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=audacious-plugins
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
ARCHOPTS="--disable-sse2"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
ARCHOPTS="--disable-sse2"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
ARCHOPTS=""
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
ARCHOPTS=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch Makefile to build only cue plugin
patch -p1 <$CWD/patches/enable_only_cue_plugin.diff || exit 1
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--enable-cue \
--program-prefix= \
--program-suffix= \
${ARCHOPTS} \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="audacious-cue"
VERSION="3.3.4"
HOMEPAGE="http://audacious-media-player.org/"
DOWNLOAD="http://distfiles.audacious-media-player.org/audacious-plugins-3.3.4.tar.bz2"
MD5SUM="c7fc344b802557cbbe208c31e5289ef1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libcue"
MAINTAINER="Mario Preksavec"
EMAIL="mario at slackware dot hr"

View file

@ -0,0 +1,8 @@
--- audacious-plugins-3.2.4/Makefile.ORIG 2012-06-30 02:05:33.000000000 +0200
+++ audacious-plugins-3.2.4/Makefile 2012-07-23 21:32:11.750875868 +0200
@@ -1,4 +1,4 @@
-SUBDIRS = src po
+SUBDIRS = src/cue
DISTCLEAN = buildsys.mk config.h config.log config.status extra.mk

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
audacious-cue: audacious-cue (Cue Sheet Plugin used by the Audacious media player)
audacious-cue:
audacious-cue: This plugin adds Cue Sheet support to the Audacious media player that
audacious-cue: comes with Slackware stock packages
audacious-cue:
audacious-cue: Homepage: http://audacious-media-player.org/
audacious-cue:
audacious-cue:
audacious-cue:
audacious-cue:
audacious-cue: