mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
multimedia/vlc: Updated for version 2.2.1.
Thanks to Christoph Willing. Signed-off-by: David Spencer <baildon.research@googlemail.com>
This commit is contained in:
parent
e0e030ddbd
commit
b3e4eced05
5 changed files with 10 additions and 117 deletions
|
@ -1,76 +0,0 @@
|
|||
--- modules/access/rdp.c.orig 2013-06-24 18:00:38.000000000 +0000
|
||||
+++ modules/access/rdp.c 2014-08-14 07:20:03.000000000 +0000
|
||||
@@ -41,6 +41,22 @@
|
||||
#include <freerdp/channels/channels.h>
|
||||
#include <freerdp/gdi/gdi.h>
|
||||
|
||||
+#if !defined(FREERDP_INTERFACE_VERSION)
|
||||
+# include <freerdp/version.h>
|
||||
+#endif
|
||||
+
|
||||
+#if !defined(FREERDP_VERSION_MAJOR) || \
|
||||
+ (defined(FREERDP_VERSION_MAJOR) && !(FREERDP_VERSION_MAJOR >= 1 && FREERDP_VERSION_MINOR >= 1 ))
|
||||
+# define SoftwareGdi sw_gdi
|
||||
+# define Fullscreen fullscreen
|
||||
+# define ServerHostname hostname
|
||||
+# define Username username
|
||||
+# define Password password
|
||||
+# define ServerPort port
|
||||
+# define EncryptionMethods encryption
|
||||
+# define ContextSize context_size
|
||||
+#endif
|
||||
+
|
||||
#include <errno.h>
|
||||
#ifdef HAVE_POLL
|
||||
# include <poll.h>
|
||||
@@ -198,15 +214,15 @@
|
||||
demux_sys_t *p_sys = p_vlccontext->p_demux->p_sys;
|
||||
|
||||
/* Configure connexion */
|
||||
- p_instance->settings->sw_gdi = true; /* render in buffer */
|
||||
- p_instance->settings->fullscreen = true;
|
||||
- p_instance->settings->hostname = strdup( p_sys->psz_hostname );
|
||||
- p_instance->settings->username =
|
||||
+ p_instance->settings->SoftwareGdi = true; /* render in buffer */
|
||||
+ p_instance->settings->Fullscreen = true;
|
||||
+ p_instance->settings->ServerHostname = strdup( p_sys->psz_hostname );
|
||||
+ p_instance->settings->Username =
|
||||
var_InheritString( p_vlccontext->p_demux, CFG_PREFIX "user" );
|
||||
- p_instance->settings->password =
|
||||
+ p_instance->settings->Password =
|
||||
var_InheritString( p_vlccontext->p_demux, CFG_PREFIX "password" );
|
||||
- p_instance->settings->port = p_sys->i_port;
|
||||
- p_instance->settings->encryption =
|
||||
+ p_instance->settings->ServerPort = p_sys->i_port;
|
||||
+ p_instance->settings->EncryptionMethods =
|
||||
var_InheritBool( p_vlccontext->p_demux, CFG_PREFIX "encrypt" );
|
||||
|
||||
return true;
|
||||
@@ -217,9 +233,16 @@
|
||||
vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_instance->context;
|
||||
|
||||
msg_Dbg( p_vlccontext->p_demux, "connected to desktop %dx%d (%d bpp)",
|
||||
+#if (FREERDP_VERSION_MAJOR >= 1 && FREERDP_VERSION_MINOR >= 1 )
|
||||
+ p_instance->settings->DesktopWidth,
|
||||
+ p_instance->settings->DesktopHeight,
|
||||
+ p_instance->settings->ColorDepth
|
||||
+#else
|
||||
p_instance->settings->width,
|
||||
p_instance->settings->height,
|
||||
- p_instance->settings->color_depth );
|
||||
+ p_instance->settings->color_depth
|
||||
+#endif
|
||||
+ );
|
||||
|
||||
p_instance->update->DesktopResize = desktopResizeHandler;
|
||||
p_instance->update->BeginPaint = beginPaintHandler;
|
||||
@@ -415,7 +438,7 @@
|
||||
p_sys->p_instance->Authenticate = authenticateHandler;
|
||||
|
||||
/* Set up context handlers and let it be allocated */
|
||||
- p_sys->p_instance->context_size = sizeof( vlcrdp_context_t );
|
||||
+ p_sys->p_instance->ContextSize = sizeof( vlcrdp_context_t );
|
||||
freerdp_context_new( p_sys->p_instance );
|
||||
|
||||
vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_sys->p_instance->context;
|
||||
diff -Nru vlc-2.1.5/modules/access/rtp/input.c vlc-2.2.0~pre2/modules/access/rtp/input.c
|
|
@ -1,5 +1,5 @@
|
|||
--- modules/access/rdp.c.orig 2015-02-21 11:01:32.145593444 +1000
|
||||
+++ modules/access/rdp.c 2015-02-21 10:34:14.875061312 +1000
|
||||
--- modules/access/rdp.c.orig 2015-04-28 21:38:25.117593997 +1000
|
||||
+++ modules/access/rdp.c 2015-04-28 21:42:40.133609568 +1000
|
||||
@@ -83,7 +83,7 @@
|
||||
set_category( CAT_INPUT )
|
||||
set_subcategory( SUBCAT_INPUT_ACCESS )
|
||||
|
@ -18,22 +18,7 @@
|
|||
p_instance->settings->DesktopWidth,
|
||||
p_instance->settings->DesktopHeight,
|
||||
p_instance->settings->ColorDepth
|
||||
@@ -248,7 +248,13 @@
|
||||
p_instance->update->BeginPaint = beginPaintHandler;
|
||||
p_instance->update->EndPaint = endPaintHandler;
|
||||
|
||||
- gdi_init( p_instance, CLRBUF_16BPP | CLRBUF_24BPP | CLRBUF_32BPP, NULL );
|
||||
+ gdi_init( p_instance,
|
||||
+ CLRBUF_16BPP |
|
||||
+#if defined(FREERDP_VERSION_MAJOR) && defined(FREERDP_VERSION_MINOR) && \
|
||||
+ !(FREERDP_VERSION_MAJOR > 1 || (FREERDP_VERSION_MAJOR == 1 && FREERDP_VERSION_MINOR >= 2))
|
||||
+ CLRBUF_24BPP |
|
||||
+#endif
|
||||
+ CLRBUF_32BPP, NULL );
|
||||
|
||||
desktopResizeHandler( p_instance->context );
|
||||
return true;
|
||||
@@ -422,7 +428,9 @@
|
||||
@@ -428,7 +428,9 @@
|
||||
if ( p_sys->f_fps <= 0 ) p_sys->f_fps = 1.0;
|
||||
p_sys->i_frame_interval = 1000000 / p_sys->f_fps;
|
||||
|
||||
|
@ -43,7 +28,7 @@
|
|||
|
||||
p_sys->p_instance = freerdp_new();
|
||||
if ( !p_sys->p_instance )
|
||||
@@ -498,7 +506,9 @@
|
||||
@@ -504,7 +506,9 @@
|
||||
|
||||
freerdp_disconnect( p_sys->p_instance );
|
||||
freerdp_free( p_sys->p_instance );
|
|
@ -1,13 +0,0 @@
|
|||
--- configure.ac.orig 2015-02-27 06:25:58.000000000 +1000
|
||||
+++ configure.ac 2015-06-02 23:10:53.544894508 +1000
|
||||
@@ -2243,8 +2243,8 @@
|
||||
[ --enable-avcodec libavcodec codec (default enabled)])
|
||||
AS_IF([test "${enable_avcodec}" != "no"], [
|
||||
PKG_CHECK_MODULES(AVCODEC,[libavcodec >= 53.34.0 libavutil >= 51.22.0], [
|
||||
- PKG_CHECK_EXISTS([libavcodec < 56],, [
|
||||
- AC_MSG_ERROR([libavcodec versions 56 and later are not supported yet.])
|
||||
+ PKG_CHECK_EXISTS([libavcodec < 57],, [
|
||||
+ AC_MSG_ERROR([libavcodec versions 57 and later are not supported yet.])
|
||||
])
|
||||
VLC_SAVE_FLAGS
|
||||
CPPFLAGS="${CPPFLAGS} ${AVCODEC_CFLAGS}"
|
|
@ -28,7 +28,7 @@
|
|||
# -----------------------------------------------------------------------------
|
||||
|
||||
PRGNAM=vlc
|
||||
VERSION=${VERSION:-2.1.6}
|
||||
VERSION=${VERSION:-2.2.1}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -86,13 +86,10 @@ unzip -o $CWD/$DECKLINKSDK
|
|||
cp -p Blackmagic\ DeckLink\ SDK\ ${DECKLINK_SDK_VERSION}/Linux/include/* decklink/include/
|
||||
|
||||
patch -p1 < $CWD/patch-vlc-opencv3.diff
|
||||
|
||||
patch -p0 < $CWD/patch-freerdp.diff
|
||||
patch -p0 < $CWD/patch-freerdp_1_2.diff
|
||||
patch -p0 < $CWD/patch-projectM-fontpath.diff
|
||||
|
||||
patch -p0 < $CWD/patch_libavcodec_version.diff
|
||||
patch -p0 < $CWD/patch_vlc_cache_gen.diff
|
||||
patch -p0 < $CWD/patch-freerdp_vlc221.diff
|
||||
|
||||
autoreconf -f
|
||||
|
||||
chown -R root:root .
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
PRGNAM="vlc"
|
||||
VERSION="2.1.6"
|
||||
VERSION="2.2.1"
|
||||
HOMEPAGE="http://www.videolan.org/vlc/"
|
||||
DOWNLOAD="http://download.videolan.org/vlc/2.1.6/vlc-2.1.6.tar.xz \
|
||||
DOWNLOAD="http://download.videolan.org/vlc/2.2.1/vlc-2.2.1.tar.xz \
|
||||
http://software.blackmagicdesign.com/SDK/Blackmagic_DeckLink_SDK_10.1.4.zip"
|
||||
MD5SUM="6de050559fbb1456b35303f04705145d \
|
||||
MD5SUM="42273945758b521c408fabc7fd6d9946 \
|
||||
16fbc2f49dc62fecac15835c538f78d4"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
|
|
Loading…
Reference in a new issue